Liens renvoient vers un Not Found et tableau de bord inaccessible

  • WordPress :5.2
  • Statut : non résolu
11 sujets de 16 à 26 (sur un total de 26)
  • Auteur
    Messages
  • #2261418
    rom92
    Participant
    Initié WordPress
    13 contributions

    Bonjour, je viens de suivre les indications et je me retrouve de nouveau avec une page blanche côté visiteur et un message « Vous n’avez pas accès à cette page » côté admin.

    Un truc bizarre toutefois, quand j’ai édité le fichier htaccess, il était vide !

    #2261449
    Li-An
    Modérateur
    Maître WordPress
    21903 contributions

    Que le htaccess soit vide n’est en soi pas inquiétant puisqu’il n’est généré que lorsque l’on enregistre les permaliens. Mais ce n’est pas normal en effet (cf Super Cache) . Collez-y le code indiqué ici https://codex.wordpress.org/htaccess

    #2261452
    rom92
    Participant
    Initié WordPress
    13 contributions

    Code collé, mais ça ne change rien. Toujours le même souci, page blanche pour le visiteur et mention « Désolé, vous n’avez pas l’autorisation d’accéder à cette page » côté admin

    #2261453
    Li-An
    Modérateur
    Maître WordPress
    21903 contributions

    Les messages d’erreurs sont toujours activés ? C’est quand même étonnant de ne voir aucun message d’erreur et une page blanche. Vous pouvez renvoyer les fichiers de WP par FTP en écrasant ceux existants – vous ne perdrez pas de données sauf si vous utilisez un des thèmes par défaut modifié par vos soins.

     

    #2261455
    rom92
    Participant
    Initié WordPress
    13 contributions

    Non aucun message d’erreur. Ils ont disparu. Et je fais comment pour renvoyer les fichiers de WP ? Je télécharge tout depuis le FTP et je les rebalance dedans ?

    #2261460
    Li-An
    Modérateur
    Maître WordPress
    21903 contributions

    C’est ça. Vous les récupérez ici, vous dézipper et vous renvoyez par FTP. J’ai quand même une question cruciale. Vous avez dit que cela faisait longtemps que vous n’étiez pas passé sur votre site. Depuis quand exactement ? OVH a fait de grands travaux à la rentrée jusqu’à la Toussaint avec beaucoup de dégâts sur les sites et je me demande si vous n’avez pas été impacté.

    #2261471
    rom92
    Participant
    Initié WordPress
    13 contributions

    Houlà, ça fait au moins 6-8 mois que je ne me suis pas connecté. Donc, je peux peut être voir ça avec le service client d’OVH…

    #2261473
    Li-An
    Modérateur
    Maître WordPress
    21903 contributions

    Ça ne changera rien, il n’ont pas de sauvegarde aussi vieille. Si les nouveaux fichiers ne résolvent rien, je pense que la base de données a eu un gros problème. Vous pouvez éventuellement essayer de recréer un nouvel admin via FTP ou la base de données. Il y a eu de nombreuses discussions sur les problèmes OVH à l’époque.

    #2261474
    rom92
    Participant
    Initié WordPress
    13 contributions

    J’ai déjà recréé un nouvel admin et ça n’a rien changé… J’upload les fichiers et je vous tiens au courant. Merci de votre aide

    #2261655
    rom92
    Participant
    Initié WordPress
    13 contributions

    Bonjour, j’ai fait le reupload des fichiers et maintenant j’ai une page blanche avec la mention
    <h1>Error establishing a database connection</h1>
    y compris sur l’URL d’admin. Et je n’ai plus de lien vers ma BDD sur mon admin OVH…

    #2261682
    Li-An
    Modérateur
    Maître WordPress
    21903 contributions

    Bon, vous avez eu un gros problème de base. Il faut contacter OVH pour savoir où a disparu votre base. Vous pouvez faire éventuellement un backup mais il y a quelque chose de pas clair du côté des serveurs OVH.

11 sujets de 16 à 26 (sur un total de 26)
  • Vous devez être connecté pour répondre à ce sujet.