Lien Affiliation Get your guide (Créer un compte)

  • WordPress :6.4
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 23)
  • Auteur
    Messages
  • #2469276
    ineys
    Participant
    Padawan WordPress
    99 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : oceanwp
    • Extensions en place : wp rocket, element or
    • Nom de l’hébergeur : 02 switch
    • Adresse du site : 999vies.net

    Problème(s) rencontré(s) : https://www.999vies.net/que-manger-nord-vietnam/ voici le lien en question 🙂

    J’aimerais  que le lien affilié ajouté ne soit plus barré

    Et que le widget avec ce code s’affiche

    <div data-gyg-href= »https://widget.getyourguide.com/default/city.frame » data-gyg-location-id= »205″ data-gyg-locale-code= »fr-FR » data-gyg-widget= »city » data-gyg-partner-id= »W3IUOS6″></div>

    Or, sur mon site, ce n’est pas du tout le cas 🙂

    Avez-vous des pistes ou idées ?

     

    Bon dimanche depuis la Corée du sud =)

    Inès

    #2469289
    momofr@free.fr
    Modérateur
    Maître WordPress
    6879 contributions

    Salut, ce lien as une classe spécifique (.broken_link, a.broken_link), c’est elle qui met cette ligne barrée (text-decoration: line-through;).

    Cela provient sans doute d’une extension (à vérifier), tu peux passer outre en modifiant cette règle dans les CSS avec ceci :

    .broken_link, a.broken_link {
    text-decoration: none !important;
    }

    #2469395
    ineys
    Participant
    Padawan WordPress
    99 contributions

    Hello merci pour ton aide 🙂

     

    J’ai ajouté le code mais la situation reste inchangée

    Oui peut être une extension ou du code que j’ai ajouté … -)

    #2469396
    momofr@free.fr
    Modérateur
    Maître WordPress
    6879 contributions

    Salut, il faut vider tes caches navigateurs/wordpress.

    #2469399
    ineys
    Participant
    Padawan WordPress
    99 contributions

    Salut !

    Je viens de le faire mais toujours pas

     

    Cache pc et wordpress 🙂

    #2470443
    ineys
    Participant
    Padawan WordPress
    99 contributions

    Est ce que c’est bien l’emplacement ? Ou je dois plutôt l’insérer sur chaque article ?

    Merci,

    Inès

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2470445
    ferman
    Participant
    Maître WordPress
    6934 contributions

    Bonjour,

    Le snippet 30 (à gauche dans votre copie d’écran) n’ a pas sa place dans les CSS personnalisées mais dans functions.php (c’est précisé dans  l’article). Il n’a certainement aucun effet autre qu’empêcher tout ce qui suit (donc le code CSS de @momo.fr) de fonctionner. Il faut le supprimer ou le mettre dans functions.php.

    #2470474
    ineys
    Participant
    Padawan WordPress
    99 contributions

    Bonjour,

    Merci encore pour ton aide et d’avoir décelé cela

    Je l’ai enlevé mais ça n’a rien changé

    J’ai aussi vidé le cache et essayer de réinsérer le lien et le widget

    Je suis en train de discuter aussi avec l’équipe d’Elementor

    #2470480
    ferman
    Participant
    Maître WordPress
    6934 contributions

    Je ne comprends pas pourquoi ce code ne fonctionne pas. Il y a peut-être d’autres erreurs dans les CSS additionnelles. Pouvez-vous mettre en pièce jointe (ou en code) l’ensemble du contenu du cadre CSS personnalisées. En parallèle, pouvez-vous coller/copier dans la fenêtre « js personnalisé » (sous les CSS personnalisées dans votre copie d’écran) le code ci-dessous et regarder si ça résout le problème:

    $=jQuery; $('.elementor-widget-container p a.broken_link').removeClass('broken_link')

    On essaiera quand même de régler le problème avec les CSS mais si on n’y arrive pas (je ne vois pas pourquoi ce ne serait pas possible) il restera toujours le javascript. Mais ce serait un peu comme écraser une mouche avec un marteau-pilon.

    #2470734
    ineys
    Participant
    Padawan WordPress
    99 contributions

    Hello,

     

    Merci Ferman pour ton aide ^^

     

    Voici tout le CSS demandé 🙂
    <div>}</div>
    <div>#mobile-fullscreen #mobile-search input, #mobile-fullscreen #mobile-search .search-text:before{</div>
    <div>font-size:14px!important;</div>
    <div>content: »Saisis ta recherche »;}</div>
    <div></div>
    <div>.nav-content{</div>
    <div>display:none;</div>
    <div>}</div>
    <div>@media screen and (max-width : 428px) {</div>
    <div>.page-header.background-image-page-header .page-header-title {</div>
    <div>!important; line-height: 1.3!important;</div>
    <div>max-width: 25ch;</div>
    <div>padding: 2rem 0;</div>
    <div>}</div>
    <div>@media screen and (max-width : 550px) {</div>
    <div>.background-image-page-header .site-breadcrumbs {</div>
    <div>margin-top: 0;</div>
    <div>top: auto;</div>
    <div>white-space: normal;</div>
    <div>overflow: inherit;</div>
    <div>margin-bottom: 6rem;</div>
    <div>}</div>
    <div>.background-image-page-header .site-breadcrumbs li * {</div>
    <div>font-size: 10px</div>
    <div>}</div>
    <div>}</div>
    <div>.broken_link, a.broken_link {</div>
    <div>text-decoration: none</div>
    <div></div>
    <div>!important;</div>
    <div>}</div>
    <div>$=jQuery; $(‘.elementor-widget-container p a.broken_link’).removeClass(‘broken_link’)</div>

    • Cette réponse a été modifiée le il y a 2 semaines et 1 jour par ineys.
    #2470736
    ineys
    Participant
    Padawan WordPress
    99 contributions

    Je viens d’ajouter la phrase de code et ça n’a rien changé 🙂

    Merci quand même, il doit y avoir un autre soucis

    Merci en tout cas d’essayer de comprendre

    Inès

    #2470744
    ferman
    Participant
    Maître WordPress
    6934 contributions

    C’est pas bien de ne pas bien lire les réponses soigneusement préparées. 🙂

    Je disais donc:

    …pouvez-vous coller/copier dans la fenêtre « js personnalisé » (sous les CSS personnalisées dans votre copie d’écran) le code ci-dessous…

    C’est à dire comme sur la pièce jointe (à droite) mais vous l’avez mis dans les CSS (pj à gauche). Ça ne peut donc pas fonctionner.

    Essayez. Si ça ne marche toujours pas il y aura un dernier truc à essayer et après je jetterai l’éponge.

    D’ailleurs, il serait intéressant de voir l’ensemble de vos CSS personnalisées; il y avait déjà du code PHP que vous avez enlevé, maintenant du javascript que vous allez enlever, et quoi d’autre?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2470774
    ineys
    Participant
    Padawan WordPress
    99 contributions

    Bonjour,

    Merci 🙂

    ça fonctionne… Je vais essayer aussi d’insérer un widget et voir si ça s’affiche

    Désolé de pas suivre les consignes, j’étais un peu ailleurs

    Je reviens dire si ça fonctionne

    Inès

    #2470775
    ineys
    Participant
    Padawan WordPress
    99 contributions

    L’ensemble de mon CSS personnalisée à l’heure actuelle :

    #mobile-fullscreen #mobile-search .search-text{
    font-size:0px!important;
    }
    #mobile-fullscreen #mobile-search input, #mobile-fullscreen #mobile-search .search-text:before{
    font-size:14px!important;
    content:"Saisis ta recherche";}

    .nav-content{
    display:none;
    }
    @media screen and (max-width : 428px) {
    .page-header.background-image-page-header .page-header-title {
    !important; line-height: 1.3!important;
    max-width: 25ch;
    padding: 2rem 0;
    }
    @media screen and (max-width : 550px) {
    .background-image-page-header .site-breadcrumbs {
    margin-top: 0;
    top: auto;
    white-space: normal;
    overflow: inherit;
    margin-bottom: 6rem;
    }
    .background-image-page-header .site-breadcrumbs li * {

    Le JS

    $=jQuery; $('.elementor-widget-container p a.broken_link').removeClass('broken_link')

     

    Maintenant, le soucis, c’est pour le widget. J’imagine qu’il faut un code qui autorise Elementor ?

    Il doit y avoir un élément qui ne marche pas avec Elementor. Je peux aussi faire la liste de mes extensions.

    J’ai essayé de les activer / désactiver. J’ai même enlevé SchedulePress qui faisait tout buguer 🙂

    En pièce jointe, on peut voir que le code (short code) pour insérer le widget ne fonctionne pas

    Première photo : rien ne s’affiche

    Merci et bon dimanche

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2470790
    momofr@free.fr
    Modérateur
    Maître WordPress
    6879 contributions

    Salut, le code mis dans la zone Shortcode doit être un code court de type [moncodecourt] pas du HTML…

15 sujets de 1 à 15 (sur un total de 23)
  • Vous devez être connecté pour répondre à ce sujet.