[Résolu] Les sous-menu sont exposés en clair au lieu de se trouver dans un ascenceur. (Créer un compte)

  • WordPress :4.9
  • Statut : résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #2041276
    Le Kid
    Participant
    Initié WordPress
    15 contributions

    Bonjour,

    Ma configuration WP actuelle :

    • – Version de WordPress : 4.9.1
    • – Version de PHP/MySQL : 5.6.33 / 10.0.31
    • – Thème utilisé : vantage-child
    • – Extensions en place : Akismet Anti-Spam (4.0.2), Erident Custom Login and Dashboard (3.5.5), Forum_wordpress_fr (4.1), Google Analytics for WordPress by MonsterInsights (6.2.6), Gravity Forms (2.2.5), Gravity Forms Toolbar (1.7.0), Lazy Load (0.6.1), MetaSlider (3.6.7), MetaSlider – Pro Add-on Pack (2.7.1), Page Builder by SiteOrigin (2.6.0), PHP Code Widget (2.3), Post Tags and Categories for Pages (1.4.1), Really Simple SSL (2.5.24), SiteOrigin CSS (1.1.5), SiteOrigin Widgets Bundle (1.11.3), TablePress (1.9), TinyMCE Advanced (4.6.7), WooCommerce (3.2.6), WooCommerce Gateways Country Limiter (1.4), WordPress Database Backup (2.3.1), WP-Members (3.1.9.3), WP All Import (3.4.6), Yoast SEO (6.1.1)
    • – Adresse du site : https://www.resimarmo.pt
    • – Nom de l’hébergeur : Apache

    Problème(s) rencontré(s) :

    J’ai un problème dans le menu principal de mon site WordPress en portugais, https://www.monsite.pt. Je ne peux pas déclarer la page « ma page d »accueil » comme page d’accueil de mon site dans « Réglages » –> « Lecture » du tableau de bord de WordPress. Quand je la déclare, cela provoque un conflit avec une page « Inicio » (« accueil » en portugais) que je n’ai pas créée (ou que j’ai peut-être créée il y a plusieurs mois mais je ne m’en souviens plus).  Par quoi cela se manifeste-t-il ? Les sous-menu et sous-sous-menus de la page « ma page d’accueil » sont exposés en clair sur une ligne en dessous de la ligne de menu principal (Alors qu’ils ne devraient apparaître que quand je passe par dessus, avec la souris).

    Comment remédier à ce problème ?

    Quelqu’un aurait peut-être une idée ?

    Merci d’avance pour la réponse.

    Le Kid.

     

    #2041516
    Flobogo
    Modérateur
    Maître WordPress
    20119 contributions

    Bonjour,

    Là, quand on accède à votre site, sur mon écran 21″ il y a 2 lignes de menu. Les items (les éléments) de la 1ère ligne contiennent des sous-menus, voire des sous-sous-menus, qui apparaissent au passage de souris.

    Quel est le problème exactement ? Il faudrait quelques captures d’écran pour nous expliquer.

    #2041843
    Le Kid
    Participant
    Initié WordPress
    15 contributions

    Merci de me répondre si vite et désolé de ne pas être plus explicite, je vais être plus concret.
    La page d’accueil « <b>Inicio</b> » je ne l’ai pas créée (je ne sais pas si c’est une page, un article ou une catégorie).
    Par contre, j’ai bien créé la page « <b>RESIMARMO</b> » (sur mes 13 sites c’est la page d’accueil et tout se passe bien).
    Mon problème est le suivant :
    1) je ne veux plus voir la page (?) « Inicio » dans le menu principal, de plus, je ne la trouve nulle part. Elle n’est pas dans les pages, pas dans les articles, pas dans les catégories, pas dans le constructeur de menu (Apparence –> Menu), elle n’est nulle part ! Et, pourtant, elle bien là, au début du menu principal ! C’est un vrai mystère.
    2) Je veux déclarer « RESIMARMO » comme page d’accueil (dans le Tableau de bord de WordPress –> « <i>Réglage</i><i> »</i> –> « <i>Lecture</i><i> »</i> et dans les « <b>Options de lecture</b> » au niveau de : « <b>La page d’accueil affiche</b> » je veux choisir le bouton radio devant « <b>Une page statique</b> » (choisir ci-dessous) et en dessous je veux sélectionner la page « <b>RESIMARMO</b> ».

    • J’ai accès à tous cela, il n’y a pas de problème mais… (et c’est là que j’ai besoin d’un conseil) quand je fais tous ces réglages cela provoque une suppression de ma page « RESIMARMO » de son emplacement normal.
    • le menu déroulant qui, normalement devrait s’afficher au survol de « RESIMARMO« , est remplacé par une liste en ligne (les uns à côté des autres), en dessous du menu principal.

    Je vais te faire deux copies d’écran (une normale, ou cela se passe bien sur mes autres sites et une autre de ce que je vois sur ce site là)

    Voilà, si tu veux d’autres renseignement, je suis à ta disposition.

    Amicalement.

    Le Kid (un kid de 62 ans, c’est pour cela que je me permet de te tutoyer ).

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2042152
    Flobogo
    Modérateur
    Maître WordPress
    20119 contributions

    OK pour le tutoiement, je vouvoie au départ par « politesse ». (et je suis une « vieille » de 54 ans 😀 )

    Bon, on va essayer de se comprendre :

    sur mes 13 sites c’est la page d’accueil et tout se passe bien

    –> tu veux dire que tu es en multi-sites ? Ou tu veux dire que sur d’autres sites, tu appelles la page d’accueil avec le nom du site ? (ce qui me paraît bizarre, mais bon …)

    je ne la trouve nulle part. Elle n’est pas dans les pages, pas dans les articles, pas dans les catégories, pas dans le constructeur de menu

    –> en effet, un vrai mystère. Et si tu essaies de désactiver toutes tes extensions, ça donne quoi ? Même si ça met le site en vrac, mais pour voir si ça change ce « inicio ». Si tu ne le vois plus, c’est qu’il vient d’une extension, réactive-les une par une.
    Et si ça ne change rien en désactivant toutes les extensions, réactive-les, et teste en changeant de thème. Il faudra peut-être refaire le menu, peut-être que là, tu verras d’où vient ce « Inicio » ? Si tu ne le vois plus, c’est que c’est lié au thème.

    Dans tes copies d’écran, je crois que tu as mis 2 fois la même.

    Essaie déjà les pistes suggérées (désactiver les extensions / désactiver le thème) et on en re-parle.

    #2043554
    Le Kid
    Participant
    Initié WordPress
    15 contributions

    Bonjour Flobogo, merci de t’occuper de mon problème,

    Je ne suis pas en « Multi-site ». Et quand on tape  le nom des sites on tombe obligatoirement sur la page d’accueil (RESIMARMO) du site concerné (resimarmo.it, resimarmo.fr, resimarmo.uk etc… Nous communiquons par le site resimarmo.com qui redirige par simple clic sur le site choisi.

    Effectivement j’aurais dû essayer de désactiver les extensions (j’ai déjà résolu plusieurs problèmes avec cette astuce, mais là, je n’y ai plus pensé) je vais le faire de suite…

    Si cela vient du thème je connais quelqu’un chez le concepteur SiteOrigine qui me trouvera la solution rapidement et je ferais une réponse sur le Forum.

    Si cela ne vient pas du thème on cherchera.

    Amicalement.

    Le Kid.

    En te remerciant encore une fois.

    Amicalement.

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2043703
    Le Kid
    Participant
    Initié WordPress
    15 contributions

    Me revoilà,

    J’ai désactivé tous les plugins, le problème restait identique.

    J’ai changé de thème et j’ai activé Twenty Thirteen de WordPress et là mon menu s’affiche bien. « Inicio » n’apparais plus et le menu déroulant de « RESIMARMO » fonctionne bien.

    C’était donc une question de « Thème« . Je vais envoyer un message à mon interlocuteur privilégié chez SiteOrigin et je reviendrais sur le forum quand le problème sera résolu.

    Merci Flobogo.

    Tes conseils ont été précieux.

    Amicalement.

    Le Kid.

     

    #2044320
    Le Kid
    Participant
    Initié WordPress
    15 contributions

    Voilà. C’est réparé !
    C’était un problème de déclaration de menu dans :
    <b>WP Admin</b> > Apparence > <b>Menus</b> et ouvrir <b>Gérer les emplacements</b>. Ensuite, j’ai défini le menu principal sur <b>Menu 1</b> et j’ai enregistré.
    C’est tout ce qu’il y avait à faire.
    Je l’avais déjà fait, mais j’aurais dû le refaire une seconde fois car c’est à la seconde fois que le thème a accepté le réglage.
    Merci, <b>flobogo</b> pour ton aide.
    Amicalement.

    Le Kid.

    #2044529
    Flobogo
    Modérateur
    Maître WordPress
    20119 contributions

    Super, quelques fois, c’est juste une petite chose qui bloque, et on ne comprend pas trop. 😕

    Merci d’avoir apporté la solution, et d’avoir passé le sujet en « résolu »

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.