Les pages Woocommerce ne s’installent pas

  • Statut : non résolu
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #547304
    Mahony246
    Membre
    Initié WordPress
    12 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 4.1
    – Version de PHP/MySQL :
    – Thème utilisé : Travelify
    – Extensions en place :
    – Nom de l’hebergeur :
    – Adresse du site :

    Problème(s) rencontré(s) :

    Bonjour,
    j’ai installé woocommerce mais les pages Boutique, Cart, Checkout… bref les pages woocommerce ne se sont pas installées.
    J’ai essayé de les activer dans woocommerce/état du système/outils, mais cela n’installe rien.

    Avez-vous déjà rencontré ce problème, quelqu’un peut-il m’aider à activer ces pages ?

    Merci d’avance

    #995221
    mathieu9512
    Participant
    Maître WordPress
    1084 contributions

    dans “woocommerce” -> “état du système”, cherche la partie “Pages WC” pour voir des pages sont déjà configurées

    #995222
    Mahony246
    Membre
    Initié WordPress
    12 contributions

    Voici ce que j’ai :

    Pages WC
    Base Boutique: [?] #5 – /shop
    Panier: [?] #6 – /cart
    Commande: [?] #7 – /checkout
    Mon Compte: [?] #8 – /my-account

    #995223
    Mahony246
    Membre
    Initié WordPress
    12 contributions

    OK c’est bon j’ai résolu mon problème, qui était finalement juste débile : je n’ai aucune idée pourquoi mais mes pages woocommerce étaient bêtement dans la corbeille. Je ne sais pas pourquoi… Mais tout va bien maintenant !

    #995224
    kameleon1er
    Participant
    Initié WordPress
    30 contributions

    Bonjour à tous, j’ai un problème identique. je deviens chèvre :
    Pour ma part, j’ai installer woocommerce sur un WP MU et l’ai activé sur un site du réseau. Tout fonctionnait bien, mais j’ai du déconner au début et suppimer les pages par défaut. Depuis je tente de le recréer. J’ai même, supprimé l’extention, puis l’ai reinstallé et l’ai réactivé sur le eous-site. Mais rien n’y fait, j’ai toujours :

    Pages WC
    Base Boutique: [?] #1499 – /boutique/
    Panier: [?] Page inexistante
    Commande: [?] Page inexistante
    Mon Compte: [?] #49 – /mon-compte/

    J’ai pourtant recréer les 2 pages dites inexistantes avec le shortcode à l’intérieur, mais rien n’y fait.
    Plus fort j’affiche bien la page /panier par exemple en direct en faisant “voir la page” dans l’admin, mais dans “etat du système, si je clique sur le lien “panier” il ne trouve pas la page.

    Si quelqu’un a une idée, c’est sympa.

    Merki

    #995225
    kameleon1er
    Participant
    Initié WordPress
    30 contributions

    Bon… finalement, ayant déjà passé bcp “trop” de temps sur le sujet et sur les forums d’aide, j’ai trouvé une soluce rapide si vs avez un WP MU, site qui déconne > Export XML > Creer un nouveau Site > Site propre > outils > import et il n’y a pus qu’à réactiver WooCommerce et remettre en place les réglages de votre thème.

    Donc, à l’installation de WooCommerce, même si les pages par défaut pourtent un non chelou, ne jamais les supprimer !!!

    Si ça peut aider.

    Merci en tout cas.

    #995226
    kameleon1er
    Participant
    Initié WordPress
    30 contributions

    Bon, alors, même si la solution trouvée et décrite dans ma dernière intervention reste tout à fait juste, j’ai re-réfléchi et suis retouné sur mon ex-site avec les pages ne fonctionnant plus. Et en fait, ça se passe effectivement pour une part dans la gestion des pages, mais également dans la partie : Woocommerce > Paramètres > Commande :
    wp-admin/admin.php?page=wc-settings&tab=checkout&section

    Et là on peut re-affecter les différentes pages nécessaires au processus de commande. Il faut préalablement bien sûr que ces pages aient dans leur description les bon Shortcodess WooCommerce :

    – shows the cart page
    – shows the checkout page
    – shows the order tracking form
    – shows the user account page

    Et boom !! ça remarche 🙂

    J’y ai passé des heures à lire sur les forums french et anglais, nulle part cette soluce.

    Ca peut aider.

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.