Les miniatures se rebellent

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 39)
  • Auteur
    Messages
  • #452936
    imported_BenKenobi
    Membre
    Padawan WordPress
    93 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.2.1
    – Thème utilisé :
    – Plugins en place : Lightbox 2.02 Plugin 0.6.4 beta ; Search Everything 3.1 ; WordPress Database Backup 1.8 ; WP-ContactForm et Askimet
    – Nom de l’hebergeur : Orange Internet Business (ex-Oléane)
    – Adresse du site : Je ne peux pas vous l’indiquer car en développement mais pas besoin pour mon problème….

    Problème(s) rencontré(s) :

    Lorsque je veux uploader une image par l’intermédiaire de l’option de chargement sous l’éditeur de texte, les miniatures ne sont plus créées ou alors elles le sont mais ne s’affichent pas (je les vois sur le FTP mais elles ne s’affichent pas sur le site)…
    J’ai vérifié les droits du dossiers uploads et des sous dossiers, j’ai tout remis en 777 et malgré cela cela ne fonctionne pas mieux. je ne sais pas pas trop quoi faire.
    Quelqu’un a-t-il une idée de la source du problème.

    Merci

    #604512
    bmzoom
    Participant
    Maître WordPress
    941 contributions

    Si c’est lightbox , il y a des versions plus convaincantes que d’autres .

    WP lightbox JS va bien .

    #604510
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    A priori Lightbox n’est pour rien dans ce problème, car même désactivé le souci continue.
    Par contre ce qui est étrange aussi c’est que la partie « chargement » en dessous de l’éditeur de texte, disparait lorsque je clic sur « Envoyer ».

    #604511
    bmzoom
    Participant
    Maître WordPress
    941 contributions

    Attention , wordpress a trop de succès .

    Des codes malicieux peuvent aussi circuler dans les pluging .

    😕

    #604509
    LH
    Membre
    Chevalier WordPress
    372 contributions

    Salut,

    Lorsque je veux uploader une image par l’intermédiaire de l’option de chargement sous l’éditeur de texte, les miniatures ne sont plus créées ou alors elles le sont mais ne s’affichent pas (je les vois sur le FTP mais elles ne s’affichent pas sur le site)…

    Une petite question:
    Est-ce que tu peux afficher les miniatures directement, en entrant leur URLs dans le navigateur ?

    Bon courage.

    #604513
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    LH > J’obtiens ce message si je veux afficher la miniature d’une image :

    Forbidden
    You don’t have permission to access /wp-content/uploads/2007/07/carte_autoroute.thumbnail.gif on this server.

    Par contre les images à leur taille originale s’affichent très bien…

    #604514
    LH
    Membre
    Chevalier WordPress
    372 contributions

    Forbidden
    You don’t have permission to access /wp-content/uploads/2007/07/carte_autoroute.thumbnail.gif on this server.

    Je suppose que tu as enlevé la racine du chemin… sinon, il manque le /home/mon-site-web/wordpress/ avant /wp-content/

    Si les fichiers sont en 777, il faut aussi regarder du côté des fichiers .htaccess, et si rien d’anormal, ensuite les rewrite rules.

    Comme tests à tâtons:
    changer de dossier le fichier /…/wp-content/uploads/2007/07/carte_autoroute.thumbnail.gif
    Le mettre dans:
    /…/wp-content/uploads/2007/
    /…/wp-content/uploads/
    /…/wp-content/
    /…/mon-dossier-test/
    => Vérifier si le problème est présent pour tous les dossiers
    copier aussi le fichier original carte_autoroute.gif dans ces dossiers pour vérifier s’il est toujours accessible.

    C’est un peu lourd, mais ça donnera peut-être des indices ?

    #604515
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Bon j’ai essayé en passant par Image Manager mais cela ne change rien. Pas de miniature non plus et même pas d’image en taille normale donc c’est pire là…

    LH > A priori en mettant dans d’autres dossiers, cela ne va pas mieux..

    J’en perds mon latin là… c’est la première fois que je vois ca…

    A moins que cela ne provienne de l’hébergement…

    #604516
    bmzoom
    Participant
    Maître WordPress
    941 contributions

    Dans wp-options , il reste des traces en tout genre de pluging déinstallé .

    Ne garder dans la base que ce qui sert est impossible .

    Avec les widgets , c’est ce qui va alourdir la BDD un peu plus .

    A mon niveau , je n’ai pas de solution pour nettoyer la base 😕

    #604517
    LH
    Membre
    Chevalier WordPress
    372 contributions

    Ce qui est étrange, c’est que l’image originale est accessible et pas la miniature 😉

    Test-1:
    Est-ce que tu as essayé de renommer le fichier carte_autoroute.gif en carte_autoroute.thumbnail.gif ?
    S’il devient inaccessible, ça veut dire que le problème vient sur le nom du fichier.

    Test-2:
    Est-ce que tu as essayé de renommer le fichier carte_autoroute.thumbnail.gif en toto.gif ?
    S’il devient accessible, ça veut vraiment dire que le problème vient sur le nom du fichier.

    Après, il faut trouver où est la règle qui bloque l’accès 😗
    fichiers .htaccess, rewrite rules, MIME type avec apache ???

    Ca marchait avant et le problème vient d’apparaître ou bien c’est une première installation avec cet hébergeur et ça n’a jamais marché ?

    Pour le moment, j’ai pas trop d’idées… Bonne soirée. 😋

    #604518
    SCN
    Membre
    Chevalier WordPress
    265 contributions

    ca peut parraitre bête mais je me souviens que j’ai eu ce type de probléme, enfin même genre sauf que c’etait avec l’upload, dossier en chmod 777 mais j’avais pas les droits d’ecriture, bizarre en tout cas!

    j’ai reglé ça en changeant le repertoire des uploads, au lieu d’utiliser monsite.com/wp-content/uploads/ essais d’utiliser monsite.com/uploads/

    Bonne chance.

    #604519
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Le changement de répertoire ne change rien non plus… tout cela est étrange quand meme…

    #604520
    SCN
    Membre
    Chevalier WordPress
    265 contributions

    T’as essayé de reinstaller ?

    #604521
    alakhnor
    Participant
    Maître WordPress
    996 contributions

    Tu as résolu ton problème finalement ?

    #604522
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions
    alakhnor wrote:
    Tu as résolu ton problème finalement ?

    Non… :(

15 sujets de 1 à 15 (sur un total de 39)
  • Vous devez être connecté pour répondre à ce sujet.