[Résolu] Les images remplacées par des points d’interrogations dans un carré bleu

  • WordPress :5.2
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 95)
  • Auteur
    Messages
  • #2265132
    Bretagne Mosaik
    Participant
    Chevalier WordPress
    177 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.2
    • Thème utilisé : Evolve version 4.1
    • Extensions en place :
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://regards-mosaik.com

    Problème(s) rencontré(s) :

    Bonjour

    1/ Dans Wp/admi, les « pages » faites en « mode classique », donc avant une des dernières MAJ de WP sont remplacées par un point d’interrogation. (PJ n°1).

    Celles qui ont été faites en prenant les « blocs » apparaissent bien.

     

    2/ Par contre lorsque l’on va sur le site http://regards-mosaik.com j’ai bien toutes les photos de toutes les “pages”, sauf que quand je veux les agrandir, j’obtiens une page blanche avec la phrase : «  Sorry,the parameters you provided were not valid »

    Exemple : http://regards-mosaik.com/le-golfe-2/la-presquile-de-rhuys/le-petit-train-de-la-presquile-de-rhuys/

     

    3/ Toujours sur le site http://regards-mosaik.com les photos qui correspondent aux articles apparaissent dans les 2 premières pages. A partir de la page n°3 on retrouve le point d’interrogation. (PJ n°2). Les photos apparaissent en cliquant sur le lien, mais pas sur la loupe. (PJ n°3)

    Cordialement

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2265276
    C_Lucien
    Modérateur
    Maître WordPress
    4250 contributions

    Bonjour,

    sur votre site, tous les liens ne sont pas en http ou en https, ce qui s’appelle du “contenu mixte”. Il faut unifier toutes les url en https. Ce qui se fait soit par une extension comme celles-ci, soit en modifiant la base de données à l’aide d’un script https://interconnectit.com/products/search-and-replace-for-wordpress-databases/.

    NB : par sécurité, ce script est à supprimer du site après usage.

    #2265280
    Bretagne Mosaik
    Participant
    Chevalier WordPress
    177 contributions

    Bonjour

    Merci pour votre réponse.

    Ce qui veut dire qu’il faut que je passe mon site en https… Une manipulation qui me fait un peu peur… car pas très à l’aise. J’ai déjà perdu 2 fois ce site…

    Et des problèmes avec JetPack la semaine dernière…

    Mais j’ai conscience que c’est indispensable. Je vais donc explorer les pistes que vous me suggéré.

    Par exemple quand vous parlez de modifier la base de données à l’aide du script (en anglais), cela se passe où ? Sur File Zilla ?

    Merci

    #2265281
    Bretagne Mosaik
    Participant
    Chevalier WordPress
    177 contributions

    En suivant vos conseils je suis allé sur le site des extensions, mais laquelle choisir. Si je regarde la première « Really Simple SSL » est ce qu’elle est adaptée ?

    En ce qui concerne le certificat SSL, OVH m’a assuré que pour eux je pouvais passer en https. Mais est ce qu’il faut obtenir un certificat ? Et Comment ?

    #2265686
    Bretagne Mosaik
    Participant
    Chevalier WordPress
    177 contributions

    Bonjour C_Lucien

    Besoin d’un peu d’aide pour ne pas faire de bêtises…

    J’ai donc installé l’extension Really Simple SSL sur mon site

    Puis j’ai fait installer Le certificat SSL Let’s Encrypt sur mon hébergement Chez OVH.

    Ils m’ont envoyé plusieurs ligne de code «  à ajouter au début du fichier .htaccess de votre site (ce fichier doit se trouver dans le dossier “www” sur le serveur d’hébergement) »

    C’est là que je ne sais pas comment faire.

    Je suis allé sur FilZilla, mais je ne sais pas où copier ce code.

    Merci pour vos conseils.

    Cordialement

    #2265744
    Flobogo
    Modérateur
    Maître WordPress
    15786 contributions

    Bonjour,

    Le fichier .htaccess est présent à la racine de votre installation (là où il y a les 3 dossiers wp-admin / wp-content, etc …), visible avec Filezilla.

    Mais si vous ne trouvez pas ou ne savez pas comment faire, l’extension Really Simple SLL devrait se charger de tout : suivez ce tuto

    #2265804
    Bretagne Mosaik
    Participant
    Chevalier WordPress
    177 contributions

    Bonjour

    J’ai bien utilisé Really Simple SLL pour faire le passage en https.

    Je pense que cela s’est bien passé. (Pièce jointe).

    Toutefois le problème original n’a pas été résolu. A savoir que « les photos sont toujours remplacées par des points d’interrogation » à partir de la page 3.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2265808
    ferman
    Participant
    Maître WordPress
    1029 contributions

    Bonjour,

    A quel endroit exactement voyez-vous le problème? Je ne trouve pas. De quelle(s) page(s) 3 s’agit-il?

    #2265810
    Bretagne Mosaik
    Participant
    Chevalier WordPress
    177 contributions

    Lorsque je vais sur mon site, http://regards-mosaik.com sur la première page vous avez les numéros de pages. A partir de la page 3 à la place des photos ce sont des points d’interrogation(Pièce jointe)

    Lorsque je clique sur ces points les photos apparaissent

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2265815
    ferman
    Participant
    Maître WordPress
    1029 contributions

    D’accord. En fait, chez moi, il n’y a pas de rectangle bleu ou de “?”, simplement pas d’image et le lien et la loupe apparaissent seulement au survol de la souris. C’est pour ça que je ne voyais pas. Voir copie d’écran.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2265822
    ferman
    Participant
    Maître WordPress
    1029 contributions

    Il y a un problème avec vos liens: Le zoom de “l’esprit du Magouër” (pas de problème) correspond au lien suivant: href=”https://regards-mosaik.com/wp-content/uploads/2019/03/Lesprit-du-Magouër.jpg” (correct). Si on prend “New-york in Las Vegas (problème) le lien correspond à une autre adresse.  href=”http://bretagne-regards-mosaik.fr/wp-content/uploads/2017/12/New-York-in-Las-Vegas-2.jpg”(incorrect)

    N’auriez-vous pas eu une ancienne version du blog de ce nom? Et dans ce cas toutes les images restées à cette adresse ne sont pas dans le dossier upload de votre site et ne peuvent bien sûr pas être chargées. Vérifiez où sont ces images et mettez-les dans le dossier upload du bon site.

    • Cette réponse a été modifiée le il y a 3 mois et 1 week par  ferman.
    #2265828
    Bretagne Mosaik
    Participant
    Chevalier WordPress
    177 contributions

    Houla… ça se complique car se sont toutes les images qui sont après la page 3 qui apparaissent avec le point d’interrogation et arrivent quand on clique dessus.

    Pour l’adresse Bretagne-regards-mosaik c’est l’ancien nom de domaine que j’ai changé il y a un an chez OVH. Cela n’a pas posé de problème jusqu’à il y a une quinzaine de jours…

    A ce moment j’ai perdu JetPack. Ils m’ont répondu alors :

    “La configuration en cache de notre côté utilisait l’URL HTTPS de votre site même si votre site ne possédait pas de certificat SSL valide.

    Je l’ai mis à jour pour utiliser HTTP à la place et il est maintenant connecté sans aucun problème.”

    Puis quelques jours plus tard :

    “Nous voyons un NET :: ERR_CERT_COMMON_NAME_INVALID dans Google Chrome. Je suppose que l’équipe de support d’OVH devrait voir la même chose lorsqu’elle le teste, car c’est ce que voit Internet.

    Idéalement, ils corrigeraient la configuration SSL, puis redirigeraient votre trafic HTTP vers HTTPS, mais les étapes à suivre pour le faire seront spécifiques à l’hôte. Je repousser sur eux jusqu’à ce qu’ils le fassent bien.

    Je ne sais pas si cela a changé les choses.

    Pour l’ancienne version du blog je ne vois pas où elle peut être. Et comment faire pour y accéder.

    #2265837
    ferman
    Participant
    Maître WordPress
    1029 contributions

    Bon, on va admettre que les images sont bien dans votre dossier upload mais que les liens ne sont pas corrects. Il va falloir les changer dans la base de données. C’est facile. J’utilise le plugin “better search replace” très simple d’emploi. Regardez cette petite vidéo qui vous explique comment ça marche.

    En bref, vous téléchargez le plugin et l’activez. * Dans la case “rechercher ” vous écrirez http://bretagne-regards-mosaik et dans la case remplacer https://regards-mosaik. Vous sélectionnez toutes les tables dans le menu déroulant (maintenez la touche majuscule enfoncée et faites défiler ). Vous faites un essai à blanc (voir vidéo) cela vous dit combien de remplacements peuvent être effectués. Puis vous décochez et faites le remplacement pour de bon. C’est tout. Avec un peu de chance, vos images étaient bien dans le dossier upload et tout est rétabli. Autrement, comme vous dites “houla ça se complique” et il faudra recharger toutes ces images. Mais je parierais que les images sont bien dans le dossier upload. Une fois fait, vous désactivez “better search replace” et vous le supprimez.

    Vous ne devez avoir aucun problème mais ne vous trompez pas en remplissant les champs rechercher et remplacer; les erreurs dans les bases de  données sont difficiles à rattraper.

    Bonne chance.

    A titre de précaution supplémentaire , si vous savez exporter votre base de données faites-le. Autrement en cas de problème (très improbable) il y a les sauvegardes de OVH.

    • J’ai oublié de préciser: Les réglages de “Better Search Replace” se trouvent dans “outils”.
    • Cette réponse a été modifiée le il y a 3 mois et 1 week par  ferman.
    • Cette réponse a été modifiée le il y a 3 mois et 1 week par  ferman.
    #2265861
    ferman
    Participant
    Maître WordPress
    1029 contributions

    Je viens de vérifier votre code source. Vous avez 19 occurrences de http://bretagne-regards-mosaïk.fr et 20 de https://bretagne-regards-mosaïk.fr et vous voulez https://regards-mosaïk.com. Cela signifie que ce que je vous ai donné précédemment ne suffit pas. Il faudra faire deux scans: dans le premier, rechercher  http://bretagne-regards-mosaïk.fr et remplacer par https://regards-mosaïk.com et dans le deuxième rechercher https://bretagne-regards-mosaïk.fr et bien sûr remplacer par https://regards-mosaïk.com.

    Je ne comprends pas comment vous pouvez avoir un tel mélange de liens.

    #2265980
    Bretagne Mosaik
    Participant
    Chevalier WordPress
    177 contributions

    Bonjour

    J’ai effectué les opérations que vous m’avez suggéré hier.

    Pour le 1er Scan j’obtiens 70 tables que je pense avoir remplacé. (pièce jointe)

    cela n’a rien changé pour les photos.

    Pour le 2ème Scan il ne se passe rien. Les tables du Scan précédent restent.

    Une autre constatation sur le site :

    Dans les photos avec point d’interrogation, lorsqu’on clique sur le lien la photo apparait.

    Lorsqu’on clique sur la loupe, l’écran indique “Safari ne parvient pas à trouver le serveur”

    Puis lorsque l’on va sur les pages, (menu déroulant en haut) toutes les photos apparaissent, même les plus anciennes.

15 sujets de 1 à 15 (sur un total de 95)
  • Vous devez être connecté pour répondre à ce sujet.