Les commentaires ne s’affichent plus

  • Statut : non résolu
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #447796
    julient
    Membre
    Initié WordPress
    30 contributions

    Bonjour,

    Je viens de me rendre compte que les commentaires ne sont plus affichés sur mon blog. De même, on ne peut plus en laisser.

    J’ai vérifié, j’ai bien < ?php comments_template(); ?> dans single.php.

    Cela vous est-il déjà arrivé ?

    julien
    http://www.lewebpedagogique.com

    #574777
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    dans single.php ne serait-il pas entre des balises de commentaires :

    #574778
    julient
    Membre
    Initié WordPress
    30 contributions

    Non non, il est comme sur le fichier original.

    Surtout le truc, c’est que ça marchait jusqu’à hier… et il me semble pas avoir de modification sur ce fichier.

    Wordpress serait il doué d’un esprit malin qui fait rien qu’à modifié la nuit ce que j’ai fait le jour ? :-

    #574779
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    As-tu modifié comment.php ?

    #574780
    julient
    Membre
    Initié WordPress
    30 contributions

    J’ai simplement traduit ce qui était en anglais en français.
    Je ne crois pas avoir touché à quelque chose d’autre.

    Cela peut il venir du fait que j’ai modifié l’adresse du blog: il était dans un répertoire et je l’ai mis dans le répertoire racine (copié-collé du répertoire dans le fichier racine, puis modification de l’adresse du blog dans les options) ?

    #574781
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    En tout cas ton template n’est pas affiché, donc tu as dû forcément modifier autre chose…

    #574782
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Essais de remettre le fichier comment.php d’origine. tu seras fixé.

    #574783
    julient
    Membre
    Initié WordPress
    30 contributions

    Ok, j’ai compris ce qui n’allait pas :

    Le blog se trouvait avant dans le répertoire /revision.
    Je l’ai transféré au répertoire racine. J’ai copié collé le répertoire révision dans le répertoire racine et modifié l’adresse de wordpress dans l’onglet option du backoffice.

    Mais il semble que les modifications se fassent encore à partir du répertoire /revision (qui existe toujours sur le serveur). En remplacant le fichier single.php dans ce répertoire, mes commentaires sont revenus.

    Donc le problème est résolu tant que je modifie dans ce répertoire.

    La question maintenant, c’est : comment faire pour finir de transférer complètement wordpress vers le répertoire racine du site ? Je pense qu’il y a une modification à faire vis-à-vis de la base de données et c’est là que je vais commencer à fouiner. Si vous avez une idée, je suis preneur !

    Encore merci !

    julien

    #574784
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Il faut modifier l’adresse du site dans les options générales de WordPress

9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.