L’éditeur par blocs ne fonctionne pas (problème dans la mise en page) (Créer un compte)

  • WordPress :5.3
  • Statut : non résolu
  • Ce sujet contient 6 réponses, 2 participants et a été mis à jour pour la dernière fois par JardinHetres, le il y a 5 mois.
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #2337760
    JardinHetres
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 5.7
    • Thème utilisé : Catch Base Pro
    • Extensions en place : Accelerated Mobile Pages / Akismet Anti-Spam / Broken Link Checker/Catch Import Export/Catch Web Tools/Classic Editor/Contact Form 7/GDPR Cookie Consent/Jetpack par WordPress.com/MonsterInsights – Google Analytics pour WordPress/PHP Compatibility Checker/Really Simple SSL/Redirection/VaultPress/WP phpMyAdmin/Yoast SEO
    • Nom de l’hébergeur : 1&1 ionos
    • Adresse du site : jardindeshetres.fr

    Problème(s) rencontré(s) :

    Bonjour,

    J’ai un problème dans la mise en page de mon éditeur de texte. La nouvelle version Gutenberg n’est pas utilisable en l’état, je suis obligée d’utiliser l’extension Classic Editor pour pouvoir modifier mon site web, mais j’aimerais bien passer à la nouvelle version d’éditeur de blocs. Pour info, le problème reste le même si je change de thème. J’ai également déjà désactivé toutes mes extensions mais le problème restait le même.

    Voici en image le problème : https://jardindeshetres.fr/2597-2

    Merci de votre aide !

    Sarah

     

    #2337890
    Flobogo
    Modérateur
    Maître WordPress
    16256 contributions

    Bonjour,

    Malgré la capture écran, je ne comprends pas vraiment votre problème. Tout dépend des blocs utilisés.Le bloc “titre” ne se gère pas comme le bloc-texte, et le CSS qui lui est appliqué n’est pas le même.

    (pour info, vous n’êtes pas en PHP 5.7 -qui n’existe pas- mais en PHP 7.3, ce qui est très bien)

    #2337905
    JardinHetres
    Participant
    Initié WordPress
    4 contributions

    Bonsoir,

    Merci pour votre réponse.

    En fait dans l’éditeur de ce site la police des blocs “paragraphe” est très grosse et surtout le bloc ne reflète pas la mise en page finale. Donc c’est impossible de réfléchir à la mise en page avec cet éditeur. (voir d’avoir une vision plus globale du texte). De plus dès que j’ouvre Yoast en bas de la page d’édition, la zone d’édition du bloque paragraphe devient encore plus petite, à peine 1 cm. Je gère 2 autres sites avec le nouvel éditeur WP et pas de problème de mise en page autres autres sites. J’aurais du plus centrer la capture écran sur l’image et le texte du paragraphe !

    Pour le 5.7 Il s’agit de la configuration de la base de donnée MySQL, je pensais que c’était la question.

    Voilà, j’espère que c’est plus clair exposé comme ça ?

    Merci pour votre aide !

    #2337909
    Flobogo
    Modérateur
    Maître WordPress
    16256 contributions

    dans l’éditeur de ce site la police des blocs “paragraphe” est très grosse

    Je vous dirais bien que c’est un problème de CSS, mais vous dites qu’en changeant de thème, vous avez toujours ce problème ?

    Même avec un thème par défaut, Twenty -XX ? Et avec vraiment toutes les extensions désactivées ?

    #2337940
    JardinHetres
    Participant
    Initié WordPress
    4 contributions

    Pour les applications, oui. J’ai testé moi-même.

    Pour le thème, je viens d’activer Twenty-XX, et effectivement il semble que ça s’arrange avec changement de thème…

    C’est le support de mon thème actuel qui avait cherché à résoudre ce problème sans rien trouvé qui m’a orienté sur un problème WP en me disant que le changement de thème n’y faisait rien… Je vais donc laisser tomber car s’il n’a pas trouvé la réponse au problème je ne vais pas y arriver non plus ;-). Et comme la solution “classic editor” fonctionne bien, il n’y a pas de blocage dc c’est ok.

    En tout cas merci beaucoup pour votre disponibilité et votre aide, et avoir un support en Français ça change vraiment tout !!!

    Bonne journée,

    Sarah

    #2338057
    Flobogo
    Modérateur
    Maître WordPress
    16256 contributions

    Et vous avez essayé avec Catch Base version gratuite ? Il faudrait quand même signaler à Catch Thèmes que ce thème-là n’est pas compatible WP 5.4.

     

    #2338093
    JardinHetres
    Participant
    Initié WordPress
    4 contributions

    Fait !

    Je lui ai envoyé des imprims écrans pour mettre en avant le problème, et sa résolution a vec le theme WP 2020.

    De mon côté j’ai étudié les options de “classic editor” qui permet de passer facilement de la version classique à “nouvel editor”, et aussi les  “options de l’écran”, qui permettent d’alléger l’espace de travail et d’avoir une meilleure vue d’ensemble, donc avec ça je peux profiter des nouvelles fonctions de Gutenberg, malgré le bug sur la mise en page.

    A suivre !

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.