L’éditeur a rencontré une erreur inattendue (Créer un compte)

  • WordPress :5.8
  • Statut : non résolu
  • Ce sujet contient 12 réponses, 2 participants et a été mis à jour pour la dernière fois par Li-An, le il y a 1 mois.
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2408846
    jeannedarc1
    Participant
    Initié WordPress
    7 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : PHP (7.0.33)
    • Thème utilisé : DIvi
    • Extensions en place :
    • Nom de l’hébergeur : 1&1
    • Adresse du site : http://www.jeannedarc-figeac.fr

    Problème(s) rencontré(s) : Mise à jour WP 6.0 – Erreur éditeur de page – L’éditeur a rencontré une erreur inattendue.

    J’ai voulu mettre à jour WP en version 6.0 et depuis l’éditeur de pages renvoie systématiquement une erreur, sur toutes les pages

    Par contre je peux modifier les articles sans problème !!

    voici le fichier d’erreur sur 1 des pages en exemple :

    TypeError: this._addClass is not a function
    at t.<computed>.<computed>._create (http://www.jeannedarc-figeac.fr/college-lycee/wp-includes/js/jquery/ui/sortable.min.js?ver=1.13.1:9:912)
    at t.<computed>.<computed>._create (http://www.jeannedarc-figeac.fr/college-lycee/wp-content/themes/Jeannedivi/et-pagebuilder/js/jquery-ui-1.10.4.custom.min.js?ver=2.3.1:6:5029)
    at t.<computed>.<computed>._createWidget (http://www.jeannedarc-figeac.fr/college-lycee/wp-content/themes/Jeannedivi/et-pagebuilder/js/jquery-ui-1.10.4.custom.min.js?ver=2.3.1:6:7036)
    at new t.<computed>.<computed> (http://www.jeannedarc-figeac.fr/college-lycee/wp-content/themes/Jeannedivi/et-pagebuilder/js/jquery-ui-1.10.4.custom.min.js?ver=2.3.1:6:4592)
    at HTMLDivElement.<anonymous> (http://www.jeannedarc-figeac.fr/college-lycee/wp-content/themes/Jeannedivi/et-pagebuilder/js/jquery-ui-1.10.4.custom.min.js?ver=2.3.1:6:6309)
    at Function.each (http://www.jeannedarc-figeac.fr/college-lycee/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:3003)
    at s.fn.init.each (http://www.jeannedarc-figeac.fr/college-lycee/wp-includes/js/jquery/jquery.min.js?ver=3.6.0:2:1481)
    at s.fn.init.t.fn.<computed> [as sortable] (http://www.jeannedarc-figeac.fr/college-lycee/wp-content/themes/Jeannedivi/et-pagebuilder/js/jquery-ui-1.10.4.custom.min.js?ver=2.3.1:6:6232)
    at Object.init (http://www.jeannedarc-figeac.fr/college-lycee/wp-admin/js/postbox.min.js?ver=6.0:2:3694)
    at Object.add_postbox_toggles (http://www.jeannedarc-figeac.fr/college-lycee/wp-admin/js/postbox.min.js?ver=6.0:2:2733)

    Que manque-t-il ? que dois-je modifier pour que cela refonctionne ?

    D’avance merci pour vos réponses

     

     

    #2408871
    Li-An
    Modérateur
    Maître WordPress
    26511 contributions

    Bonjour, passez php en 7.4+ déjà pour voir ?

    #2408999
    jeannedarc1
    Participant
    Initié WordPress
    7 contributions

    Je viens d’effectuer l’up vers la 7.4 pour le PHP mais toujours le même problème pour l’éditeur…

    Le problème c’est que je ne peux pas modifier mes pages alors que cela va devenir urgent !! les articles je peux c’est pas un peu bizarre ??

    #2409005
    Li-An
    Modérateur
    Maître WordPress
    26511 contributions

    Bonjour, désactivez les autres extensions, mettez un thème par défaut et testez pour voir. Vous pouvez laisser une extension de maintenance pour ne pas effrayer vos visiteurs et utiliser https://www.echodesplugins.li-an.fr/plugins/widget-importer-exporter/ pour sauvegarder le réglage de vos widgets. Vous pouvez aussi regarder dans Outils>Santé du site s’il n’y a pas un problème important.

    #2409132
    jeannedarc1
    Participant
    Initié WordPress
    7 contributions

    J’ai enlevé toutes les extensions et j’ai toujours le même message…

    Je mets une par une les extensions notamment la classic editor, elegant builder et là j’ai quelque chose mais… les parties ne se réduisent plus et la partie LAyout Builder est vide !!? alors que la partie révision par exemple je ne peux pas la réduire… on dirait que les boutons « flèches » ne fonctionnent pas…

    Un problème connu sous cette WP 6.0 ??

    Est-ce Classic editor qu’il ne faut plus utilisé ?

    Est-ce que je peux mettre elementor par exemple sans que cela me casse tout ?! J’ai essayé mais je ne vois pas de différence…

    Je suis un peu perdu là …

    #2409154
    Li-An
    Modérateur
    Maître WordPress
    26511 contributions

    Vous pouvez renvoyer les fichiers de WP par FTP en écrasant ceux existants – vous ne perdrez pas de données sauf si vous utilisez un des thèmes par défaut modifié par vos soins. Peut-être que la mise à jour s’est mal passée.

    #2409210
    jeannedarc1
    Participant
    Initié WordPress
    7 contributions

    J’ai l’impression que c’est la version de classic editor qui n’est pas du tout compatible avec WP 6.0… le problème c’est que je ne peux pas le désactiver pour prendre un autre éditeur car j’ai systématiquement l’erreur d’éditeur si je désactive « classic editor » !!!

    Est-ce qu’on peut revenir à WP 5.9 ?

    Est-ce que je peux revenir à Gutenberg par exemple ??

    Est-ce que je peux accéder autrement aux modifications des pages en attendant une solution ? éditeur externe ? accès par FTP pour modifier ? ou c’est « bloqué » chez WP ?

    #2409212
    Li-An
    Modérateur
    Maître WordPress
    26511 contributions

    Il n’y a aucun message indiquant un problème avec WP 6.0 pour Classic Editor sur la page officielle. Vous pouvez essayer avec celui-là à la place https://wordpress.org/plugins/disable-gutenberg/ mais je doute que ce soit à ce niveau que le problème existe.

    Vous pouvez aussi via la console de votre hébergeur remettre votre site à un état antérieur à la mise à jour.

    #2409692
    jeannedarc1
    Participant
    Initié WordPress
    7 contributions

    La version de disable gutenberg n’a pas fonctionné non plus !! pas mieux en affichage

    c’est surtout qu’il manque toute la partie « visuel » pour travailler le site…

    J’ai essayé elementor en créant une nouvelle page j’ai le visuel mais dès que je veux insérer un élément => elementor se plante style plus rien n’est cliquable, et après je ne peux rien créer !!?

    Personne d’autres n’a ce problème ??? chouette j’ai l’exclus !!! :((

    On m’a donné une procédure pour revenir en arrière de WP, c’est fiable ?

    Sinon pour les sauvegardes de mon hébergeur… elles sont trop récente du coup j’ai trop attendu et je n’avais que 5 jours :((

    Comment on peut réparer le site ?

    Comment je peux récupérer mon site ?

    Merci

    #2409693
    jeannedarc1
    Participant
    Initié WordPress
    7 contributions

    Est-ce que ceci peut être rédhibitoire ?
    Your Elegant Themes subscription has expired. You must renew your account to regain access to product updates and support. To ensure compatibility and security, it is important to always keep your themes and plugins updated.

    • Cette réponse a été modifiée le il y a 1 mois par jeannedarc1.
    #2409715
    Li-An
    Modérateur
    Maître WordPress
    26511 contributions

    On va donc recommencer à zéro.

    Il y avait un questionnaire affiché, c’est dommage de ne pas l’avoir complété entièrement, car il peut aider à vous aider.
    Alors, merci de le copier-coller et compléter du mieux possible dans votre prochain post. Vous pouvez utiliser l’extension disponible à cette adresse https://github.com/zitezinfo/infosite et copier/coller les informations en remplaçant le terme Apache par le nom réel de votre hébergeur (OVH, Ionos,…).

    Pour l’installer : Extensions>Ajouter, cliquer sur le bouton Téléverser une extension.

     

    #2410003
    jeannedarc1
    Participant
    Initié WordPress
    7 contributions

    Voilà les résultats pour  :

    La page d’accueil des 3 sites :

    Ma configuration WP actuelle :
    – Version de WordPress : 6.0 multi-site
    – Version de PHP / MySQL : 7.4.30 / 5.7.38
    – Thème utilisé : JeanneDivi (slug : Jeannedivi) pas de thème enfant
    – Thème URI : http://www.elegantthemes.com/gallery/divi/
    – Extensions activées pour le réseau : 1&1 WP Wizard (2.0.1), Access Category Password (1.5.1), Akismet Anti-Spam (4.2.4), All-in-One Event Calendar by Time.ly (3.0.0), AntiSpambot (1.2.0), BackWPup (3.10.0), Contact Form 7 (5.6), Disable Gutenberg (2.7), Easy FancyBox (1.8.18), ET Shortcodes (1.2.1), File Gallery (1.8.5.3), GDPR Cookie Consent (2.1.2), Infosite (6), Jetpack (11.1), Limit Login Attempts (1.7.1), MetaSlider (3.27.6), Monarch Plugin (1.4.14), Photo Gallery (1.6.9), PHP Compatibility Checker (1.5.2), TablePress (1.14), TablePress Extension: Responsive Tables (1.2), UpdraftPlus – Backup/Restore (1.22.12), WordPress Importer (0.7), WP-PageNavi (2.94.0), Yoast Duplicate Post (4.5), Yoast SEO (19.2)
    – Extensions désactivées : Flamingo (2.3), HandHeld (1.3.1), UberMenu – Flat Skins Pack Extension (3.0), UberMenu 3 – The Ultimate WordPress Mega Menu (3.7.8), Widget Importer & Exporter (1.6)
    – Adresse du site : http://www.jeannedarc-figeac.fr
    – Hébergeur : ionos

    Le site collège Lycée :

    Ma configuration WP actuelle :
    – Version de WordPress : 6.0 multi-site
    – Version de PHP / MySQL : 7.4.30 / 5.7.38
    – Thème utilisé : JeanneDivi (slug : Jeannedivi) pas de thème enfant
    – Thème URI : http://www.elegantthemes.com/gallery/divi/
    – Extensions activées : HandHeld (1.3.1), UberMenu – Flat Skins Pack Extension (3.0), UberMenu 3 – The Ultimate WordPress Mega Menu (3.7.8), Widget Importer & Exporter (1.6)
    – Extensions activées pour le réseau : 1&1 WP Wizard (2.0.1), Access Category Password (1.5.1), Akismet Anti-Spam (4.2.4), All-in-One Event Calendar by Time.ly (3.0.0), AntiSpambot (1.2.0), BackWPup (3.10.0), Contact Form 7 (5.6), Disable Gutenberg (2.7), Easy FancyBox (1.8.18), ET Shortcodes (1.2.1), File Gallery (1.8.5.3), GDPR Cookie Consent (2.1.2), Infosite (6), Jetpack (11.1), Limit Login Attempts (1.7.1), MetaSlider (3.27.6), Monarch Plugin (1.4.14), Photo Gallery (1.6.9), PHP Compatibility Checker (1.5.2), TablePress (1.14), TablePress Extension: Responsive Tables (1.2), UpdraftPlus – Backup/Restore (1.22.12), WordPress Importer (0.7), WP-PageNavi (2.94.0), Yoast Duplicate Post (4.5), Yoast SEO (19.2)
    – Extensions désactivées : Flamingo (2.3)
    – Adresse du site : http://www.jeannedarc-figeac.fr/college-lycee
    – Hébergeur : IONOS

    Le site de l’école :

    Ma configuration WP actuelle :
    – Version de WordPress : 6.0 multi-site
    – Version de PHP / MySQL : 7.4.30 / 5.7.38
    – Thème utilisé : JeanneDivi (slug : Jeannedivi) pas de thème enfant
    – Thème URI : http://www.elegantthemes.com/gallery/divi/
    – Extensions activées pour le réseau : 1&1 WP Wizard (2.0.1), Access Category Password (1.5.1), Akismet Anti-Spam (4.2.4), All-in-One Event Calendar by Time.ly (3.0.0), AntiSpambot (1.2.0), BackWPup (3.10.0), Contact Form 7 (5.6), Disable Gutenberg (2.7), Easy FancyBox (1.8.18), ET Shortcodes (1.2.1), File Gallery (1.8.5.3), GDPR Cookie Consent (2.1.2), Infosite (6), Jetpack (11.1), Limit Login Attempts (1.7.1), MetaSlider (3.27.6), Monarch Plugin (1.4.14), Photo Gallery (1.6.9), PHP Compatibility Checker (1.5.2), TablePress (1.14), TablePress Extension: Responsive Tables (1.2), UpdraftPlus – Backup/Restore (1.22.12), WordPress Importer (0.7), WP-PageNavi (2.94.0), Yoast Duplicate Post (4.5), Yoast SEO (19.2)
    – Extensions désactivées : Flamingo (2.3), HandHeld (1.3.1), UberMenu – Flat Skins Pack Extension (3.0), UberMenu 3 – The Ultimate WordPress Mega Menu (3.7.8), Widget Importer & Exporter (1.6)
    – Adresse du site : http://www.jeannedarc-figeac.fr/maternelle-primaire
    – Hébergeur : IONOS

    Le site formation continue :

    Ma configuration WP actuelle :
    – Version de WordPress : 6.0 multi-site
    – Version de PHP / MySQL : 7.4.30 / 5.7.38
    – Thème utilisé : ArcencielDivi (slug : Arcencieldivi) pas de thème enfant
    – Thème URI : http://www.elegantthemes.com/gallery/divi/
    – Extensions activées : UberMenu – Flat Skins Pack Extension (3.0), UberMenu 3 – The Ultimate WordPress Mega Menu (3.7.8)
    – Extensions activées pour le réseau : 1&1 WP Wizard (2.0.1), Access Category Password (1.5.1), Akismet Anti-Spam (4.2.4), All-in-One Event Calendar by Time.ly (3.0.0), AntiSpambot (1.2.0), BackWPup (3.10.0), Contact Form 7 (5.6), Disable Gutenberg (2.7), Easy FancyBox (1.8.18), ET Shortcodes (1.2.1), File Gallery (1.8.5.3), GDPR Cookie Consent (2.1.2), Infosite (6), Jetpack (11.1), Limit Login Attempts (1.7.1), MetaSlider (3.27.6), Monarch Plugin (1.4.14), Photo Gallery (1.6.9), PHP Compatibility Checker (1.5.2), TablePress (1.14), TablePress Extension: Responsive Tables (1.2), UpdraftPlus – Backup/Restore (1.22.12), WordPress Importer (0.7), WP-PageNavi (2.94.0), Yoast Duplicate Post (4.5), Yoast SEO (19.2)
    – Extensions désactivées : Flamingo (2.3), HandHeld (1.3.1), Widget Importer & Exporter (1.6)
    – Adresse du site : http://www.jeannedarc-figeac.fr/arcencielformation
    – Hébergeur : ionos

    Si cela peut aider à résoudre le problème !! merci d’avance

    #2410012
    Li-An
    Modérateur
    Maître WordPress
    26511 contributions

    Alors les trois tournent avec un thème personnalisé. Vous avez essayé avec la dernière version de Divi ?

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.