[Résolu] Le texte du slider de la page d’accueil ne s’affiche pas en responsive

  • WordPress :5.0.1
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 21)
  • Auteur
    Messages
  • #2250404
    blandineleblanc29
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    Ma configuration WP actuelle

    • – Version de WordPress : 5.1
    • – Version de PHP/MySQL : 7.0.33 / 5.6.40
    • – Thème utilisé : Rambo
    • – Thème URI : https://webriti.com/rambo-lite-version-details-page/
    • – Extensions en place : Classic Editor (1.4), Forum_wordpress_fr (4.1), One Click Demo Import (2.5.0), Orbit Fox Companion (2.5.8), SEOPress (3.3.9), Slider Images (1.3.8), Slider Responsive Slideshow (0.6.5), WP Cerber Security, Antispam & Malware Scan (7.9.7), WP Contact Slider (2.3), WPForms Lite (1.5.1)
    • – Adresse du site : http://yann-hemery.fr
    • – Nom de l’hébergeur : Apache /// OVH

    Problème(s) rencontré(s) :

    Bonjour,

    Le titre et texte du slider de ma page d’accueil ne s’affiche pas correctement en version smartphone. Le support rambo m’a dit d’ajouter le code CSS ci-dessous et je l’ai fait mais du coup, le titre n’apparaît plus et le texte couvre toute l’image du slider.

    Le code proposé :

    @media (max-width: 767px){

    .carousel-inner .active > div {

    display: block;

    }}

    @media (max-width: 767px){

    .carousel-inner .active > div {

    display: block;

    }}

    Merci !!!!

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2250509
    PhiLyon
    Modérateur
    Maître WordPress
    22625 contributions

    Bonjour.

    Essaies avec ce code

    @media (max-width: 767px) {
    	.carousel-inner .active.left { left: 0; }
    	.carousel-inner .next        { left:  0; }
    	.carousel-inner .prev		 { left: 0; }
    	.active > div { display:block; }
    	.active > div:first-child { display:block; }
    }

    🙂

    #2250541
    blandineleblanc29
    Participant
    Initié WordPress
    13 contributions

    Bonjour et merci pour la réponse ! Malheuresement cela n’ a pas fonctionné  !!! Il semble même que le « bloc » n’est pas bougé d’une iota 😉

     

    #2250570
    PhiLyon
    Modérateur
    Maître WordPress
    22625 contributions

    Bonjour.

    Étrange, ça fonctionne chez moi, tu as vidé ton ou tes caches ?

    🙂

    #2250573
    blandineleblanc29
    Participant
    Initié WordPress
    13 contributions

    Voilà, j’ai vidé le cache, toujours pas d’affichage en mode responsive… On a l’impression que le texte est dans un bloc sur le slider, le slider se met bien en responsive mais pas le texte sur le bloc ???

    Ci-dessous capture d’écran

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2250585
    PhiLyon
    Modérateur
    Maître WordPress
    22625 contributions

    Moi ça donne l’image jointe, tu as supprimé le code qu’ils t’avaient donné.

    🙂

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2250587
    blandineleblanc29
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    Je ne comprends pas ta question 😉

    Oui, j’ai supprimé le code qu’ils m’avaient donné et remplacé par le tien… il ne fallait pas ?

     

    #2250588
    PhiLyon
    Modérateur
    Maître WordPress
    22625 contributions

    Si il fallait, tu n’as rien modifié d’autre dans le CSS ?

    🙂

    #2250590
    blandineleblanc29
    Participant
    Initié WordPress
    13 contributions

    Non non

    je te joins une capture du css

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2250592
    PhiLyon
    Modérateur
    Maître WordPress
    22625 contributions

    C’est bien le slider du thème ?

    🙂

    #2250600
    blandineleblanc29
    Participant
    Initié WordPress
    13 contributions

    j’ai remplacé celle proposé par le thème. et ai mis ma phot.. .. les dimensions que j’ai choisies sont 1920 *597 pxls

    Ta question m’a fait changé les dimensions et je viens d’ intégrer une nouvelle image aux dimensions du slider du thème : 1600*500…(pas sure que ce soit les exactes dimensions ? Bref, conséquences  : cela a légèrement repoussé le texte et on voit davantage la fin du titre… le mot « patrimoine » de « Yann héméry, créateur de patrimoine » est visible…

    la dimension de l’image, serait-elle une piste ?

    #2250633
    PhiLyon
    Modérateur
    Maître WordPress
    22625 contributions

    Essaies comme-ça, il y aura sûrement des valeurs à modifier

    @media (max-width: 767px) {
    	.carousel-inner .active.left { left: 0; }
    	.carousel-inner .next        { left:  0; }
    	.carousel-inner .prev		 { left: 0; }
    	.active > div { display:block; }
    	.active > div:first-child { display:block; }
    	.slider_con span {
        font-size: 10px;
        line-height: 14px !important;
    		margin: 10px 0 0 0 !important;}
    	.slider_con h2 {
        font-size: 18px;
        line-height: 10px !important;
        margin: 10px 0px 0 8px !important;
    }	
    .slider_con h2, .slide-title {
       margin-top:10px;
    }
    }

    🙂

    #2250640
    blandineleblanc29
    Participant
    Initié WordPress
    13 contributions

    C’est vraiment pas mal !!!!!!! 😉 Merci !!!!!

    pas bp d’ajustements finalement ?  Ci-joint capture écran…

     

    Par contre ce que je ne comprends pas (mais c’est peut-être un autre bloc ???) les titres de la section « service setting » n’apparaissent pas sur mon android… ils apparaissent en revanche sur le smartphone Apple ??? Faut-il que je fasse un autre ticket pour cela ?

    Merci en tout cas !!!

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2250643
    PhiLyon
    Modérateur
    Maître WordPress
    22625 contributions

    Rajoutes une width:100% au titre.

    Sur mon vieux Samsung, ils apparaissent tes titres, vides ton cache.

    C’est un peu long à charger, peut-être ma wifi ou le vent.

    🙂

    #2250653
    blandineleblanc29
    Participant
    Initié WordPress
    13 contributions

    Bonsoir,

    100% au titre ds le CSS ? Parce que là je n’ai pas accès au code HTML

    A bientot

     

15 sujets de 1 à 15 (sur un total de 21)
  • Vous devez être connecté pour répondre à ce sujet.