[Résolu] le mode « Elementor canevas » d’une page ne se pérennise pas (Elementor)

  • WordPress :4.9.4
  • Statut : résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2186142
    klamk
    Participant
    Padawan WordPress
    52 contributions

    Bonjour,

    Ma configuration WP actuelle

    • WordPress 4.9.6
    • Version de PHP/MySQL :
    • Thème utilisé : twenty seventeen
    • Extensions en place : Shortcodes Ultimate, Coming Soon Page & Maintenance Mode, Contact Form 7, UpdraftPlus, Elementor
    • Nom de l’hébergeur : OVH
    • Adresse du site : pas en ligne

     

    Problème(s) rencontré(s) :

    J’ai installé Elementor juste pour créer deux pages vierges (sans en-tête ni pied de page), qu’on peut peut-être appeler « landing page » même si elle n’ont pas la même fonction. J’y arrive en sélectionnant le modèle « elementor canevas » dans wordpress et dans Elementor. J’ai construit pour chacune des 2 pages un modèle elementor.

    Il y a un problème pour l’une de ces pages qui est la page d’accueil du site.

    Au départ, tout fonctionne.

    Mais <b>au bout d’un moment, quand on la charge via le menu ou via l’extérieur, on n’est plus en mode canevas : le menu apparaît, et la landing page est réduite comme rétrécie.</b>

    J’ai trouvé qu’à ce moment le modèle indiqué dans l’éditeur de wordpress est le modèle par défaut ! (alors que c’est bien le canevas dans elementor).

    Je re-sélectionne donc le modèle « elementor canevas » dans l’éditeur wordpress, je sauvegarde la page. Et ça fonctionne.

    Et quelque temps après, le problème réapparaît. C’est une boucle…

    Comme si <b>on n’arrive pas à fixer définitivement comme modèle « elementor canevas » dans l’éditeur wordpress</b>.

    Comment supprimer cette instabilité ?

    Merci d’avance

    #2186443
    momofr@free.fr
    Modérateur
    Maître WordPress
    2065 contributions

    Salut, le support d’Elementor est efficace tu devrais poster plutôt dessus ils sauront t’indiquer où ça coince. Ce genre de dysfonction semble lié à un cache ou un conflit avec une autre extension (tu n’en as pas beaucoup), Shortcodes Ultimate te sert à quoi au juste (un peu doublon avec Elementor à mon avis) ?

    #2189942
    klamk
    Participant
    Padawan WordPress
    52 contributions

    Merci

    le problème est réglé :
    dans Elementor j’ai validé à nouveau le choix du modèle « elementor canevas ». Automatiquement ce choix s’est affiché dans l’éditeur WordPress (avant, je ne comprenais pas ce manque de synchro entre les 2 affichages). Et ça n’a pas bougé depuis lors !
    J’en conclus que je pensais à tort ce choix avoir validé dans Elementor. Erreur de débutante certainement.

    Autrement, je ne me suis mise à Elementor que dernièrement (pour les landing pages) alors que le site était en grande partie fabriqué. Ce qui explique que j’ai utilisé « Shortcodes Ultimate » pour des choses faisables avec Elementor. Ça va rester comme ça longtemps à moins qu’il y ait un conflit quelconque.

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.