La traduction de mon thème ne fonctionne pas (Créer un compte)

  • WordPress :5.3
  • Statut : non résolu
11 sujets de 16 à 26 (sur un total de 26)
  • Auteur
    Messages
  • #2337137
    sisilapaillette
    Participant
    Initié WordPress
    19 contributions

    Super, merci beaucoup !

    #2337139
    PhiLyon
    Modérateur
    Maître WordPress
    26065 contributions

    Essaie de contacter leur support également.

    🙂

    #2337140
    sisilapaillette
    Participant
    Initié WordPress
    19 contributions

    Le support d’Atelier du coup ?

    #2337141
    PhiLyon
    Modérateur
    Maître WordPress
    26065 contributions

    Oui et essaie avec ces 2 nouveaux fichiers, je l’ai fait directement à partir du fichier .pot, sans prendre leur modèle, j’y ai modifié Shop et Add to cart.

    🙂

    #2337144
    WP Traduction
    Modérateur
    Maître WordPress
    1983 contributions

    Bonjour,

    Si vous avez mis les fichiers de traduction à plusieurs endroits, cela pourrait expliquer le problème.

    Donc mettez les bons fichiers atelier-fr_FR.po et .mo, dans wp-content/languages/themes et supprimez tous les autres fichiers de traduction en français partout ailleurs (thème & thème enfant) et le code que vous avez ajouté dans le thème enfant, puis vérifiez si cela résout le problème.

    Si ça n’est pas le cas, essayez l’extension WPT Custom Mo File dont voici un tuto : https://youtu.be/G0CqwLclTJg.

    Et si aucun résultat, alors vérifiez que ces chaînes ne proviennent pas d’une extension tierce et prenez contact avec le support du thème.

    #2337233
    sisilapaillette
    Participant
    Initié WordPress
    19 contributions

    Bonjour,

    J’ai essayé les deux options, aucune ne fonctionne. J’ai déjà regardé dans pas mal de fichiers .po d’extensions (dont tous ceux de Woocommerce), as-tu une idée d’une extension qui pourrait contenir ces chaînes ? Je vais contacter le support du thème également.

    Merci !

    #2337238
    sisilapaillette
    Participant
    Initié WordPress
    19 contributions

    En fait je n’ai plus accès au support du thème, il était disponible pour 6 mois et la période est terminée (et ils précisent sur leur page qu’ils ne répondent pas aux demandes de support pour la customisation)…

    #2337242
    PhiLyon
    Modérateur
    Maître WordPress
    26065 contributions

    Bonjour.

    Avec Notepad++ essaie de faire une recherche de l’un des termes sur tout ton site.

    🙂

    #2337244
    sisilapaillette
    Participant
    Initié WordPress
    19 contributions

    Petite update : j’ai fait une recherche avec String Locator, je trouve les chaînes problématiques dans le fichier woocommerce-fr_FR.po (j’ai vérifié avec PoEdit, elles sont bien traduites dans le fichier), et apparemment dans les fichiers .po du plugin Kadence (je joins la capture d’écran), sauf qu’elles ne sont pas présentes quand j’ouvre les fichiers .po. J’ai essayé de désactiver Kadence mais rien ne change.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2337246
    WP Traduction
    Modérateur
    Maître WordPress
    1983 contributions

    Bonjour,

    as-tu une idée d’une extension qui pourrait contenir ces chaînes ?

    Comme vous n’avez pas pris la peine de lister vos extensions dans le formulaire de demande de renseignements, je ne vois pas comment je pourrais avoir une idée à ce sujet.

    je n’ai plus accès au support du thème

    Vous pouvez prolonger le support moyennant finance (pas besoin de racheter le thème, juste prolonger le support, c’est moins cher). Par la même occasion, permettez-moi de vous rappeler que ce forum d’entraide n’a pas vocation à se substituer au SAV des thèmes & plugins payants.

    ils ne répondent pas aux demandes de support pour la customisation

    Cela n’a rien à voir avec de la customisation puisque c’est de la traduction, or c’est censé fonctionner, c’est donc bien un problème de support.

    Sinon, à tout hasard, pensez-vous à bien vider vos éventuels caches et à passer en navigation privée pour vérifier que ça fonctionne, ou non, à chaque modification ?

    #2337247
    sisilapaillette
    Participant
    Initié WordPress
    19 contributions

    Nos messages se sont croisés, oui je vide les caches (navigateur + wp super cache) et je passe en navigation privée à chaque fois. Ok pour le support, je pensais que c’était du domaine de la customisation, je vais prolonger du coup.

    Merci !

11 sujets de 16 à 26 (sur un total de 26)
  • Vous devez être connecté pour répondre à ce sujet.