La recherche ne fonctionne plus

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 22)
  • Auteur
    Messages
  • #459384
    geekubuntu
    Participant
    Chevalier WordPress
    286 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.5.1
    – Thème utilisé : celui par défaut remanié
    – Plugins en place : viper quicktags, xml sitemap, contact form 3
    – Nom de l’hebergeur : moi
    – Adresse du site : http://www.strapontins.org/

    Problème(s) rencontré(s) :

    Voilà,

    après modifications du thème (désactivation de la sidebar en retirant les get_sidebar notamment), ma recherche ne fonctionne plus 😕

    Ainsi, http://www.strapontins.org/?s=holé ne renvoit rien, et je ne sais pas d’ou vient le problème.. pourquoi cela ne marche plus?

    ++

    #629518
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    Bonjour,

    J’ai exactement le même problème depuis des semaines et personne n’a répondu.
    Donc, je vais suivre les réponses que tu vas avoir

    #629519
    geekubuntu
    Participant
    Chevalier WordPress
    286 contributions

    personne d’autre?

    #629520
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    Bon j’avais tapé tout un paragraphe…… Les raccourcis………. voilà ce que j’en pense des raccourcis……
    Sinon, j’avais écris que j’envisageais d’utiliser le moteur de recherche GG déjà intégré à mon site….
    Je n’ose en tous cas pas passer sur 2.5

    #629521
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    Ma recherche à moi fonctionne bien !

    Ouais, ouais, je sais, c’est le genre de réponse qui ne font pas beaucoup avancer le schmilblick.
    Je poursuis donc :
    Première cause vraisemblable : vous utilisez une extension incompatible avec votre version de WP.
    Mode opératoire pour le diagnostic : 1/ désactiver toutes les extensions, 2/ vérifier si ça marche (ou non), 3/ réactiver une par une les extensions pour trouver celle qui fait planter la recherche 4/ ne pas oublier de venir poster ici le fruit de votre travail.

    Deuxième cause plus douteuse : La page de votre thème n’affiche pas correctement le résultat des recherches.
    Mode opératoire pour le diagnostic : 1/ positionner le thème par défaut 2/ lancer une recherche et vérifier que ça marche (ou non) 3/ corriger votre thème en s’inspirant du thème par défaut (ou de tout autre thème qui fonctionne) 4/ idem ci-dessus.

    3ème cause possible : base de données vérolée, version de WordPress instable ? Vérifier la base via phpMySQL, mettre à jour WP…

    4ème possibilité : aucune de toutes celles-là.
    Ben dans ce cas, je sèche !

    #629522
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    PS : pour vos essais, utilisez l’extension « Maintenance Mode » qui vous permettra de faire vos essais sans rendre trop vos lecteurs perplexes.

    PS2 : je précise en outre que j’utilise l’extension « Search everything », compatible WP2.5+.

    #629523
    geekubuntu
    Participant
    Chevalier WordPress
    286 contributions

    trouvé: il s’agit de l’extension WP Mobile http://www.andymoore.info/wordpress-mobile-plugin/

    pour moi c’est donc résolu 🙂

    ++

    #629524
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    Je n’utilise pas cette extension mobile, mais je vais tout tester

    Heu, j’ai une autre question, rien à voir : peut-on changer le titre du blog? enfin, est ce qu’il y a un impact sur les urls déjà en ligne.
    Pour l’instant, c’est tarot-numerologie, avec le slogan. Si je le change, j’ai peur que ça mette la pagaille dans tout ce qui est déjà fait.

    Sinon, je n’ai plus le theme par défaut… J’ai pensé longtemps que le nombre de themes influait sur le poids de chargement de blog.

    Je vais voir de ce pas, les plugins

    Merci d’avance de vos commentaires

    #629525
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    http://www.tarot-numerologie.fr/blog?s=tibet
    Quelque soit le mot de recherche que j’entre, ça aboutit à une page erreur sur ie.
    Est ce qu’il n’y aurait pas un lien a evc le fait que mon blog n’est accessible qu’avec le /à la fin de l’adresse
    Là, il manque donc un “/” entre blog et le “?”
    Enfin j’imagine que ça vient de ça
    J’ai désactivé la plupart des plugins, ça ne fonctionne toujours pas.

    Je vais peut-être changer de theme, en allant en chercher un autre

    Sinon, est ce que je peux changer le nom du blog sans perturber ce qui est déjà publié?

    Merci d’avance

    #629526
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    J’ai pu récupérer un theme par défaut, l’installer…
    En français, ça fait drole de ne pas avoir à traduire au passage.
    Mais le moteur ne fonctionne toujours pas

    #629527
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    @ tarotnumerologie » Tu peux changer le titre de ton blog sans inquiétude.
    Tu indiques qu’avec le thème par défaut, cela ne fonctionne toujours pas, mais est-ce avec toutes les extensions désactivées ?

    Peux tu nous faire un copier-coller précis de l’erreur que tu récupères ?

    #629528
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    Heu, presque toutes sont désactivées. Il me reste post-views, akismet, all in one, analytics, flexipages, obsosocialbook…, simple tags.
    J’ai principalement stoppé des trucs dont je n’ai pas pour l’instant besoin
    Je me demande meme si tout ça ne pèse pas sur le poids du blog à l’ouverture.
    Il est lourd à ouvrir le mien.

    Mais merci beaucoup de ta réponse, elle me fait avancer le shmilblik

    l’erreur, la voilà
    http://www.tarot-numerologie.fr/blog?s=tibet
    Serveur introuvable
    Impossible d’afficher la page
    La page que vous recherchez est actuellement indisponible. Le site Web rencontre peut-être des difficultés techniques, ou vous devez modifier les paramètres de votre navigateur.

    #629529
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    Il y a un truc bizarre sur ton site :
    http://www.tarot-numerologie.fr/blog
    ne renvoit pas la même chose que
    http://www.tarot-numerologie.fr/blog/

    Et si la recherche
    http://www.tarot-numerologie.fr/blog?s=miracle
    foire, en revanche la recherche
    http://www.tarot-numerologie.fr/blog/?s=miracle
    fonctionne.

    Bref… Je pense qu’il faut que tu ajoutes un / à la fin de l’url de ton blog dans l’interface d’administration.
    Tu n’aurais pas bidouillé un fichier .htaccess par hasard (pas du tout ma spécialité, il faudra que tu trouves quelqu’un d’autre pour t’aider si ça ne suffit pas).

    #629530
    HeleneR
    Participant
    Maître WordPress
    1545 contributions

    Ton test est exactement ma situation.
    Ca fait d’ailleurs longtemps que ça dure.
    Et d’après ce que j’ai pu lire ici ou là. je ne suis pas la seule dans cette situation
    Heu, je n’ai rien touché au .htaccess.
    Je n’y connais rien non plus :o) et je n’ai rien touché, à cause de ça.

    pffffffffffffffffffffffft

    Si quelqu’un d’autre a une idée, mais merci pour le schmilblik précedent. ca m’a quand meme aidé sur un autre gros problème

    #629531
    Comme une image
    Participant
    Maître WordPress
    2493 contributions

    Je n’y connais pas grand chose non plus, au .htaccess.
    Est-ce que tu as essayé d’ajouter un / à la fin de l’url de ton blog, dans l’interface WP ?

15 sujets de 1 à 15 (sur un total de 22)
  • Vous devez être connecté pour répondre à ce sujet.