La liste des tags / étiquettes les plus utilisées est absente des articles (Créer un compte)

  • WordPress :5.8
  • Statut : non résolu
  • Ce sujet contient 5 réponses, 3 participants et a été mis à jour pour la dernière fois par doyz17, le il y a 5 mois.
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #2400824
    doyz17
    Participant
    Initié WordPress
    15 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4.28 / 5.5.5
    • Thème utilisé :  Hello Theme (elementor)
    • Extensions en place :

    Advanced Custom Fields: 5.12.2
    Advanced Post Queries: 1.0.15
    Custom Post Type UI: 1.11.2
    Edit Author Slug: 1.8.4
    Elementor: 3.6.1
    Elementor Pro: 3.6.4
    Happy Elementor Addons: 3.5.1
    Happy Elementor Addons Pro: 2.2.6
    iThemes Security: 8.1.0
    UpdraftPlus – Backup/Restore: 1.22.11
    User Profile Picture: 2.6.0
    WP DPE-GES: 1.4
    WP Rocket: 3.10.8

    • Nom de l’hébergeur :  O2Switch
    • Adresse du site : investisseurdugoelo.fr

    Problème(s) rencontré(s) :

    Je rencontre un soucis (et je pense que je ne suis pas le seul).

    Lorsque j’ajoute des tags à un article (dans mon cas un custom post type mais la n’est pas le problème), je n’a pas la liste des tags déjà utilisés.

    J’ai remarqué que cela le faisait sur d’autres site qui ont l’éditeur « Gutenberg » de WordPress. Sur un vieux site qui possède l’ancien éditeur, je ne rencontre pas ce souci.

    Savez-vous comment passer outre ?

    Un plugin ou un bout de code ?

     

    D’avance merci.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2400835
    Li-An
    Modérateur
    Maître WordPress
    26654 contributions

    Bonjour, comme je viens de faire la manip ce matin, c’est dû au fait que la custom taxonomy n’est pas définie correctement pour Gutenberg. J’ignore ce qui gère celle-ci (thème, extension ou code perso) mais ça nécessite l’ajout d’une ligne dans sa définition. J’ai dû le faire manuellement pour une vieille extension qui n’est plus maintenue et que j’utilise toujours. https://knowthecode.io/show-custom-taxonomy-panel-in-the-gutenberg-editor

    #2400840
    doyz17
    Participant
    Initié WordPress
    15 contributions

    Merci beaucoup, Bon la problématique maintenant est de savoir où intégrer ce bout de code : « ‘show_in_rest’      => true, »

     

     

    #2400841
    Lumiere de Lune
    Participant
    Maître WordPress
    20483 contributions

    Dans la fonction register_taxonomy

    On peut redéfinir une taxonomie (dans son thème ou dans un plugin) en réenregistrant une taxonomie existante avec une priorité plus basse dans l’action (15 par exemple).

    Le show_in_rest est effectivement nécessaire pour les custom posts et les customs taxonomies, car il est à « false » par défaut. WP aurait pu changer la valeur par défaut, ça aurait facilité la vie…

    #2400852
    Li-An
    Modérateur
    Maître WordPress
    26654 contributions

    @lumière : je n’avais pas pensé à ça. Bon, en même temps si mon extension est mise à jour, j’imagine que ce sera corrigé.

    #2400853
    doyz17
    Participant
    Initié WordPress
    15 contributions

    Merci à vous deux.

     

    je vais tester cela et ferai un retour

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.