jQuery est indéfini sous IE 5.5 et 6 (Créer un compte)

  • Statut : non résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #463375
    emilie1955
    Participant
    Initié WordPress
    48 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.5.1
    – Thème utilisé : yogouhrt par Web-Kreation. Traduction (niss.fr).
    – Plugins en place :
    – Nom de l’hebergeur :
    – Adresse du site : http://www.resterenvie.com/blogue

    Problème(s) rencontré(s) :

    Bonjour à toute la communauté, je ne sais pas si je peux poser ma question ici… je me risque: j’utilise la librairie jQuery loadée avec google.load(“jquery”, “1.2.6”);

    Sous IE 5.5 et 6 j’obtiens des erreurs, la première:

    jQuery est indéfini.

    Voici mon script d’appel et de fonction:

    <script type="text/javascript" src="http://www.google.com/jsapi"></script>
    <script>  
      // Load jQuery
      google.load("jquery", "1.2.6");
    </script>
    	
    	<script type="text/javascript" src="wp-content/scripts/jquery.easing.js"></script>
    	<script type="text/javascript" src="wp-content/scripts/jquery.accordion.js"></script>
    <script type="text/javascript">
    
    <!--
    	jQuery(document).ready(function() {
    		
    		jQuery('#content').accordion({
    			header: '.suite',
    			active: false,
    			alwaysOpen: false,
    			animated: "easeslide",
    			autoheight: false
    		});	
    	
    	});	
    	-->
    </script>

    Quelqu’un a déjà rencontré ce problème ?

    Merci de votre aide.

    #646780
    Rod
    Membre
    Maître WordPress
    744 contributions

    sous IE2 et IE3 aussi. Et Netscape 4.

    IE6 n’est plus utilisé par personne, ou presque. Et encore moins IE 5.5.

    Pour rappel : IE7 a juste … 7 ans ! Il est temps que tu occultes des compatibilités qui n’ont plus lieu d’etre.

    #646781
    emilie1955
    Participant
    Initié WordPress
    48 contributions

    Bonjour Rod, Maître WP.

    Pour rappel : la Version 7.0 est sortie : 19 octobre 2006

    So… IE7 n’a que 2 ans.

    La version 6 a duré 5 ans, meilleur score pour une version d’IE.

    Une bonne raison pour en tenir compte lors du développement.

    J’aime bien tester avec IE Tester si mes sites s’affichent, peut-être pas impecc mais s’affichent au moins. Depuis que j’ai inséré mon script jQuery plus rien ne va.

    Si quelqu’un a une idée du bug… je suis preneuse.

    #646782
    emilie1955
    Participant
    Initié WordPress
    48 contributions

    Alors Rod… ? t’as fouillé dans tes tites notes ?

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.