J’ai un problème avec les permalien de wordpress

  • WordPress :4.9.4
  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #2137114
    laurent1150
    Participant
    Initié WordPress
    7 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :  5.7.21
    • Thème utilisé : GreatMag
    • Extensions en place : Membership Ultra et autres plugin
    • Nom de l’hébergeur : Microsoft azure
    • Adresse du site : managameproduct.ca
    • Logiciel utilisé : wampserver 3

    Problème(s) rencontré(s) :

    Bonjour, j’ai un problème avec  les permalien de wordpress le problème c’est que quand je règle les permalien à Nom de l’article il me sortent l’érreur suivant:

    Not Found
    The requested URL /tchat/ was not found on this server.
    
    Apache/2.4.33 (Win32) PHP/5.6.35 Server at managameproduct.ca Port 80

    Mais, quand je le règle à simple j’ai plus cette érreur et je voudrait règle les permalien à Nom de l’article sans que ça me fasse l’érreur not found.

    Merci et j’attend votre réponce avec impatience.

    laurent1150

    • Ce sujet a été modifié le il y a 2 months par  laurent1150.
    • Ce sujet a été modifié le il y a 2 months par  laurent1150.
    • Ce sujet a été modifié le il y a 2 months par  laurent1150.
    #2137190
    PH_MarcAndreB
    Participant
    Initié WordPress
    4 contributions

    Bonjour Laurent,

    En ce moment il faudrait vous assurer que mod_rewrite soit actif sur votre hébergement Azure:

    Selon WordPress Codex
    <h2 class= »pagetitle »> »fr:Utilisation des permalien »</h2>
    […]

    Les « permaliens simplifés » sont disponibles sous ces environnements :

    • Serveur web Apache avec le module <tt>mod_rewrite</tt>
    • Serveur web Microsoft IIS 7+ avec le module URL Rewrite 1.1+ module et PHP 5 en mode FastCGI
    • Microsoft IIS 6+ en utilisant ASAPI_Rewrite
    • Lighttpd en utilisant a 404 handler ou mod_rewrite (voir See Also

    […]

    Il faudrait dès lors contacter le soutien technique de votre hébergement afin de vous assurez que les paramètres de votre Serveur web rencontrent les exigences requises pour les URL simples

     

     

    #2149642
    laurent1150
    Participant
    Initié WordPress
    7 contributions

    J’ai vérrifier sur mon wamp le mod_rewrite est belle et bien activé mais rien ne ce passe mai quand je le met à Simple et ça marche mais si je le met à Nom de l’article ça ne marche pas c’est ça qui est vraiment étrange.

    • Cette réponse a été modifiée le il y a 1 month et 1 week par  laurent1150. Raison: J'ai ajouté une phrase
    #2150043
    laurent1150
    Participant
    Initié WordPress
    7 contributions

    Up

    #2150044
    CAMEO172
    Participant
    Maître WordPress
    1312 contributions

    Avez vous tenter de valider par DEUX fois votre choix de permalien. Il faut parfois un peu insisté pour que ce soit bien mise à jour.

    Je ne l’explique pas.

    #2150045
    laurent1150
    Participant
    Initié WordPress
    7 contributions

    Avez vous tenter de valider par DEUX fois votre choix de permalien.

    Non je ne sais pas comment faire habituellement je active  le mod_rewrite et ça marche mais après je ne sais pas comment règlé le problème.

    #2150054
    CAMEO172
    Participant
    Maître WordPress
    1312 contributions

    Administration -> Réglages -> Permaliens

    A la fin de la page il y a « Enregistrer les modifications ». ça fait mouliner wordpress et modifier si besoin le .htacess automatiquement

    #2150400
    Flobogo
    Modérateur
    Maître WordPress
    14567 contributions

    Bonjour,

     

    • Nom de l’hébergeur : Microsoft azure
    • (…)
    • Logiciel utilisé : wampserver 3

     

    Je ne comprends pas bien : vous êtes hébergé chez « Microsoft Azure » ? Ou vous êtes en config locale avec WAMP ?

    #2152724
    laurent1150
    Participant
    Initié WordPress
    7 contributions

    Sur microsoft azure j’ai pris une machine virtuel windows 10, j’ai installer wamp serveur dessu pour faire fonctioner mon site web et j’ai passer wamp serveur de local à public grâce à l’adresse ip de ma machine virtuel.

    #2152726
    laurent1150
    Participant
    Initié WordPress
    7 contributions

    J’ai résolut mon problème il falais que je mette Options FollowSymLinks et AllowOverride Alldans mon virtual host.

    #2152766
    Flobogo
    Modérateur
    Maître WordPress
    14567 contributions

    Bah tant mieux, parce que techniquement, j’étais « out ». Je ne connais rien aux machines virtuelles.

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.