J’ai ruiné mon Blog. Si vous pouviez m’aider :( (Créer un compte)

  • Statut : non résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #452680
    raphy
    Membre
    Initié WordPress
    29 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.2
    – Thème utilisé : Benevolence
    – Plugins en place :
    – Nom de l’hebergeur : free
    – Adresse du site : http://www.kokodiary.com

    Problème(s) rencontré(s) :

    Comme je l’ai expliqué ici : http://www.wordpress-fr.net/support/sujet-6502-problemes-apres-mise-jour-suppression-impossible-etc

    suite a une mise a jour un peu radicale (du 1.5.2 au 2.2) j’ai ruiné mon blog.

    J’avais avant fait un back de la base par phpmyadmin
    et un back up du dossier wordpress par ftp.

    Quel est le meilleur moyen de faire table rase pour repartir de mes back up, et d’upgrader lentement ? 🙂

    Merci

    ps: je suis ultra neophyte en mysql etc.. donc merci de me donner tous les détails 🙂

    #603272
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Pour le ftp et le sql, tu vides tout et tu réinjectes tes sauvegardes, non ? Je ne vois que ça.

    Tu es chez quel hébergeur.

    Ensuite pour mettre à jour, il faudra passer par beaucoup de lectures. Sinon, ne met pas trop d’espoir sur les gens d’ici pour t’aider, c’est plutôt un forum patapouf. :D

    #603273
    raphy
    Membre
    Initié WordPress
    29 contributions

    il veut peut etre dire que ne pas recevoir de reponse en un peu plus de 24 h, c’est un peu “tranquilou” comme réactivité.

    Je ne critique pas, car nul n’est tenu de répondre a tout et tout le monde, et je comprends que venir 1000 fois en aide pour le meme probleme ce ne soit pas simple.

    Mais ce que je sais, c’est qu’aujourd’hui mon site est une ruine. Que plus j’essaye d’arranger pire c’est, et que je ne peux pas trouver de solutions en lisant ce forum vu que je suis 20000 % a la ramasse.

    J’ai vraiment besoin d’aide. Je suis pres a donner mes sauvegarde mes identifiants free et mysql si quelqu’un peu m’aider…

    J’ai essayé de tout effacer (bdd et ftp), afin de partir d’une intal clean. Deja rien que ca chez free j’ai des message d’erreur. Vu que j’ai une sauvegarde .sql je em suis dit que je pourrai ensuite y injecter les anciens messages.. rien ne marche.. ou plutot ne sachant pas faire j’improvise ce qui n’arrange rien

    J’ai donc vraiment besoin d’aide 🙂

    #603274
    raphy
    Membre
    Initié WordPress
    29 contributions

    bon j’ai installé mon WP ailleurs :

    Ma configuration WP actuelle
    – Version de WordPress : 1.5.2
    – Thème utilisé : Benevolence
    – Plugins en place :
    – Nom de l’hebergeur : infomaniak
    – Adresse du site : http://www.kokodiary.com

    Mes questions sont les suivantes :

    *J’aimerai upgrader. Je passe par quelles versions inermédiaires ? et surtout ou les trouver ?
    * tous mes “à” se sont transformés en point d’interrogation. J’ai réparé le site en faisant des copier/coller petit bout par petit bout de ma sauvegarde de ma base sql. Par quel caractère dois je changer tous les “à” pour qu’en ré-important ma base j’ai bien des “à” et pas des “?” ?

    merci bcp

    #603275
    dlo
    Participant
    Maître WordPress
    1850 contributions

    Bon, allez, les patapouf vont s’y coller !!! 😉

    1) Peux tu nous dire si la recopie de la sauvegarde du dossier WordPress faite par FTP a marché ?

    2) As tu supprimé toutes les tables wp_xxx dans ta base MySql via PHPMyAdmin ?

    En fonction de ta réponse, on verra pour la suite….

    Cordialement

    #603276
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4079 contributions

    Modération : Déjà une seule discussion suffisait pour le même problème les réponses vont s’entrecroiser…
    Je ferme la précédente et on poursuit ici. merci.

    YannC > En consultant ce forum tu remarqueras que la moyenne du temps de réactivité est plutôt bonne et même à mon avis plus rapide que sur bien des forums… Ensuite, nous ne sommes que bénévoles, nous faisons tout notre possible pour répondre au mieux dans les meilleurs délais mais c’est pas toujours facile. Ton intervention est donc fort déplacée !
    Si nous n’avons pas répondu à l’une de tes questions c’est peut être que nous n’avons pas la réponse ou alors que nous ne l’avons pas vu (ca peut arriver !) ou encore que tu n’es pas assez patient… et que la personne la plus compétente pour te répondre n’est pas encore passé sur le forum et n’a donc pas vu la question… bref plusieurs raisons sont possibles… un peu de respect merci.

    raphy > Combien d’article ta base comporte-t-elle ?

    as-tu effacé tous les fichiers de ton FTP (sauf WP-CONFIG.PHP et WP-CONTENT) et remis les nouveaux en place puis as-tu démarré UPGRADE.PHP en te connectant à l’admin dès la mise à jour des fichiers effectuées ?

    #603277
    raphy
    Membre
    Initié WordPress
    29 contributions

    vive les patapoufs 🙂

    Plus sérieusement voila ce que j’ai finalement fait :

    J’etais chez free. J’avais des erreurs en pagailles quand j’effaçais tout et que je refaisais une instal clean.
    Bref je n’ai pas trouvé la solution

    j’ai una utre hebergement chez infomaniak.

    J’ai installé wordpress 1.5.2 (qui était celle dont je partais quand ça marchait).
    Ensuite en utilisant la fonction “sql” de phpmyadmin, j’ai ajouté petit a petit par copier/coller le contenu de ma sauvegarde .sql (pourquoi ? parce que le fichier faisait 7 Mo a cause du spam dans les commentaires, et par l’upload a travers l’interface de phpmyadmin ça ne fonctionnait pas)

    Ce qui m’a permis de reconstruire la base. Ce n’est peut etre pas la meilleure solution, mais ça fonctionne.

    Bref la 1.5.2 marchait sur infomaniak. Je perds mes liens mais a moindre mal.

    J’ai fait les upgrade suivantes :

    1.5.2 –> 2.0
    2.0–>2.0.9
    2.0.9–>2.2

    Et la ca va presque parfaitement 🙂

    Il me reste 2 questions :

    * tous mes “à” se sont transformés en point d’interrogation. Y a t il un moyen pour tous les changer ? Ou vais je devoir repasser derrière tous mes articles ?

    * j’ai un souci avec l’affichage des liens. Avant j’utilisais , et je mettais un certain nombre de critères pour n’afficher qu’une seule catégorie de lien, classer les lien par le nom, ne pas mettre le nom de la catégorie, etc etc.
    Ce qui donnait :
    <?php get_links('1', '', '
    ‘, ‘
    ‘, 1, ‘name’, 1, 0, -1, 0); ?>

    mais cela ne fonctionne plus. Si je laisse ça , rien ne s’affiche.
    j’ai donc mis ceci :

    et la les 2 catégories de liens, avec leur contenu s’affiche, mais ca me convient moyen.
    Comment faire pour : Afficher les liens sans le nom de la catégorie ? / Afficher une catégorie de lien, puis un peu plus loin une seconde catégorie de lien.

    Merci 🙂

    #603278
    YannC
    Membre
    Chevalier WordPress
    295 contributions
    raphy wrote:
    il veut peut etre dire que ne pas recevoir de reponse en un peu plus de 24 h, c’est un peu “tranquilou” comme réactivité.

    Oui, c’est ce que je voulais dire 🍺

    Mais quelle cascade de réactions outragées!

    Obiwan > en consultant ce forum par la fontion recherche, je constate surtout qu’un nombre infini de posts n’obtient jamais de réponse satisfaisante. Je comprends bien que le nombre de personnes compétentes qui fréquente ce forum ainsi que leur enthousiasme soit rare et précieux , mais tout à fait entre nous si le mot patapoufs n’avait pas été lâché ici, je suis à peu près sûr que moi seul m’intéresserait au problème de ce pauvre raphy. C’est peut-être un problème d’organisation, ou de manque d’efficacité de Punbb qui ne trace pas bien les posts par exemple. Voila. C’est mon avis seulement.

    Bon, patapouf c’est pas méchant du tout et pas vraiment déplacé puisque c’est juste la sensation que me donne ce forum que je fréquente depuis une dizaine de mois. Faut aussi savoir ne pas prendre la mouche. Z’avez qu’à faire un sondage anonyme : “Trouvez-vous que les forums WPfr sont 1- trop patapoufs 2- un peu patapoufs 3- assez dynamiques 4- très dynamiques 5- ne se prononce pas” si vous voulez être fixés sur qui se fait des idées. On peut remplacer patapouf et dynamique par “Appréciez la réactivité du forum : évaluez sur 100 10″.

    Aaxane > selon moi, la meilleure source d’information c’est Google, qui oriente sur les blogs WP, puis le codex et wiki de WP.org (en anglais). Mais la meilleure de chez meilleure, c’est de décortiquer un thème, puis un autre, de surfer, de se bouger et d’éviter autant que possible l’attraction gravitationnelle et patapoufienne de la planète WPfrnet :D Sinon c’est foutu on y est encore 2 mois plus tard et on n’a pas avancé :D

    Patapouf, c’est ça 67bf27900f68a297324de2b6069et.jpg

    Passons.

    raphy > Free ou Infomaniak, le problème est identique : tu dois réinstaller une version WP1.5 vierge, puis écraser les fichiers par défaut sur ton ftp et faire de même sur ta console de gestion MySql free (d’abord tu y détruis tout puis tu y “importes” ta bdd). Normalement tu retrouveras le couple identique que tu avais à l’époque avant la mise à jour.

    #603279
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Juin = Beau temps = Exams = Moins de WP…

    Logique imparable.

    #603280
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Amo > 🙂

    Raphy > Ton problème de points d’interrogation est lié à ta mise à jour. Tu devais auparavant être en charset caractères ISO 8859-1 et là tu es passé en UTF-8 (le nouveau WordPress est en UTF-8 par défaut). Vois sur le forum (recherche) car ça a du déjà arriver. Il faudra sûrement encore un peu bricoler ta base de données.

    Pour get_links, je crois que c’est une balise déclassée mais alors pôôôô sûr du tout. Tu dois vérifier sur le codex.wordpress.org.

    Quant à la gestion des nouvelles balises, tu peux l’affiner dans ta console de gestion (catégorie liens et pages je suppose) ; et si tu trouves la fiche sur les paramètres de get_links_list(), je suis preneur ! car sur cette fiche là (

    http://codex.wordpress.org/fr:Marqueurs_de_Modele/get_links_list ) il n’y a que deux (!?) paramètres.

10 sujets de 1 à 10 (sur un total de 10)
  • Le forum ‘Utilisation spécifique de WordPress’ est fermé à de nouveaux sujets et réponses.