interprétation de sources (+pb de mise en page)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 20)
  • Auteur
    Messages
  • #447338
    DePassage
    Participant
    Initié WordPress
    11 contributions

    Bonjour bonjour,
    je viens demander de l’aide pour résoudre deux problème (distincts) :
    – quand je colle du code source, php ou html, dans un article, il est interprété. C’est pas le but…. Je sais que beaucoup cherchent le contraire, à en lire le forum, mais moi je veux bien qu’il apparaîssent en clair. Je sais aussi qu’on a consillé plusieurs choses : quoter ou blockquoter le texte, le faire en html avec les bonne vieilles balises ceci est une patate chaude, touchez pas!, mais non, rien n’y fait chez moi…

    Une piste peut-être ? Je trouve pas dans les option, config, préférence :rolleyes:

    Un autre problème : à l’index du blog j’ai un sérieux problème de positionnement de certains bloc, j’ai cru au début que c’était l’un de mes thèmes mais ça le fait avec d’autres… Avec mental disorder par exemple, j’ai le footer très décalé vers la droite. Avec Crimson, j’ai carrément tout le sidebar qui se retrouve à la fin du corps et non à droite. Et tout ceci se passe rien qu’à l’index, à l’affichage d’un article tout est normal.
    Est-ce que je suis censé trouver le bug dans l’index.php de l’application (puisque ça semble pas apaprtenir aux gabarits des thèmes en soi) ? Mais quoi ?

    A noter aussi que le problème est similaire avec le thème par défaut. Tout ça m’enquiquine en ligne, alors qu’en local je n’arrive pas à recréer l’erreur pour mettre le doigt dessus.

    Merci pour vos lumières 🙂

    PS : et pour ma contrib du jour, je signale que dans le dernier billets de ce site (1er avril, la V2.0.2 fr), il y a une énôôôrme faute de français…

    a été publier

    #572299
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Passer les caractères < en < ?

    #572300
    DePassage
    Participant
    Initié WordPress
    11 contributions
    Xavier wrote:
    Passer les caractères < en < ?

    Oui j’avais lu ceci de ta part déjà dans un autre topic. Mais je n’ai essayé que pour les balises , pour moi ça aurait dû suffire à passer le reste en clair (le contenu entre les balises), parce que s'il faut éditer tous les en < dans tous les post contenant du php, ou pire du html qui contient énormément de , on s'en sort plus. A moins de faire une requête massive sur la base pour convertir tous les en < dans la table des post et commentaires, mais je trouve ça un peu barbare et risqué.

    Bon en attendant d'autres pistes, je vais tester avec un seul post contenant du html et éditer tous les

    #572301
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Certes, mais il te faudrait faire pareil pour n’importe quelle page Web.
    Maintenant, p’tet que je rate un plugin ou un option qui résoud ton problème…

    #572302
    DePassage
    Participant
    Initié WordPress
    11 contributions

    Je vais explorer ça, j’en reparlerai.

    Sinon as-tu une idée pour ce problème de m. en page sidebar ?

    #572303
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Sidebar : difficile à dire sans voir le site

    #572304
    DePassage
    Participant
    Initié WordPress
    11 contributions

    Il est dans un sous-domaine protégé, sans ça je l’aurais signalé en URL.
    Mais peut-être que je peux coller le source de certains fichiers, si tu sais m’indiquer lesquels peuvent être à l’origine du problème.

    #572305
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Plusieurs fichiers peuvent s’influencer entre eux, impossible de dire quel fichiers particuliers est en cause, il faut voir la chose en entier.

    #572306
    DePassage
    Participant
    Initié WordPress
    11 contributions

    Bonjour,
    en fait je peux reformuler ma question ainsi : quel est le ou les fichiers “maîtres” qui gèrent l’affichage (correct) de la homepage ainsi que de chaque catégories, indépendamment de chaque thème ?

    Je dis “maîtres” parce que je fais l’hypothèse que si j’ai la sidebar complètement en bas de page tant dans la homepage que dans les catégories, et quel que soit le thème, ce n’est pas un ou des thème qui est foireux chez moi mais bien un ou des fichiers indépendants qui commandent le tout.
    Je n’ai pas de problème en local – même thèmes – donc il est tout simplement possible que mon upload distant ait déconné pour ce ou ces fichiers particuliers, il me suffirait de ré-upoader, mais je ne sais pas quel(s) fichier(s)…

    Merci d’avance 😉

    #572307
    bisane
    Participant
    Initié WordPress
    46 contributions

    A priori, ce sont les fichiers du thème qu’il faut re-télécharger…
    Mais je me demande, en relisant ton post, s’il n’y a pas un problème dans un post, justement (une balise non fermée, par exemple). As-tu les mêmes posts en local et sur le web? Il me semble que ce serait la 1ère chose à vérifier…

    #572308
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Je remonte ce vieux sujet car je rencontre un problème identique.

    La balise de mon WP ne fonctionne pas. Ce qui m'empêche d'insérer du code HTML sans qu'il ne soit interpréter. Mon but étant bien sûr que le code apparaisse clairement dans mon article et mis en valeur...

    Mais WP s'entête à interprêter le code source indiqué malgré la présence de la balise ... 😕

    Si vous avez une idée pour me dépanner...

    #572309
    AmO
    Participant
    Maître WordPress
    4452 contributions

    J’utilise le plugin Code Hightliter pour cela 🙂

    #572310
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Bon je vais l’essayer alors… mais c’est tout de même embêtant que ce bouton “code” ne fonctionne pas… Il doit y avoir un problème quand même à quelque part.

    #572311
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Je reviens à la charge…
    J’ai installer CodeHighliter qui fonctionne a priori bien… seulement on vient de me signaler qu’il semble que sur des résolutions inférieur d’écran le code n’est pas renvoyé à la ligne automatiquement et il dépasse sur la sidebar… comment faire pour qu’il s’adapte à toute taille d’écran… Bref que dans toutes les situations le code nsérer dans un article ne pose pas de problème de présentation…

    Voir mon article qui est concerné.

    #572312
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Actuellement ma balise

     est configuré ainsi dans le CSS :
    pre { 
            border: 1px dotted #ccc;
            padding: 0.2em 0.5em;
            font: 1em/1.5em ‘lucida grande’;
            background: #EFEFEF;
    }

    Que dois-je ajouter ou enlever ?

15 sujets de 1 à 15 (sur un total de 20)
  • Vous devez être connecté pour répondre à ce sujet.