[Résolu] Intégrer police achetée sur mon site WordPress hébergé sur OVH (Créer un compte)

  • WordPress :5.2
  • Statut : résolu
  • Ce sujet contient 20 réponses, 4 participants et a été mis à jour pour la dernière fois par Anonyme, le il y a 4 années et 2 mois.
15 sujets de 1 à 15 (sur un total de 21)
  • Auteur
    Messages
  • #2291340
    fabidbe
    Participant
    Initié WordPress
    38 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : Tych
    • Extensions en place :
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://www.rhumantic.be

    Problème(s) rencontré(s) :

    Bonjour,
    J’aimerai intégrer une police que j’ai acheté et que je souhaiterai appliquer sur les titres de ma page.
    J’ai suivi un tuto sur cette page : https://wpformation.com/comment-modifier-sa-font-ou-police-decriture-dans-wordpress/
    Malgré que j’ai suivi scrupuleusement chaque étape, création de mon thème enfant avec la création des fichiers style.css et du fichier functions.php intégré dans le dossier du thème enfant… J’ai ensuite intégré dans le thème enfant les fichiers de ma police générés par le site ‘web font generator’, modifié le fichier style.css en y intégrant ces lignes :
    /*
    Theme Name: Theme enfant Rhumantic
    Description: Theme enfant site Rhumantic
    Author: Fabian – Rhumantic
    Author URI: https://www.rhumantic.be
    Template: tyche
    Version: 0.1.0
    */

    @font-face {
    font-family: ‘mahira‘;
    src: url(‘mahira.eot’);
    src: url(‘mahira.eot?#iefix’) format(’embedded-opentype’),
    url(‘mahira.woff2′) format(‘woff2’),
    url(‘mahira.woff’) format(‘woff’),
    url(‘mahira.ttf’) format(‘truetype’),
    url(‘mahira.svg#svgwpf‘) format(‘svg’);
    }

    h1, h2, h3, h4, h5, h6 {
    font-family: ‘wpf’, Arial, sans-serif !important;
    }
    Malgré avoir fait tout cela, la police ‘Mahira’ que j’ai achetée ne s’affiche pas.
    ça fait des heures que je suis dessus et j’aimerai vraiment savoir ou est mon erreur…
    Avez vous des pistes ou un autre tuto ?
    Merci d’avance pour votre aide,
    Fabian

    PS: J’ai déjà consulté ce sujet https://wpfr.net/support/sujet/installer-une-nouvelle-police/#post-2291338  mais je n’ai malgré tout pas réussi à solutionner mon problème.

    Je suis vraiment désespéré 🙁

     

    #2291343
    mathieu42
    Participant
    Maître WordPress
    2002 contributions

    essayez avec ce code CSS

    h1, h2, h3, h4, h5, h6 {
    font-family: "mahira";
    }

    #2291345
    fabidbe
    Participant
    Initié WordPress
    38 contributions

    Hello,

    Tout d’abord merci pour ta réponse, malheureusement ça n’a aucun effet sur les titres de ma page 🙁

    Voici mon code actuel depuis ta modification :

    /*
    Theme Name: Theme enfant Rhumantic
    Description: Theme enfant site Rhumantic
    Author: Fabian – Rhumantic
    Author URI: https://www.rhumantic.be
    Template: tyche
    Version: 0.1.0
    */

    @font-face {
    font-family: ‘mahira‘;
    src: url(‘mahira.eot’);
    src: url(‘mahira.eot?#iefix’) format(’embedded-opentype’),
    url(‘mahira.woff2′) format(‘woff2’),
    url(‘mahira.woff’) format(‘woff’),
    url(‘mahira.ttf’) format(‘truetype’),
    url(‘mahira.svg#svgwpf‘) format(‘svg’);
    }

    h1, h2, h3, h4, h5, h6 {
    font-family: « mahira »;
    }

     

     

    #2291347
    fabidbe
    Participant
    Initié WordPress
    38 contributions

    Je ne sais pas si ça change quelque chose mais j’utilise Elementor pour la création de ma page …

    #2291349
    Anonyme
    Invité
    Maître WordPress
    34067 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #2291354
    fabidbe
    Participant
    Initié WordPress
    38 contributions

    Je confirme que mon thème enfant est bien activé.

    J’ai tout refait à zéro et ma police n’apparaît toujours pas (malgré !important ajouté depuis ta remarque)

    Est ce que le fait que j’utilise Elementor ne changerait pas la donne ?

    #2291373
    mathieu42
    Participant
    Maître WordPress
    2002 contributions

    il y a un soucis avec les guillemets : http://rhumantic.be/wp-content/themes/tyche-child/style.css?ver=5.3.2​

    mettez des  » ou des ‘.

     

    #2291394
    Anonyme
    Invité
    Maître WordPress
    34067 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #2291397
    fabidbe
    Participant
    Initié WordPress
    38 contributions

    Bonjour Hervel,

    Loin de moi d’avoir voulu faire une remarque négative.  Ne sachant pas à quoi servait ce !important que j’ai simplement copier/coller d’un tuto, j’ai essayé sans suite à ta « proposition » ou « remarque » et ça n’a pas fonctionné.

    Je ne mettais pas en cause ta façon de t’adresser à moi ou je ne sais comment tu as pu le prendre.

    Bien à toi,

    Fab

     

    #2291398
    fabidbe
    Participant
    Initié WordPress
    38 contributions

    Bonjour mathieu42,

    Merci pour ta proposition.

    J’ai modifié les lignes en mettant soit des ‘ ou des  » et j’ai toujours le même résultat, càd pas ma police d’écriture sur les titres de ma page.

    Voici l’état de mon fichier style.css pour que tu puisses le constater :

    /*
    Theme Name: Theme enfant Rhumantic
    Description: Theme enfant site Rhumantic
    Author: Fabian – Rhumantic
    Author URI: https://www.rhumantic.be
    Template: tyche
    Version: 0.1.0
    */

    @font-face {
    font-family: ”mahira”;
    src: url(”mahira.eot”);
    src: url(”mahira.eot?#iefix”) format(”embedded-opentype”),
    url(”mahira.woff2”) format(”woff2”),
    url(”mahira.woff”) format(”woff”),
    url(”mahira.ttf”) format(”truetype”),
    url(”mahira.svg#svgwpf”) format(”svg”);
    }

    h1, h2, h3, h4, h5, h6 {
    font-family: « mahira »;
    }

    J’ai bien copié tous les fichiers de la police « Mahira » à la source du dossier enfant au cas ou …

    Une autre proposition ?  Je suis prêt à suivre une autre façon de faire si il faut y a aucun soucis, je suis vraiment novice donc ouvert à tout 😉

    Merci d’avance pour votre aide,

    • Cette réponse a été modifiée le il y a 4 années et 2 mois par fabidbe.
    #2291400
    PhiLyon
    Modérateur
    Maître WordPress
    28264 contributions

    Bonjour.

    Pour l’instant ton site est HS, tu as fait quoi ?

    🙂

    #2291401
    fabidbe
    Participant
    Initié WordPress
    38 contributions

    Bonjour Philyon,

    Je l’avais mis en « privé »… Hum Hum

    Il est maintenant ouvert !

    #2291403
    Anonyme
    Invité
    Maître WordPress
    34067 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #2291404
    fabidbe
    Participant
    Initié WordPress
    38 contributions

    J’ai créé le fichier style.css avec Notepad++ que j’ai donc enregistrer au format .css puis que j’ai uploadé sur mon serveur FTP via FileZilla.

    Le fait qu’il soit UTF-8 sans bom ne me parle malheureusement pas dutout.  Dois je refaire mon fichier ?

    #2291405
    Anonyme
    Invité
    Maître WordPress
    34067 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

15 sujets de 1 à 15 (sur un total de 21)
  • Vous devez être connecté pour répondre à ce sujet.