Intégrer forum et wordpress (Créer un compte)

  • Statut : non résolu
7 sujets de 76 à 82 (sur un total de 82)
  • Auteur
    Messages
  • #583142
    Benoit V.
    Participant
    Initié WordPress
    40 contributions

    Bah de rien. 😋

    #583143
    maxime
    Participant
    Initié WordPress
    7 contributions

    Je viens d’essayer et ça ne marche pas …

    J’ai fait les modifs écrites mais j’ai des erreurs du type function not found dans les fichiers footer et header que j’ai modif …

    J viens de lire sur le sujet que l’organisation des dossiers faite pour l’explication était :
    Site
    |–> /blog
    |–> /forum

    Alors que moi j’avais :
    Site
    |–> /forum
    |–> /blog

    Je change l’organisation et je regarde si ça fonctionne mieux …

    #583145
    maxime
    Participant
    Initié WordPress
    7 contributions

    Ok alors je viens de faire le changement et ça marche :D

    Juste deux petits problèmes :
    Si je supprime cette ligne le blog a une taille de texte normale mais celui du forum est tout petit … Mais si je la garde le forum est à une taille de polices normale mais le blog est écris en gros …

    Oxygen.css
    Remove

    Quote:
    html, body, /* remove this line if necessary for site integration */

    Je ne peux pas modifier selon ces recommandations je ne trouve pas ces lignes dans les fichiers … Apparemment ces derniers ont été modifiés depuis …

    Oxygen.css
    Replace

    Quote:
    body {
    font-size: 100%;
    }

    with

    .brd {
    font-size: 150%;
    }

    Oxygen_cs.css
    remove

    body {
    background: #fff;
    color: #333;
    }

    Mon problème de polices vient très sûrement de ces lignes …

    Une idée pour y remédier ?

    #583146
    maxime
    Participant
    Initié WordPress
    7 contributions

    Début de réponse à ma propre question :D

    Alors il faut :

    Dans Oxygen.css
    Supprimer la ligne

    Quote:
    html, body, /* remove this line if necessary for site integration */

    Remplacer

    .brd { /* Needs modifying if body has non default font-size */
    font: 75%/130% Verdana, Arial, Helvetica, sans-serif;
    }

    with

    .brd { /* Needs modifying if body has non default font-size */
    font: 120% Verdana, Arial, Helvetica, sans-serif;
    }

    Le % étant la taille de la police … C’est pour ça que j’avais jamais la bonne taille : soit j’étais à 75% soit à 130% … J’aime bien 120% mais 100% est la taille “normale” …

    Par contre ce morceau

    Dans Oxygen_cs.css
    Supprimer

    Quote:
    body {
    background: #fff;
    color: #333;
    }

    je pense que c’est devenu ça

    .brd {
    color: #333;
    }

    #brd-title {
    color: #fff;
    }

    Mais en le supprimant j’ai juste le titre du forum qui passe du blanc au gris foncé …
    Donc soit je me suis trompé de morceau soit cette modif n’a pas beaucoup d’intérêt …

    #583144
    maxime
    Participant
    Initié WordPress
    7 contributions

    En fait il reste des erreurs …
    Lorsque je navigue dans le forum tout fonctionne nickel, que ce soit dans la partie admin, liste des membres, lors de la connexion et de la déconnexion …
    Mais lorsque je clique sur le le lien “Profile” j’obtiens cette erreur :

    Fatal error: Cannot redeclare output_forum_head() (previously declared in /mnt/102/sda/2/0/monsite/blog/forum/footer.php:101) in /mnt/102/sda/2/0/monsite/blog/forum/footer.php on line 103

    Lorsque je clique sur “New Posts” j’obtiens celle-ci :

    Fatal error: Call to a member function set_prefix() on a non-object in /mnt/102/sda/2/0/monsite/blog/wp-settings.php on line 247

    Lorsque je clique sur “Search” la page de recherche s’affiche mais si j’effectue une recherche :

    Fatal error: Call to a member function set_prefix() on a non-object in /mnt/102/sda/2/0/monsite/blog/wp-settings.php on line 247

    Pour l’instant ce sont les seules erreurs que j’ai trouvé …

    Dans le fichier footer.php de la ligne 96 à 105 il y a (c’est un des morceaux de code que j’ai rajouté pour l’intégration …) :

    96 /** Loads the WordPress Environment and Template */
    97 require(FORUM_ROOT.’../wp-blog-header.php’);
    98
    99 function output_forum_head()
    100 {
    101 global $forum_head_content;
    102 echo $forum_head_content;
    103 }
    104
    105 add_filter(‘wp_head’, ‘output_forum_head’, 10, 0);

    Dans le fichier wp-settings.php à la ligne 247 il y a :

    $prefix = $wpdb->set_prefix($table_prefix);

    Pourquoi apparaissent-elles ? Une idée pour les faire disparaitre ?

    #583147
    agony
    Participant
    Initié WordPress
    32 contributions

    Bonjour,

    topic intéréssant !

    J’aimerai savoir comment virer les marges avec une iframe svp.
    car à l’intégration il y a un décallage ?

    Many a fait un tuto pour l’intégration dans une page WP en virant la colonne ? ca m’interesse svp 🙂

    #583148
    AntoBFH
    Participant
    Initié WordPress
    14 contributions

    Salut!
    J’aimerais intégrer mon menu personnalisé dans mon header mais je ne sais pas comment faire, mon forum:
    http://teamep.gaming.multiplay.co.uk/forum/index.php
    Et le site:
    http://teamep.gaming.multiplay.co.uk/

7 sujets de 76 à 82 (sur un total de 82)
  • Le forum ‘Utilisation spécifique de WordPress’ est fermé à de nouveaux sujets et réponses.