Installer WPMU en local sur un mac avec MAMP (Créer un compte)

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #449461
    imported_Damino
    Participant
    Padawan WordPress
    72 contributions

    Salut, autant j’ai installé sans problème wordpress en local sur mon mac avec MAMP, autant là je galère pour WPMU.
    Certains l’ont-il installé avec succès ?

    Merci.

    #585102
    devrugby
    Participant
    Initié WordPress
    6 contributions

    je débute avec wordpress.

    j’ai essayé sur mamp, l’install est à peu près ok, mais je ne reçoit jamais de mail de confirmation.
    je donne des nouvelles si j’avance.

    #585103
    LH
    Membre
    Chevalier WordPress
    372 contributions

    Salut,

    En local, tu as rarement un serveur de mail d’installé. Donc la plupart du temps, tu ne recevras pas de mail! Il faut bien noter les login/mot-de-passe affichés et autrement, il faut changer directement le mot de passe dans la base de données :(

    #585106
    Charger
    Participant
    Initié WordPress
    12 contributions

    Bonjour,
    je suis dans la même situation que Damino. WordPress MU en local sur Mac: fiction ou réalité?

    En tout cas, je ne compte plus les posts français ou anglais laissés à l’abandon à ce sujet.

    #585105
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Le mot de passe est donner a la fin de l’installation pour les versions les plus récentes.
    Sinon c’est quoi le prb ?

    #585107
    Charger
    Participant
    Initié WordPress
    12 contributions

    Je parviens à valider la première page d’installation WordPress (avec les réglages serveurs) pour arriver ensuite avec bonheur sur la seconde qui me confirme que WordPress a été installé avec succès. Je clique ensuite sur le lien censé me rediriger vers ma section d’administrateur et là… c’est le drame: un message m’annonce “Aucun site WPmu défini sur ce serveur. Si vous êtes le propriétaire de ce site, merci de consulter la page Debugging WPMU pour obtenir de l’assistance.”

    Que faire?

    Merci. 😉

    #585108
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Avec la toute dernière version 1.3.3 ?

    #585104
    Charger
    Participant
    Initié WordPress
    12 contributions

    Oui, téléchargée ici même: http://www.wordpress-fr.net/support/sujet-6468-testez-nouvelle-traduction-wpmu-pack-francais

    Souhaites-tu que j’écrive tout ce que j’ai fait jusque là ou tu as déjà une idée du problème?

    #585109
    AmO
    Participant
    Maître WordPress
    4451 contributions

    Tu utilises quel adresse pour installer WP ?

    localhost ?

    #585110
    Charger
    Participant
    Initié WordPress
    12 contributions

    Oui, voici ce que j’ai mis dans le fichier wp-config-sample.php:

    define(‘DB_NAME’, ‘wordpress’);    // Le nom de la base de donnees
    define(‘DB_USER’, ‘root’);     // Votre identifiant MySQL
    define(‘DB_PASSWORD’, ‘root’); // …et votre mot de passe
    define(‘DB_HOST’, ‘localhost:80’);    // Dans la plupart des cas, vous n’aurez pas a modifier cette ligne
    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ”);
    define(‘VHOST’, ‘VHOSTSETTING’); 
    $base = ‘BASE’;

    Mon adresse exacte est donc: http://localhost:80/wordpress/

    #585111
    Charger
    Participant
    Initié WordPress
    12 contributions

    Voilà maintenant l’autre message que Safari m’envoie lorsque j’essaye d’accéder à mon espace administrateur après que WordPress m’ait confirmé la réussite de l’installation: “Safari ne parvient pas à ouvrir la page. Trop de redirections sont survenues en tentant d’ouvrir “http://localhost:80/wordpress/wp-signup.php”. Ceci peut se produire lorsque vous ouvrez une page qui est redirigée vers une autre page laquelle se redirige à son tour vers la page originale.”

    #585112
    MICKAEL
    Membre
    Initié WordPress
    19 contributions

    Salut à tous.
    Je travail avec WP mu en local, avec MAMP, je vais essayer de vous aider.
    (l’instal ne peu se faire qu’en sous-repertoire me semble-t-il)

    -dans les preferences de MAMP: port apache : 80
    -faire une copie backup de application/MAMP/conf/apache/httpd.conf
    -dans httpd.conf remplacerla derniere ligne qui doit etre

    # NameVirtualHost *

    par

    NameVirtualHost 127.0.0.1
    
    
        DocumentRoot /Applications/MAMP/htdocs
        ServerName 127.0.0.1
    
    
    
        DocumentRoot /Applications/MAMP/htdocs/monsite1.com
        ServerName dev.monsite1.com
    
    
    
        DocumentRoot /Applications/MAMP/htdocs/monsite2.com
        ServerName dev.monsite2.com

    ( les DocumentRoot et ServerName que vous créez sont des dossiers dans MAMP/htdocs/ qui agissent comme des noms de domaines sur votre serveur)

    -dans Utilitaires/Gestionnaire NetInfo, allez sur /machines/localhost/
    -deverouillez le cadenas en bas à gauche (nom et password administrateur)
    -dupliquez /machines/localhost/ : ip_adresse: 127.0.0.1 et name: dev.monsite1.com
    -cliquez sur la zone /machines pour confirmer
    -vous pouvez recommencer pour un 2eme nom de domaine ex: dev.monsite2.com
    -Quitez Gestionnaire Netinfo

    Passons à l’instal de wpmu:
    -creez une db
    -Dans Applications/MAMP/htdocs déposer votre dossier wpmu dézipé et renommer le monsite1.com
    (quand vous allez ecrire l’adresse http://dev.monsite1.com, vous serez dans votre dossier wpmu monsite1.com)
    -d’ailleurs allons y, dev.monsite.com dans la barre d’adresse ….go
    -vous tombez normalement sur la page d’instal
    -choissisez instal en sous-repertoire
    -remplissez tous les champs dbname, root, root, localhost, meme le mail (ex:a@a.a)
    -si tout se passe bien vous arrivez sur la confirmation d’instal avec le mot de passe , connectez vous et changez votre mot de passe immediatement ( ca evite d’aller dans la db si on l’oubli)

    le tour est joué, amusez vous bien
    j’espere que c’est assez claire ????

    #585113
    zadig
    Membre
    Chevalier WordPress
    244 contributions

    J’ai regardé ce tuto avec intérêt mais je bute sur un point : “Gestionnaire NetInfo” n’existe plus sous Léopard.

    forum de MacBidouille.

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.