Installer WP en local à partir d’un WP « en ligne » (Créer un compte)

  • Statut : non résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #520039
    Insky
    Membre
    Initié WordPress
    22 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress :WordPress 3.4.1
    – Version de PHP/MySQL : nc
    – Thème utilisé : The Morning After 3.3.1
    – Extensions en place : WP-DBManager – Cforms – google analytics – quick chat (principalement)
    – Nom de l’hebergeur : Ovh (ou 1and1 je ne sais plus)
    – Adresse du site : asptt-pau-badminton.com

    Problème(s) rencontré(s) :
    Avant un changement complet de template, j’aimerais faire un backup complet du site tel qu’il est, et le déployer en local.
    J’ai donc sauvegardé via fillezilla tout le contenu ftp du site + procédé à un backup de la BDD que je me suis envoyé par e-mail.

    De là, j’ai fais placé un dossier « asptt-pau-badminton.com », dans le dossier « www » de Wamp. Puis, dans phpmyadmin, j’ai créée une bdd (du même nom que celle fournie par l’extension de backup de bdd), je suis rentré dans cette bdd tout juste créee, et j’ai importé à partir du fichier de backup, le contenu. Pas de message particulier.

    Enfin, édition du fichier wp-config.php en remplaçant le nom de la bdd (déjà bon), l’utilisateur et mdp de la bdd (en reprenant ceux par défaut, soit « root », et  » vu qu’il n’y a pas de mdp..), et enfin l’adresse de l’hébergement en mettant ‘localhost’.

    Je teste, et là, c’est le drame!
    Erreur 404… je reconnais bien le site en fond… mais par contre où que je clique, tous les liens sont les liens externes du site en ligne… rien n’est « local ».

    Où ai-je cafouillé ?
    Merci pour votre aide
    Cordialement,

    Laurent

    #877585
    Franck (fge)
    Modérateur
    Maître WordPress
    9573 contributions

    Dans le fichier d’export de la base de données, il faut remplacer toutes les URL faisant référence au site en ligne par les URL du site local. Utilise un logiciel comme Notepad++ pour le faire sans problème.

    #877586
    Insky
    Membre
    Initié WordPress
    22 contributions

    Je ne suis pas sur de comprendre. Avant l’import du fichier sql (que l’extension WP DB BACKUP me donne) dans mon phpmyadmin local, j’ouvre ce fichier et remplace tous les « asptt-pau-badminton.com » par « localhost » ? C’est bien çà ? Jusqu’ou faut il remplacer ? « www » également ?

    Merci pour ces précisions,
    Cordialement,

    Laurent

    #877587
    Flobogo
    Modérateur
    Maître WordPress
    18417 contributions

    J’ai été confrontée au même problème il y a quelques semaines … Ce fil de discussion (par Luciole135 et Guy) m’a bien dépannée !

    #877588
    Franck (fge)
    Modérateur
    Maître WordPress
    9573 contributions

    Oui, l’adresse originale (avec les www) doit être remplacée par l’adresse du blog en local, soit localhost s’il est installé à la racine, soit localhost/wordpress s’il est installé dans un sous-répertoire.

    #877589
    Insky
    Membre
    Initié WordPress
    22 contributions

    Je viens de lire l’article intéressant en effet bien qu’il ne m’aide pas directement.

    En passant par Dream, je viens de modifier la bdd en faisant recherche et remplacer « http://www.asptt-pau-badminton.com » par « http://localhost/asptt-pau-badminton.com », puis, sauvegarde de ce fichier. Je suis retourné dans phpmyadmin, ai supprimer tout le contenu de la bdd, avant d’importer à nouveau le contenu du nouveau fichier… mais j’obtiens un message d’erreur  » MySQL a répondu: Documentation
    #2006 – MySQL server has gone away ».
    Donc pas moyen de remettre la BDD… je comprends pas pourquoi :( ?

    J’ai revidé la bdd et réimporter le premier sql non modifié, çà passe, mais celui où j’ai remplacé les url, çà ne passe pas…

    #877590
    Insky
    Membre
    Initié WordPress
    22 contributions

    Edit :
    Je viens de renommer mon répertoire (me disant que çà pouvait venir de là…), aussi le chemin d’accès est désormais localhost/asptt
    J’ai repris mon fichier bdd original, j’ai refais la modif des liens, réimporté à nouveau, cette fois pas d’erreur… je reviens donc sur mon WP local, cette fois je n’ai plus une erreur 404, par contre une partie du template à disparue (il y a un menu en dur dans le template avec « home » « archives » etc.. qui n’apparait plus, et les « featured articles » également, plus là… autre chose, quand je clique sur un lien (de type : http://localhost/asptt/resultats/resultats-tournoi-daire-sur-ladour-665), je reviens systématiquement sur l’index de wamp… (l’url dans ma barre d’adresse est alors par exemple : http://localhost/asptt/resultats/resultats-tournoi-daire-sur-ladour-665), pourtant c’est bien l’index de wamp qui est affiché, et tous les liens de l’index sont modifiés. Exemple pour le lien phpmyadmin, l’url est : http://localhost/asptt/resultats/phpmyadmin/ (ce qui bien sur ne fonctionne pas…).

    Bref, je suis un peu perdu.. j’ai l’impression d’avoir fait un pas en avant et un en arrière… avec l’impression que le problème vient des url mais je patauge…

    #877591
    Insky
    Membre
    Initié WordPress
    22 contributions

    dernier détail, j’ai refais le test en cliquant sur un article d’une autre catégorie (actualites), et çà fait pareil, les liens de l’index wamp contient alors tous http://localhost/asptt/actualites/le-lien-en-question

    #877592
    ombres-et-lumieres
    Membre
    Chevalier WordPress
    147 contributions

    J’ ai une installation « en double », localhost et en ligne.
    Et je n’ ai aucun problème avec les downloads de ma base de données en ligne. Enfin presque. Mais ma procédure n’ est pas la même.

    Pour ce faire, il faut d’ abord créer en local une installation de wp vierge. Ensuite y installer le thème et les plugins qui sont en ligne. Ensuite, dans l’ admin, il y a un onglet « outils » qui permettent des exportations et importations. Je vais donc en ligne et depuis cet outil, je récupère toutes, enfin presque toutes les données de la base de données. Ensuite, en local, via le même onglet, j’ active l’ outil uploader dans wordpress ( c’ est un simple plugin qui va s’ installer automatiquement). Je récupère le fichier xml (si mes souvenirs sont bons) et l’ upload. Il me demande à quel utilisateur les articles doivent être attribués et lance la moulinette.
    Peu de temps après tu constateras que tes articles en ligne se retrouvent dans ton installation en local, sans avoir le problème d’ adressage que tu as rencontré.

    Cette procédure a un gros avantage: celui de travailler « dans le relatif » et donc de ne pas récupérer des adresses absolues. Mais elle a aussi un gros inconvénient: celui de ne pas récupérer l’ entièreté de la base de données. Les tables ajoutées par des plugins ne sont pas récupérées ainsi que d’ autres choses plus basiques, par exemple les attachments.
    J’ ai également parfois dû faire des ajustements du côté des menus.

    Mais, de mon point de vue, un site en local n’ est en fait qu’ un simulacre permettant de faire des test lorsqu’ on décide de modifier tel ou tel point et, donc se suffirait d’ un simple « lorem ipsum ».

    #877593
    Insky
    Membre
    Initié WordPress
    22 contributions

    C’est une méthode alternative mais qui me parait plus contraignante dans l’absolu qu’en récupérant d’un côté le contenu du ftp en local + la bdd. Normalement c’est sensé être plus rapide (quand çà veut bien marcher!).
    Dans la mesure du possible je préfèrerais autant disposer d’un « miroir » en local.

    Car installer une version WP vierge créera dès le départ une différence de version (le site en question n’utilisant pas la dernière version..)

    #877594
    Franck (fge)
    Modérateur
    Maître WordPress
    9573 contributions

    par contre une partie du template à disparue

    Les pemaliens sont rarement activés par défaut sur les installation locales, ce qui pourrait expliquer le problème. Deux solutions, soit activer les permaliens dans l’installation locale en activant le « rewrite_mod » dans la configuration d’Apache, soit remettre dans les paramètres de WordPress local les permaliens par défaut (suppression de .htaccess et suppression de la valeur « permalink_structure » dans la table wp-options)

    #877595
    ombres-et-lumieres
    Membre
    Chevalier WordPress
    147 contributions

    j’ ignore quel type de machine tu utilises, mais en cherchant autre chose je viens de trouver ceci dans le codex, qui pourrait, peut-être t’ aider, valable uniquement pour mac.
    http://codex.wordpress.org/MacOS_X_Local_Mirror

    #877596
    Flobogo
    Modérateur
    Maître WordPress
    18417 contributions
    Insky wrote:
    En passant par Dream, je viens de modifier la bdd en faisant recherche et remplacer « http://www.asptt-pau-badminton.com » par « http://localhost/asptt-pau-badminton.com »,

    –> l’erreur vient du http:// qui ne doit pas figurer dans l’adresse en local !

    Je vous invite à relir le 1er post de Luciole135 sur cette page

    #877597
    Guy
    Participant
    Maître WordPress
    14817 contributions
    Flobogo wrote:
    l’erreur vient du http:// qui ne doit pas figurer dans l’adresse en local !

    Ce n’est pas exactement cela, il s’agit d’être cohérent dans les remplacements. Soit on met le http:// dans les deux termes soit dans aucun:

    http://www.old_domaine.com => http://localhost
    ou
    http://www.old_domaine.com => localhost

14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.