Installer image manager? (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 19)
  • Auteur
    Messages
  • #451660
    chupastar
    Participant
    Initié WordPress
    21 contributions

    Bonjour,

    Je suis en train d’essayer d’installer la dernière version (v2.4.1) plugin image manager, sur la dernière version de WP (2.1.3), j’ai donc envoyé la totalité du fichier d’image manager sur le serveur comme mes autres plugin, je l’ai activé dans la console de gestion des plugin, mais quand je clique sur “option” , WP m’indique “Impossible de charger imagemanager-plugin.php.” pourtant le ichier est bien présent sur le serveur…

    Aussi, dans la aprtie d’écriture des billets, le bouton imagemanager est présent mais rien ne se passe lorsque qu’on clic dessus.

    Où est l’erreur?

    Merci.

    Mon site: http://www.picsmaker.net

    #598437
    Elisabeth
    Participant
    Chevalier WordPress
    130 contributions

    tu peux peut être essayer de recharger Image Manager sur ton site, le fichier imagemanager-plugin.php est peut être défectueux

    #598438
    chupastar
    Participant
    Initié WordPress
    21 contributions

    Non, ça ne change rien…

    #598439
    Elisabeth
    Participant
    Chevalier WordPress
    130 contributions

    As tu d’autres plugins installés, peut-être qu’il y a un conflit ???

    #598440
    chupastar
    Participant
    Initié WordPress
    21 contributions

    Oui j’en ai d’autres:

    ImageManager
    akismet
    google-sitemap-generator
    hello.php
    mylinkorder
    popularity-contest
    simpler-wordpress.php smiley_js_buttons.php
    spotmilk
    srg_clean_archives.php
    stats
    textile 2
    wp-admin-tiger

    Merci.

    #598441
    Elisabeth
    Participant
    Chevalier WordPress
    130 contributions

    essaye de désactiver celui-ci wp-admin-tiger

    #598442
    chupastar
    Participant
    Initié WordPress
    21 contributions

    Ça ne change rien, j’ai aussi désactivé spotmilk (peut être qu’ils cohabitaient mal tous les deux…)

    #598443
    Elisabeth
    Participant
    Chevalier WordPress
    130 contributions

    Désactive tous les plugins pour voir, puis active seulement image manager + ensuite : vide le cache de ton navigateur puis une MAJ par ctrl +F5 ou upgrade.php

    #598444
    chupastar
    Participant
    Initié WordPress
    21 contributions

    Avec tous les plugins désactivé ça ne marche pas non plus… Y a vraiment un problème…

    Et sinon la page se met à jour toute seule après avoir modifié l’état d’un plugin, mais j’ai quand même re-rafraîchit la page quand même, mais sans résultats…

    #598445
    Elisabeth
    Participant
    Chevalier WordPress
    130 contributions

    et tu as toujours le même message d’erreur dans option ?

    #598446
    chupastar
    Participant
    Initié WordPress
    21 contributions

    Toujours!

    Je viens de recharger/transferer entièrement le plugin, ça n’a rien changé…

    #598447
    Elisabeth
    Participant
    Chevalier WordPress
    130 contributions

    Peut être une piste

    #598448
    chupastar
    Participant
    Initié WordPress
    21 contributions

    Cool, c’est installé et je peux accéder à la page d’option. Mais (car il y a toujours un mais…) lorsque je suis dans la page d’édition des billets, quand je clic sur le bouton “image manager” ça me renvoie vers une page d’erreur 404…

    #598449
    Elisabeth
    Participant
    Chevalier WordPress
    130 contributions

    tu peux peut être essayer ça :

    Elisabeth wrote:
    As tu fait les trois modif indiquées dans mon message à savoir:
    1) Créer un fichier (sans rien dedans) editor_plugin.js dans le dossier wp-include/js/tinymce/plugins/
    2) ouvrir avec un éditeur le fichier tiny_mce_gzip.php situé dans /wp-includes/js/tinymce/ et modifier comme suit (cf en gras) à partir de la ligne 173:

    $plugins = explode(“,”, $plugins);
    foreach ($plugins as $plugin) {

    if ($plugin != ”) {

    $pluginFile = realpath(“plugins/” . $plugin . “/editor_plugin” . $suffix . “.js”);
    /* WP $languageFile = realpath(“plugins/” . $plugin . “/langs/” . $lang . “.js”); WP */

    if (file_exists($pluginFile))
    TinyMCE_echo(file_get_contents($pluginFile));

    /* WP if ($languageFile) WP */
    TinyMCE_echo(wp_tinymce_lang(“plugins/” . $plugin . “/langs/%s.js”)); // WP

    }
    }

    Ce sont les modif faites sur 3 blogs (2 sur le web et un en local, tous les trois avec des thèmes différents) et ça a marché ! Peut être qu’avec un peu de chance ça fonctionnera pour toi aussi 😉

    Il y a peut être aussi une question de rafraichissement de ton site, lorsque les modifs sont faites, le plugin image manager réactivé (si tu l’avais désactivé), tu peux vider le cache de ton navigateur et faire un CTRL+F5 ou wp-admin/upgrade.php

    #598450
    chupastar
    Participant
    Initié WordPress
    21 contributions

    Impeccable! Merci beaucoup!

    Dommage, j’ai l’impression qu’il n’y a pas d’option pour placer l’image au centre (

    ou un truc du genre que je suis sans cesse en train de copier coller pour centrer mon image).
15 sujets de 1 à 15 (sur un total de 19)
  • Vous devez être connecté pour répondre à ce sujet.