installation wordpress en local (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 56 réponses, 8 participants et a été mis à jour pour la dernière fois par Osara, le il y a 9 années et 9 mois.
15 sujets de 1 à 15 (sur un total de 57)
  • Auteur
    Messages
  • #518478
    webmaster59
    Membre
    Chevalier WordPress
    124 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.3.2
    – Version de PHP/MySQL :
    – Thème utilisé :
    – Extensions en place :
    – Nom de l’hebergeur : 1&1
    – Adresse du site :

    Problème(s) rencontré(s) :

    Je rencontre un problème lors de l’installation de mon site en local (via wampserver), j’ai une erreur 404. Le head et le footer s’affichent correctement, mais pas le corps du site. J’ai une erreur 404. Cela pourrait-il être un pb de lien ? Un pb de configuration à l’installation ? Je pense que ça ne doit pas être trop compliqué mais je sèche.

    D’avance, merci

    #871858
    luciole135
    Participant
    Maître WordPress
    13735 contributions

    je dois être aussi peu doué que vous, je ne suis jamais arrivé à faire focntionner WAMPP mais j’ai réussi avec XAMPP : http://blogtoolbox.fr/installer-wordpress-localement/

    #871859
    piekes
    Membre
    Maître WordPress
    724 contributions

    Hello
    Si tu touches un tout petit peu tes billes, laisse tomber Apache, PHP, MySQL sous Windows.
    Essaye de travailler avec VirtualBox en faisant tourner une VM Linux. Que du bonheur ! Quel pied par rapport à mes anciens déboires avec les Wampp, Easy machin et j’en passe…

    #871860
    webmaster59
    Membre
    Chevalier WordPress
    124 contributions

    Bonsoir,

    merci pour le conseil pour virtualbox mais j’aimerai d’abord résoudre ce pb avec wamp. Je n’ai pas le contenu principal de l’index , quelqu’un pourrait il m’aider? j’ai une belle erreur 404 😉

    #871861
    Spidlace
    Membre
    Chevalier WordPress
    118 contributions

    Personnellement, j’utilise depuis quelques temps ce tutoriel avec lequel je n’ai jamais eu aucun soucis 😉

    http://www.scriptol.fr/wordpress/installer-localement-wordpress.php

    #871862
    Guy
    Participant
    Maître WordPress
    14817 contributions

    – Avec un des thèmes par défaut est ce que cela fonctionne
    – As tu accès au panneau d’administration
    – Quelle est ta configuration de permaliens

    #871863
    Flobogo
    Modérateur
    Maître WordPress
    18599 contributions

    Bonjour,

    Je confirme l’intérêt du lien indiqué par Spidlace, il m’avait également été bien utile.

    J’en profite pour poser une petite question : est-ce possible d’avoir 2 installations en local ?
    En fait, j’en ai déjà une qui tourne avec WP 3.4.2 comme sur mon « vrai » site pour l’instant, mais j’aimerai tester WP 3.5 « sans risques ».
    Et vu que la dernière fois, j’ai galéré pour le ré-inntaller en local (je n’avais plus le tuto ci-dessus, cette fois, je l’ai mis dans mes favoris), je ne veux pas courir le risque de me retrouver à devoir encore tout réinstaller si WP 3.5 buggue avec mes extensions.

    Donc, comment installer un 2ème WP en local, à l’aide de WAMP ?Merci d’avance si vous pouvez me guider.

    #871864
    luciole135
    Participant
    Maître WordPress
    13735 contributions
    Flobogo wrote:
    J’en profite pour poser une petite question : est-ce possible d’avoir 2 installations en local ?
    En fait, j’en ai déjà une qui tourne avec WP 3.4.2 comme sur mon « vrai » site pour l’instant, mais j’aimerai tester WP 3.5 « sans risques ».

    Il suffit dans ce créer un dossier (appelé par exemple test35) à la racine du site local (sous WAMPP je ne sais pas comment s’appelle la racine) et d’installer WP 3.5 avec la procédure usuelle.
    Il suffira d’ajouter /test35 au nom du site local dans le navigateur pour lancer l’installation.

    #871865
    Guy
    Participant
    Maître WordPress
    14817 contributions

    La racine s’appelle www.

    Au niveau de l’organisation, je préfère ne pas installer de sites directement à la racine (dans le www) mais dans des sous dossiers.

    Tu peux ensuite y accéder par http://localhost/wordpress/site1 , etc… Si tu veux définir une url plus « sexy », tu peux créer des hôtes virtuels (virtual hosts).

    #871866
    Flobogo
    Modérateur
    Maître WordPress
    18599 contributions

    Merci à vous, Luciole135 et Guy.
    Mais je ne comprends pas bien la différence entre vos solutions, enfin, surtout, je ne comprends pas bien ce que propose Guy :
    – Pour Luciole : un dossier à la racine du site (effectivement www pour le site local) dans lequel on réinstalle WP 3.5 , ça je comprends
    – Pour Guy : dans un sous-dossier … [mais un sous-dossier de quoi ? de quel dossier ?] … et pour ré-installer aussi ne version de WP 3.5 ? ça change quoi ?

    Quant à créer des hôtes virtuels … autant me parler chinois. 😕
    Si déjà j’arrive à créer un 2ème site virtuel en local, ça me suffira … URL sexy ou pas 😉
    (c’est pas pour le fun de l’URL, c’est juste pour tester WP 3.5)

    #871851
    Lumiere de Lune
    Participant
    Maître WordPress
    20483 contributions

    Dans un sous dossier du dossier www.
    Guy et Luciole disent exactement la même chose.

    #871867
    webmaster59
    Membre
    Chevalier WordPress
    124 contributions

    Bonjour,

    Guy :
    – Je n’ai pas essayé avec des thèmes par défaut, comment tester sans désinstaller le thème personnalisé?
    – oui, j’ai accès au panneau dans wamp (si c’est cela à quoi tu fais référence?)
    – les permaliens sont par exemple : http://www.monsite/titre-de-mon-article , j’ai également sélectionné rewrite_module dans wamp/apache/ModuleApache

    #871868
    webmaster59
    Membre
    Chevalier WordPress
    124 contributions

    Pour résumer,

    j’ai bien le head, le footer, une partie du css (avec mon bakground etc) mais je n’ai pas le contenu principal de la page index. A savoir qu’une ami m’avait dépanné pour ce pb sur un autre poste (pc), pb qu’il avait résolu.

    J’ai voulu refaire l’installation sur un autre poste, mais je n’arrive pas à afficher tout le contenu de l’index. J’ai modifié, le fichier wp.config, importer la bdd, modifier les fichiers php.ini pour augmenter l’espace de stockage etc mais rien n’y fait il manque une partie de l’index.

    Je ne pense pas que cela soit très compliqué, mais je ne vois pas trop d’ou vient le pb

    #871869
    Osara
    Invité
    Maître WordPress
    34107 contributions

    J’ai installé WP sous MampServer et WampServer sans difficulté. Essaye comme Guy le mentionné avec le thème par défaut. Si celui-ci ne pose pas de problème, cela est dû au thème utilisé. Autrement peut-être un petit souci à l’installation, un fichier corrompu …

    #871870
    Spidlace
    Membre
    Chevalier WordPress
    118 contributions

    @Flobogo,

    Pour installer un deuxième wordpress en local, il te suffit d’aller dans PhpMyAdmin et de créer une nouvelle base de donnée que tu nommes comme bon te semble.

    Puis dans ton dossier www de wamp, créer un nouveau dossier et nomme le à ta guise. Et enfin met tout tes fichiers de wordpress 3.5 à l’interieur ( wp-content, wp-config etc etc… )
    Puis quand tu le lanceras via l’adresse : localhost/nomdetondossier/, et qu’il te demandera de configurer le fichier config dans la rubrique Nom de la base de donnée, rentres y la nouvelle base de donnée que tu as créé puis pour le reste il te suffit de remplir comme indiquer dans le lien que j’ai mis 🙂

    L’importance de créer une nouvelle base de donnée est d’éviter toute erreur entre l’ancien wordpress que tu as et le nouveau que tu décides d’installer. Pour ne pas avoir de conflit entre les wp_ 😉
    Si je n’ai pas été clair dis le moi 🙂

    @webmaster59,

    Le lien que j’ai indiqué plus haut ne t’as pas aidé ?

15 sujets de 1 à 15 (sur un total de 57)
  • Vous devez être connecté pour répondre à ce sujet.