[Résolu] Installation de php ne marche pas. (Créer un compte)

  • WordPress :5.2
  • Statut : résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #2293632
    MathiAs2Pique
    Participant
    Initié WordPress
    32 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : php : 7.3 mysql : 10
    • Thème utilisé :  Colibri
    • Extensions en place :  non important
    • Nom de l’hébergeur : Raspberry pi 0
    • Adresse du site : privé, désolé.

    Problème(s) rencontré(s) :

    Mon site avait quelques problèmes de lenteurs, depuis quelques temps. Par conséquent, j’ai essayé de tout mettre à jour, en commençant par php, qui était installé à la version 7.1. Or, après avoir désinstallé php7.1 et installé php7.3 et ses modules,  j’ai comme l’impression que l’installation n’a pas marché, ou qu’il y a un problème. En effet, quand je veux accéder à mon site, voilà ce qu’il me renvoie:

    <?php
    /**
     * Front to the WordPress application. This file doesn't do anything, but loads
     * wp-blog-header.php which does and tells WordPress to load the theme.
     *
     * @package WordPress
     */
    
    /**
     * Tells WordPress to load the WordPress theme and output it.
     *
     * @var bool
     */
    define( 'WP_USE_THEMES', true );
    
    /** Loads the WordPress Environment and Template */
    require( dirname( __FILE__ ) . '/wp-blog-header.php' );

     

    Merci de m’aider à résoudre ce problème pour le moins fâcheux,

     

    Mathias.

    #2293640
    Inglebard
    Participant
    Chevalier WordPress
    112 contributions

    Bonjour,

     

    Vous indiquez avoir mis à jour php, cependant je vois que vous êtes sur un RPI0.

    Les paquets se mettent à jours avec le système. Passez vous donc par un autre moyen pour mettre à jour php ?

     

    Concernant votre problème, il semblerait qu’il y a un problème de dialogue entre Apache (ou un autre service web du même type) et php.

    Si vous utilisez apache, vérifier sa configuration, l’ancien module php est peut-être toujours actifs et le nouveau ne l’ait pas.

    Avez-vous faites ce genre de commande après la mise à jour php pour adapter la configuration apache ? Quelque chose de ce genre :

    sudo a2enmod php7.3
    sudo service apache2 restart

    #2293645
    MathiAs2Pique
    Participant
    Initié WordPress
    32 contributions

    Salut,

    Merci de ta réponse.

    Après avoir exécuté cette commande

    sudo a2enmod php7.3

    apache ne veut plus se lancer. J’ai donc activé les logs pour voir ce qu’il se passait, ça me donne ça :

    sudo systemctl status apache2.service
    
    
    
    ● apache2.service - The Apache HTTP Server
       Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
       Active: failed (Result: exit-code) since Thu 2020-01-16 08:49:28 GMT; 1min 11s ago
         Docs: https://httpd.apache.org/docs/2.4/
      Process: 5324 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
    
    Jan 16 08:49:28 raspberrypi systemd[1]: Starting The Apache HTTP Server...
    Jan 16 08:49:28 raspberrypi apachectl[5324]: apache2: Syntax error on line 146 of /etc/apache2/apache2
    Jan 16 08:49:28 raspberrypi apachectl[5324]: Action 'start' failed.
    Jan 16 08:49:28 raspberrypi apachectl[5324]: The Apache error log may have more information.
    Jan 16 08:49:28 raspberrypi systemd[1]: apache2.service: Control process exited, code=exited, status=1
    Jan 16 08:49:28 raspberrypi systemd[1]: apache2.service: Failed with result 'exit-code'.
    Jan 16 08:49:28 raspberrypi systemd[1]: Failed to start The Apache HTTP Server.

    Idem si je fais la première de tes commandes en remplaçant 7.3 par 7.1.

    #2293646
    Inglebard
    Participant
    Chevalier WordPress
    112 contributions

    Il y a un problème ici :

    Syntax error on line 146 of /etc/apache2/apache2.conf
    • Cette réponse a été modifiée le il y a 8 mois par Inglebard.
    #2293650
    MathiAs2Pique
    Participant
    Initié WordPress
    32 contributions

    à la ligne 146, il y à ça :

    IncludeOptional mods-enabled/*.load

    #2293651
    Inglebard
    Participant
    Chevalier WordPress
    112 contributions

    A priori tu ne dispose pas de module php7.3 pour apache.

    Peux tu faire ceci pour désactivé fait précédemment :

    sudo a2dismod php7.3
    sudo service apache2 restart

     

    Peux tu me dire ce qui se trouve la dedans.

    ls /etc/apache2/mods-available/

    • Cette réponse a été modifiée le il y a 8 mois par Inglebard.
    #2293663
    Inglebard
    Participant
    Chevalier WordPress
    112 contributions

    En gros faudrait vérifier que dans /etc/apache2/mods-available/

    Il y ait php7.3.conf et php7.3.load

    Si c’est le cas faire un :
    sudo a2enmod php7.3

    Sinon installer le paquet suivant :
    sudo apt install libapache2-mod-php libapache2-mod-php7.3

    Puis enlever les anciens module apache de php en vérifiant dans “/etc/apache2/mods-enabled/”
    Si php7.2.load ou php7.1.load sont présent :

    sudo a2dismod php7.2 pour désactiver php7.2
    sudo a2dismod php7.1 pour désactiver php7.1

    Ensuite redémarrer apache
    sudo service apache2 restart

    Si il y a un problème, vérifier dans :
    cat /var/log/apache2/error.log

    #2293683
    MathiAs2Pique
    Participant
    Initié WordPress
    32 contributions

    Re ! Merci pour tes réponses

    J’ai fais ce que tu m’as dit, et tout marche maintenant ! Par contre, le site est très lent, je dois patienter une minute au moins pour qu’une page se charge, tu sais d’où ça peut venir ?

     

     

    #2293710
    Inglebard
    Participant
    Chevalier WordPress
    112 contributions

    Difficile à dire, vérifies que ton wordpress, thème wordpress et modules wordpress sont à jour.

    #2293861
    MathiAs2Pique
    Participant
    Initié WordPress
    32 contributions

    Salut, en fait je crois que ça vient de ça : dans “Santé du site”, j’ai deux erreurs notables :

     

    1. L’API REST est l’une des façon pour WordPress ou d’autres applications de communiquer avec le serveur. Un exemple est l’écran de l’éditeur, qui s’appuie dessus pour afficher et enregistrer vos publications.
      
      La requête API REST a échoué à la suite d’une erreur.
      Erreur : [] cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received

       

     

     

    2.

    Les requêtes de bouclage sont utilisées pour lancer des évènements planifiés, ainsi que par les éditeurs de thèmes et d’extensions pour vérifier la stabilité du code.
    
    La requête de bouclage sur votre site a échoué, ce qui signifie que les fonctionnalités qui s’appuient sur ces requêtes ne fonctionnent actuellement pas comme elles le devraient.
    Erreur : [] cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received

     

    Mais aucune solution n’est donnée, comment je peux rétablir tout ça ?

    #2293863
    Inglebard
    Participant
    Chevalier WordPress
    112 contributions

    Étrange, on dirait que votre site ne se trouve pas lui même.

    Je ne sais pas quel est votre nom de domaine.

    Vérifier que le nom de domaine utilisé dans le worpdress pointe bien sur votre Raspberry.

    Vous pouvez essayer de modifier le fichier /etc/hosts de votre Raspberry en ajoutant (avec la variante www ci nécessaire) quelque chose comme ceci:

    `
    127.0.0.1    nomdedomaine
    `
    #2293884
    MathiAs2Pique
    Participant
    Initié WordPress
    32 contributions

    Salut, j’ai déjà ça dans ce fichier :

     

    
    
    127.0.0.1       localhost
    [...]
    127.0.1.1       raspberrypi

    Je modifie quand même ?

    • Cette réponse a été modifiée le il y a 7 mois et 4 semaines par MathiAs2Pique. Raison: trompé
12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.