Install multisite: The requested URL /monsite/test/wp-admin/ was not found

  • WordPress :4.8.2
  • Statut : non résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #1953222

    bastringue
    Participant
    Initié WordPress
    17 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
      • PHP 7.1.8-1ubuntu1 (cli) (built: Aug 8 2017 15:57:37) ( NTS )
      • mysql Ver 14.14 Distrib 5.7.20, for Linux (x86_64) using EditLine wrapper
    • Thème utilisé :
      • fourni avec WP
    • Extensions en place : non
    • Nom de l’hébergeur : localhost
    • Adresse du site : http://localhost/monsite

    Problème(s) rencontré(s) : Bonjour, j’essaye d’installer WP multisite et je suis arreté par un pb que je n’avais jamais eu sur des versions plus anciennes…En bref, je commence par l’installation mono-site et ça fonctionne bien. Pour préciser, j’ai posé le répertoire d’installation que j’ai renommé ‘monsite’ dans /var/www/html (le Documentroot du serveur Apache2) et j’accède au site sans problème  avec l’adresse http://localhost/monsite.

    Passant à l’étape multisite, je modifie wp-confog.php (define( ‘WP_ALLOW_MULTISITE’, true )). Je crée alors le réseau de sites (ok) , procède à la modification de .htaccess et de wp-config.php (comme demandé). Je vais sur le menu de création de sous-sites et crée un sous site ‘test’ (ok), mais quand je clique sur le lien d’administration de ce sous-site, j’obtiens « The requested URL /monsite/test/wp-admin/ was not found on this server »

    J’ai recommencé plusieurs fois en vérifiant mais rien n’y fait. J’ai vérifé que le mod_rewrite d’Apache2 était activé (‘a2enmod rewrite’). Je précise qu’il s’agit de la version 2.4 d’Apache2 (ce lien laisse penser que le pb pourrait venir de là mais je ne sais pas comment configurer correctement apache2 pour WP-multisite  🙁  ).

    Merci d’avance…Pierre

     

     

    #1957978

    ftiar
    Participant
    Initié WordPress
    20 contributions

    Hello Pierre, tu as choisit une installation multisite en mode sous dossier ou sous domaine ? Je te conseille plutôt du sous dossier si tu es en local ca sera plus simple.

    Concernant ton problème, je pense que ca vient du htaccess, il faut des règles de ce type :

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    </IfModule>

    Ce sont les occurrences suivantes qui sont importantes : [_0-9a-zA-Z-]

    Si ce n’est toujours pas ok, il me semble qu’il faut se connecter sur le tableau de bord du network, et recharger les permaliens.

    Grégoire Noyelle a écrit un tutoriel assez complet à ce sujet : https://www.gregoirenoyelle.com/wordpress-creer-un-reseau-de-site/

     

    #1962538

    bastringue
    Participant
    Initié WordPress
    17 contributions

    Merci beaucoup pour ta réponse… J’allais inscrire moi même une réponse car trouvant enfin le temps de m’y remettre, j’ai pu élucider le mystère !

    Ca venait de mon serveur Apache2 et du paramétrage du site virtuel que j’utilise pour mon site WordPress (voir le rappel sur l’installation d’un serveur virtuel ci-dessous) : il a suffi que  j’ajoute les lignes ci-dessous en tant que propriétés du répertoire qui contient les sources du site….Ces lignes étaient nécessaires semble-t’il, pour interpréter correctement les liens de wordpress  qui pointent vers un site dérivé du site principal : http://SitePrincipal/SiteDérivé/page.php.

    <VirtualHost *:80>
    ServerName local.vtest
    DocumentRoot /repertoire/vers/vtest
    <Directory /repertoire/vers/vtest/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Require all granted
    </Directory>
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
    </VirtualHost>

    Rappel sur la mise en place d’un serveur virtuel sur Apache2 (en linux):

    Dans la version 2.4.27 d’Apache2, on configure un site virtuel en créant un fichier « monsite.conf » dans le répertoire /etc/apache2/sites-available (en s’inspirant du fichier correspondant au serveur virtuel par défaut : « 000-default.conf »). Quand on crée un fichier de configuration d’un site, il faut lancer la commande « a2ensite » suivie du nom du site pour l’activer (ça crée un lien symbolique dans le répertoire /etc/apache2/sites-enabled/ vers ce fichier). Pour le désactiver on utilise « a2ddsite ». Il ne faut pas oublier d’actualiser le serveur apache à chaque changement avec ‘sudo systemctl reload apache2’. Dans l’exemple donné, local.vtest est le nom du serveur local que j’ai déclaré dans le fichier /etc/hosts avec une adresse IP interne (127.0.1.2 par exemple). DocumentRoot donne le chemin vers le répertoire racine du site. Si on ne veut pas créer un site virtuel spécifique pour WP, alors on peut se contenter du site par défaut (fichier 000-default.conf) mais alors, il faut vérifier que les propriétés du répertoire désigné par DocumentRoot sont les bonnes (avec les bonnes options). Concernant le .htaccess, il est possible qu’on puisse s’en sortir aussi avec lui et sans avoir à toucher les fichiers de configuration du site sous etc/apache2, mais je n’ai pas regardé de prés…

    En tous cas, merci

    #1962543

    bastringue
    Participant
    Initié WordPress
    17 contributions

    …oups j’oubliais :  oui j’ai une configuration WordPress en sous dossiers (et pas en sous-domaines)…

    et tout bien considéré, et comme tu le conseilles, je vais chercher aussi une solution par .htaccess : c’est plus adapté à une future installation chez un hébergeur que la modification des config apache2….

     

     

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.