Index.php

Suite à la migration du forum, chaque utilisateur devra lancer une procédure de réinitialisation du mot de passe pour pouvoir se connecter. Merci !

  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Articles
  • #506087

    Kotsu
    Membre
    Initié WordPress
    20 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : La dernière
    – Version de PHP/MySQL : Sais pas
    – Thème utilisé : AnimeOnline
    – Extensions en place : Rien
    – Nom de l’hebergeur : 000hosting
    – Adresse du site : http://mugiwara-fan.comeze.com/

    Problème(s) rencontré(s) : J’ai fais une bétise, j’ai enlever l’index.php de mon ftp pour le remplacer par un autre:

    Le site est fermé.

    Puis je voulais remettre l’autre (que j’avais copier/coller) et sa me mes ce message quand je l’ai mis:

    Fatal error: Call to undefined function get_header() in /home/a3959088/public_html/index.php on line 1

    Voilà mon index.php:

    <?php get_header(); ?>
    		<div class="span-24" id="contentwrap">
    			<div class="span-16">
    				<div id="content">	
                    <?php if(is_home()) { include (TEMPLATEPATH . '/featured.php'); } ?>		
    					<?php if (have_posts()) : ?>	
    						<?php while (have_posts()) : the_post(); ?>
    						
    						<div <?php post_class() ?> id= »post-<?php the_ID(); ?>« >
                                <?php if ( function_exists("has_post_thumbnail") && has_post_thumbnail() ) { the_post_thumbnail(array(260,200), array("class" => « alignleft post_thumbnail »)); } ?>
    							<h2 class="title"><a href="<?php the_permalink() ?> » rel= »bookmark » title= »Permanent Link to <?php the_title_attribute(); ?>« ><?php the_title(); ?></a></h2>
    							<div class="postdate"><img src="<?php bloginfo('template_url'); ?>/images/date.png » /> <?php the_time('F jS, Y') ?> <img src="<?php bloginfo('template_url'); ?>/images/user.png » /> <?php the_author() ?> <?php if (current_user_can('edit_post', $post->ID)) { ?> <img src="<?php bloginfo('template_url'); ?>/images/edit.png » /> <?php edit_post_link('Edit', '', ''); } ?></div>
    			
    							<div class="entry">
    								<?php the_content('<strong>Read more »</strong>‘); ?>
    							</div>
    						</div><!--/post-<?php the_ID(); ?>-->
    				
    				<?php endwhile; ?>
    				<div class="navigation">
    					<?php if(function_exists('wp_pagenavi')) { wp_pagenavi(); } else { ?>
    					<div class="alignleft"><?php next_posts_link('« Older Entries') ?></div>
    					<div class="alignright"><?php previous_posts_link('Newer Entries »') ?></div>
    					<?php } ?>
    				</div>
    				<?php else : ?>
    					<h2 class="center">Not Found</h2>
    					<p class="center">Sorry, but you are looking for something that isn’t here.</p>
    					<?php get_search_form(); ?>
    			
    				<?php endif; ?>
    				</div>
    			</div>
    		
    		<?php get_sidebars(); ?>
    	</div>
    <?php get_footer(); ?>

    #818714

    Kotsu
    Membre
    Initié WordPress
    20 contributions

    Up please 🙂.

    #818715

    luciole135
    Membre
    Maître WordPress
    13792 contributions

    Avez-vous une sauvegarde de la base de données ?

    #818716

    Guy
    Participant
    Maître WordPress
    14940 contributions

    tu as probablement confondu l’index.php de wordpress et celui de ton thème.

    Si tu n’as touché qu’aux fichiers nommés index.php. Prend celui de wordpress et remplace le (celui de la racine du site), ensuite prends celui de ton thème et remplace le dans le répertoire wp-content/themes/nom du theme

    #818717

    Kotsu
    Membre
    Initié WordPress
    20 contributions

    C’est bon c’est remis en ordre merci beaucoup vous deux, Guy la réponse c’étais bien ta réponse 😉.

    #818718

    sneak-art
    Membre
    Initié WordPress
    3 contributions

    Bonjour,

    je viens d’avoir un problème similaire mais la manipulation décrite sur le forum ne fonctionne pas.

    voici mon erreur : Fatal error: Call to undefined function get_header() in /homez.604/sneakart/www/index.php on line 7

    Ma configuration WP actuelle
    – Version de WordPress : 3.5.1
    – Version de PHP/MySQL : Sais pas
    – Thème utilisé : Magzimus
    – Extensions en place : Rien
    – Nom de l’hebergeur : 0VH
    – Adresse du site : http://www.sneak-art.com

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.