Impossible de valider ma page (Créer un compte)

  • Statut : non résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #462266
    Maitre Mo
    Participant
    Maître WordPress
    1653 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress :
    – Thème utilisé :
    – Plugins en place :
    – Nom de l’hebergeur :
    – Adresse du site :

    Problème(s) rencontré(s) :
    V’là autre chose, qu’est-ce que j’ai encore fait ? Je passe régulièrement ma page d’accueil au validateur W3C, et voilà que ce soir il m’indique qu’il ne peut pas la vérifier : “Sorry, I am unable to validate this document because on line 552 it contained one or more bytes that I cannot interpret as utf-8 (in other words, the bytes found are not valid values in the specified Character Encoding). Please check both the content of the file and the character encoding indication.
    The error was: utf8 “xE7″ does not map to Unicode”.
    Lorsque j’affiche la ligne 552 sous FF, rien à signaler je crois, c’est celle d’un tag… Mais j’ai pu constater que les numéros de ligne varient d’un affichage à l’autre, alors…
    Si quelqu’un a la gentillesse de m’indiquer ce que je dois corriger (http://maitremo.fr), je l’embrasse d’avance, sauf s’il veut pas, car ça m’énerve bien..!
    Merci !

    #642660
    viwiv
    Membre
    Maître WordPress
    809 contributions

    Bonsoir Maître,

    La ligne no 552 est vide, ce qui déplaît au W3c… Te dire pourquoi elle est vide, je l’ignore 🙂 En plus, j’en vois une autre de vide.

    Essaie de désactiver l’ignoble nuages de tags qui bouge, grâce à Flash, et revalide. En plus, il est très moche, moi je trouve, et pas du tout accessible.

    Amitiés,

    V.

    #642661
    Maitre Mo
    Participant
    Maître WordPress
    1653 contributions

    Merci viwiv,
    Je sais que tu ne l’aimes pas, mais moi j’adore..! Et je l’ai depuis longtemps, le problème ne vient pas de là : je viens de le désactiver et l’erreur demeure, se déplaçant seulement à la ligne 481…
    Bon, faut juste que je trouve ou se trouve cette ligne 552 et que je la dégage… Ca m’agace, ça m’agace..!

    #642662
    viwiv
    Membre
    Maître WordPress
    809 contributions

    Mon bon Mâitre,

    Avais-tu revalidé ta page depuis l’installation du plugin “Scoopeo – Bookmark this!” ? Je subodore que ta page est invalide *aussi* pour cette raison là.

    Par ailleurs, je pense que la valideur n’est pas content car il trouve deux fois dans ta page :

    rel=”alternate” type=”application/rss+xml”

    La première déclaration est dans ton header, la deuxième dans ta colonne de droite.

    Amitiés,

    V.

    #642663
    codfingers
    Participant
    Maître WordPress
    541 contributions

    Pff ! moi je donnerai beaucoup pour que ce soit validé, mais je ne sais pas faire ( manque de patience)

    l’idéal serait un logiciel qui vous le fasse… à force le cambouis cela fatigue….

    #642664
    Maitre Mo
    Participant
    Maître WordPress
    1653 contributions

    Merci une nouvelle fois, viwiv.
    Je ne pense pas que ce soit Scoopeo, qui est installé lui aussi depuis très longtemps.
    En revanche je sais que ma sidebar peut poser certains problèmes, la ligne que tu me donnes y figure, en relation avec… Les icônes de validation qui y figurent ! Et qui par définition sont là elles aussi depuis un certain temps, puisque c’est via elles que je valide régulièrement..! Je m’y perds…
    J’ai cru trouver hier sous FF avec firebug, qui m’indiquait une ligne complexe non reconnue, ayant à voir avec un fichier wp-includes/js/tw-sack.js, et particulièrement avec ce code :

    this.createAJAX = function() {
    		try {
    			this.xmlhttp = new ActiveXObject(“Msxml2.XMLHTTP”);
    		} catch (e1) {
    			try {
    				this.xmlhttp = new ActiveXObject(“Microsoft.XMLHTTP”);
    			} catch (e2) {
    				this.xmlhttp = null;
    			}
    		}

    , encore plus particulièrement avec la deuxième partie (“e2”); inutile de préciser que je n’avai jamais vu ce fichier… J’ai supprimé cette seconde partie, et encore erreur FF; je l’ai remise et plus d’erreur FF, tandis que ma page ne peut toujours pas être validée, avec ou sans la ligne relative à “e2″…
    Donc ce n’était point ça…
    It is shit !

    #642665
    Maitre Mo
    Participant
    Maître WordPress
    1653 contributions

    Bon alors, c’est la rentrée apparemment, donc up, et hop-là, et voilà !

    #642666
    Dric
    Participant
    Maître WordPress
    757 contributions

    J’ai eu pendant un bon bout de temps cette erreur sur un thème propre et validé à la base, qui a disparu mystérieusement en changeant de thème.

    Je penche pour un sortilège maléfique envoyé contre ton blog. Brûle un poulet ou une télé cathodique en allumant plein de cierges, et reviens nous dire si ça a marché.

    Plus sérieusement, je n’ai jamais trouvé d’où venait cette erreur alors si tu arrives à solutionner ce mystère ça m’intéresse grandement.

    #642667
    Maitre Mo
    Participant
    Maître WordPress
    1653 contributions

    Bien, alors si jamais quelqu’un qui s’y connait vraiment (pas comme le nain rouge, là, tout juste bon à me dire de cramer des poulets et qu’il a eu la même erreur que sa parresse intellectuelle a laissé en friche) a la moindre idée de ce que je peux faire pour résoudre cette étrangeté…
    Et si je vais sous FF et passe ça par Firebug, il me valide, juste une série de warnings (Béatrice, je voulais dire “de clignotants anémiés”); j’efface la console pour revenir à la page d’accueil du blog et paf ! Là il m’affiche une erreur de grosse croix rouge insupportable de m… ! Donc j’y retourne et là, il m’affiche… Ah ben non, là plus rien, tiens…
    Bon enfin bref, je ne sais même pas si les deux ont un rapport, mais en tout cas le généreux bienfaiteur qui tiltetrait sur cette non validation par WC3 serait mon ami pour la vie, et plus si affinités.
    J’ajoute que la ligne 552 à ma connaissance contient juste une balise , ce qui est passionnant.
    C’est la dernière fois que je remonte cette question, c’est promis, après de toute façon j’arrête tout, les gens sont vraiment trop méchants.

    #642668
    Dric
    Participant
    Maître WordPress
    757 contributions

    Le nain rouge s’appelle en réalité Roger W3C. Oui, je suis le fils de M. Consortium W3C. Et je vais dire à Père que tu fais rien qu’à m’embêter.

    Pour infos complémentaires, j’ai montré cette erreur à un spécialiste de l’accessibilité et des standards, qui s’est contenté de hausser les épaules avec une moue dubitative qui voulait probablement signifier : “J’ai regardé ton truc, mais il semble bien que nous soyons face à un mystère numérique insondable. Et ne viens plus m’emmerder maintenant.”

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.