[Résolu] Impossible de se connecter admin ou abo après le passage sur un serveur distant (Créer un compte)

  • WordPress :4.6.1
  • Statut : résolu
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #1603019
    Riri la bidouille
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : PHPMyadmin MYSQL v.5.5
    • Thème utilisé : Twentyfive
    • Extensions en place : plus la liste, mais pb persistant en les désactivant
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://www.cometmediassud.com

    Problème(s) rencontré(s) :

    Bonjour à tous,

    En passant d’un hébergeur local (WAMP, PHPmyadmin 4.6.4) à mon FTP sur OVH, il m’est désormais impossible de me connecter en tant que admin, mais aussi avec les identifiants abonnés que j’avais créé en local. Toujours le même message (erreur sur les identifiants et le mot de passe), alors que les identifiants sont les bons (vérif multiples dans la BDD).

    A noter que j’ai établi des protections en changeant le message d’échec de log pour ne pas trop en dire (bidouillage). Mais je n’ai pas changé une seule ligne de code entre le passage du local au disant et mon bidouillage fonctionnait très bien en local.

    J’ai des extensions et notamment une box de connexion mais problème persistant en déconnectant toutes les extensions.

    A noter que j’ai dû faire un export de ma base en SQL en maximisant la comptabilité en MySQL 40.

    Alors, j’ai bien entendu essayer de créer un nouvel user admin en passant par PHP my admin > échec > toujours le même message d’erreur
    A noter que les mots de passe se transforment tout seul dans ma base de données en utilisant un cryptage MOD 5.

    Pour ceux qui taperont sur google le nom du site, oui j’ai tout refais (vider le serveur, et refaire un nouveau wordpress) pour cause de piratage, non mon site n’est pas une ode à la double pen. Mais on s’éloigne du du sujet du post. Merci pour votre aide. Et bravo à toute la communauté pour votre travail, j’ai tout appris ici 😉

    #1603030
    Riri la bidouille
    Participant
    Initié WordPress
    5 contributions

    Et quand je demande un nouveau mot de passe, même si ce n’est pas ça le problème, je ne reçois pas le mail de worpress. C’est peut-être lié…

    #1603036
    Riri la bidouille
    Participant
    Initié WordPress
    5 contributions

    Et j’ai essayé toutes les solutions dans le post de 2013 sur la même question. Qui n’a pas été résolu…
    https://wpfr.net/support/sujet/impossible-de-se-connecter-sur-ladmin/

    Jusqu’aux changement de droit des dossiers en 755 et fichiers en 644.

    HELP, c’est pour demain matin :-/

    #1603055
    momofr@free.fr
    Modérateur
    Maître WordPress
    3202 contributions

    Pas facile de t’aider il faut auditer ton site et ta base de données pour déterminer où ça coince.

    #1603072
    Riri la bidouille
    Participant
    Initié WordPress
    5 contributions

    Merci Momo pour ce signe de vie. Et tant qu’il y en a, l’espoir triomphe.
    Nouvelle évolution, ce matin, je me réveille à la fraiche…
    Je me dis que cette journée sera belle et j’essaye de nouvelles choses persuadé que le dénouement est proche…
    Puis après 10 minutes d’utilisation que vois-je ?
    Désormais… Le serveur local présente le même problème avec une impossibilité de se connecter…
    Est ce qu’une connexion à PHP my admin peut lancer une action qui agit sur les possibilités de connexion. Parce que c’est à la suite d’une connexion à PHPmyadmin en local que ça s’est produit.

    #1603084
    momofr@free.fr
    Modérateur
    Maître WordPress
    3202 contributions

    Naturellement non, le fait de se connecter à PHPMyAdmin ne fait rien à ton installation, seule les manipulations effectuées dans ta base peuvent nuire ou aider, c’est selon.

    Tu dois avoir une sauvegarde de ta base de données ? Supprime toutes les tables de la base de données chez OVH et réimporte ta base locale, ensuite applique les requêtes SQL décritent ici et tu devrais retrouver ton site.

    Il y a d’autres façons de faire mais il faut un minium de connaissances du fonctionnement des tables de la base de données WP.

    #1603094
    Riri la bidouille
    Participant
    Initié WordPress
    5 contributions

    Ouiiiiiiiiiiiiiiiiiiiiiiiiiiiiii ! Trouvé !
    Alors, en refaisant depuis le départ tout le wordpress, je me promène dans wp_content pour copier mes fichiers médias, et là… je me suis rendu compte que iTheme Security, extension que j’avais installé, rajoute des fichiers dans wp_content/upload.
    Donc il ne suffit pas de désactiver l’extension dans wp_content/plugin pour éliminer les extensions comme source de problème, mais il faut aussi supprimer aussi ce dossier là. C’est bon je peux me reconnecter à mon admin et tout !!!
    Merci momo pour ton soutien et j’espère que ce post servira à d’autres.

    Amour paix et liberté à bientôt mes amis mes frères

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.