Impossible de se connecter à WordPress – Admin ou Utilisateur classique – 2019

  • WordPress :5.0.3
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 34)
  • Auteur
    Messages
  • #2246172
    NicoB
    Participant
    Initié WordPress
    19 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : MYSQL v.5.6
    • Thème utilisé : Seventeen (ce n’est pas mon thème qui cause problème, j’ai testé en le supprimant via mon ftp, idem j’ai réinstallé la nouvelle version seventeen via ftp et le problème demeure)
    • Extensions en place : ce ne sont pas les extensions qui causent le problème, j’ai testé en les désactivant via mon ftp
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://www.moncpf.org

    Problème(s) rencontré(s) :

    Impossible de se connecter à l’espace wordpress depuis hier (aussi bien admin que utilisateur), ni depuis wp-admin, ni depuis wp-login.php !

    Lorsque je rentre mes identifiants correctement, la page se rafraîchit ou me renvoie vers la page d’accueil de mon site, mais sans me connecter.

    Lorsque je rentre des identifiants erronés, la plateforme me dit bien qu’ils sont erronés (donc le problème ne vient bien sûr pas de là…).

    J’ai tenté en désactivant, puis en mettant la dernière MAJ de mon thème wordpress. Aucune modif. Idem en désactivant tous les plugins via mon ftp.

    J’ai tenté de me connecter via plusieurs IP différentes et via mon téléphone, en admin comme en « abonné », rien n’y fait.

    J’ai même tenté de réutiliser une sauvegarde de la veille (quand tout fonctionnait bien). Mais ça n’a rien changé au problème non plus !

    Donc je ne comprends pas ..!

    Du coup, j’ai besoin de votre aide pour comprendre d’où peut venir le problème !

    Merci d’avance

    Edit : Quand je tente une récupération de mot de passe, voici le message qui s’affiche : « Impossible d’enregistrer la clé de mise à zéro du mot de passe dans la base de données. »

    • Ce sujet a été modifié le il y a 1 week par  NicoB.
    • Ce sujet a été modifié le il y a 1 week par  NicoB.
    • Ce sujet a été modifié le il y a 1 week par  NicoB.
    #2246182
    ouiouiphoto
    Participant
    Maître WordPress
    817 contributions

    Bonjour

    Je vérifirais le fichier .htaccess. eventuellement je le sauverais et ferais un htaccess de base avec seulement dedans

     

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    EDIT : et je vérifierais aussi que le quota n’a pas été dépassé pour l’hébergement ou la base de donnée

    • Cette réponse a été modifiée le il y a 1 week par  ouiouiphoto.
    #2246247
    NicoB
    Participant
    Initié WordPress
    19 contributions

    Exactement pour le dépassement du quota ! Tu as mis le doigt dessus ! Je m’en suis rendu compte quelques minutes après avoir posté cela !

     

    Seulement, problème : j’ai fait tout ce que j’ai pu, j’ai supprimé la moitié de mes sauvegardes et rien n’y fait, impossible d’actualiser le compteur OVH du quota ! Je pense qu’ils doivent avoir un délai très long (peut-être de 24H) pour actualiser le compteur du quota ! Mais moi j’ai une communauté d’environ 400 clients qui ont besoin d’accéder au site chaque jour, donc si j’attends 24H ou plus, c’est vraiment pas bon …

     

    Du coup j’ai payé environ 7€ pour une base de donnée plus conséquente et je suis en train d’essayer de l’utiliser en envoyant une sauvegarde du 10/02/2019 de mon site… J’espère que ça va le faire.

     

    Je n’y connais pas grand chose en wordpress ou OVH, donc je bidouille.

     

    Pour l’instant ça ne sent pas bon car j’ai ce message à l’écran quand je charge la page admin de mon site :

    <h1>Erreur lors de la connexion à la base de données</h1>
    Cela signifie soit que l’identifiant ou le mot de passe dans votre fichier wp-config.php n’est pas correct, soit que nous ne pouvons pas contacter le serveur de base de données à l’adresse bn195819-001.privatesql. Cela peut signifier que votre serveur de base de données est tombé.

    • Confirmez-vous utiliser le bon nom d’utilisateur et le bon mot de passe ?
    • Confirmez-vous avoir saisi le bon nom d’hôte (hostname) ?
    • Confirmez-vous que le serveur de la base de données fonctionne correctement ?

    Si vous n’êtes pas sûr de connaître ces termes, vous devriez probablement contacter votre hébergeur. Si vous avez toujours besoin d’aide, vous pouvez toujours vous rendre sur les forums d’entraide de WordPress.

    #2246248
    ouiouiphoto
    Participant
    Maître WordPress
    817 contributions

    Comme tu as demandé une augmentation du quota OVH doit faire des manips sur ta base ce qui peut expliquer le problème. Effacer les sauvegardes va libérer de la place sur disque mais pas sur la base de donnée. Le rafraîchissement du quota sur la base de donnée est faisable dans ton espace client

    Ensuite tu as des extension pour optimiser une base de donnée.  comme https://fr.wordpress.org/plugins/wp-optimize/

     

     

     

    #2246281
    NicoB
    Participant
    Initié WordPress
    19 contributions

    Oui je parlais du rafraîchissement de ma base de données, soit « recalculer le quota ». J’ai bien dû le lancer 20 fois en supprimant des sauvegardes mais rien n’y fait, il reste supérieur à 200 Mo et dans le rouge : « 207.35 Mo / 200 Mo ».

     

    Merci pour ce plugin, je vais tenter de le lancer depuis mon FTP.

    EDIT : Pour ce plugin, on me renvoie le message suivant : « Le script d’installation net2ftp a été copié sur le serveur FTP.
    Ce script est lancé sur votre serveur web et requiert que PHP soit installé. » Avec un lien mort pour installer le PHP …

    • Cette réponse a été modifiée le il y a 6 days et 18 hours par  NicoB.
    #2246291
    NicoB
    Participant
    Initié WordPress
    19 contributions

    Visiblement ce plugin n’y change rien.

     

    En gros, je pense que mon problème actuel c’est le quota qui ne s’actualise pas du côté de OVH et du côté de wordpress, le fait que j’ai bidouillé sur les fichiers wp-config.php et wp-login.php en essayant d’arranger le problème, mais je n’ai rien arrangé …

     

    Qu’est-ce que vous me conseillez de faire du coup ? Attendre 24H le temps que le quota s’actualise ?

    #2246295
    ouiouiphoto
    Participant
    Maître WordPress
    817 contributions

    Si tu as bidouillé dans les fichiers php il n’est pas étonnant que ca ne marche plus. Donc la première etape c’est de remetre les fichiers comme ils étaient pour pouvoir te reconnecter a ton blog

    #2246296
    NicoB
    Participant
    Initié WordPress
    19 contributions

    Comment libérer de l’espace sur ma base de données alors ? Je ne comprends pas

    #2246298
    NicoB
    Participant
    Initié WordPress
    19 contributions

    Par rapport aux fichiers, oui bien sûr, c’est évident mais il faut comprendre que ça ne marchait déjà pas avant.

     

    Et pour le fichier wp-config.php j’ai déconné je l’ai modifié sans en avoir la copie, j’ai dl la copie mais le fichier était incomplet, un genre de bug réseau.

     

    Du coup j’ai récupéré des lignes de codes wp-config.php sur un github, ça peut faire l’affaire tu penses ?

    #2246307
    NicoB
    Participant
    Initié WordPress
    19 contributions

    Finalement, je vais payer pour passer de l’offre perso à l’offre pro. Je crois que c’est la seule option possible en fait …

     

    EDIT : C’est fait, j’ai aussi remis mon fichier wp-config.php comme avant. Maintenant quand je tente de me connecter à la partie admin, en fait je me retrouve à redevoir installer wordpress. Comme le premier jour … Est-ce normal ? Je ne crois pas mais bon, je vais sûrement pouvoir récupérer mon site comme avant ensuite non ?

    • Cette réponse a été modifiée le il y a 6 days et 16 hours par  NicoB.
    #2246313
    ferman
    Participant
    Chevalier WordPress
    101 contributions

    Bonsoir,

     

    Avant de faire quoi que ce soit attendez que oui oui photo vous réponde. Vous risquez de faire des bêtises.

    #2246316
    ouiouiphoto
    Participant
    Maître WordPress
    817 contributions

    A mon avis tu mélange pas mal de trucs et tu fais trop de manips dans tous les sens. Donc première étape. Arrive tu a te connecter a la base de donnée avec phpmyadmin ?  Si oui as tu toutes les infos dans cette base. Si oui a tu modifié le wp-config.php pour utiliser cette base et pas une autre

    #2246329
    NicoB
    Participant
    Initié WordPress
    19 contributions

    Avec le phpmyadmin je ne sais pas, je n’ai pas essayé.

    J’arrive à me connecter à net2ftp.

    Là grosso-modo je me retrouve avec une version wordpress toute nouvelle, sans mes articles, commentaires etc etc :'(

     

    Je ne sais pas du tout si j’ai un moyen de les retrouver… C’est la merde si je dois re-créer tout le contenu parce que j’ai des clients qui attendent…

    En fait je pensais que la base de données OVH contenait ce genre de données (articles, commentaires, pages etc), mais visiblement non…

    #2246330
    NicoB
    Participant
    Initié WordPress
    19 contributions

    J’aurais dû suivre ce conseil ferman, mais j’ai été pressé par mes clients, c’est dommage … Je ne sais pas si je reverrai un jour mes données du coup … :/

    #2246346
    ferman
    Participant
    Chevalier WordPress
    101 contributions

    Normalement votre base de données pleine n’est pas effacée. Comme dit plus haut, il faut aller dans phpmyadmin. Rien d’autre n’est important pour le moment. ovh a dû vous donner un mot de passe pour rentrer dans phpmyadmin. Quand vous avez accès à votre base de données, exportez-là. savez-vous comment faire?

     

15 sujets de 1 à 15 (sur un total de 34)
  • Vous devez être connecté pour répondre à ce sujet.