[Résolu] Impossible de se connecter à l’admin – Site rapatrié en local avec Wamp (Créer un compte)

  • WordPress :5.7
  • Statut : résolu
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #2470712
    cacalsof
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Ma configuration WP actuelle

    Problème(s) rencontré(s) :

    Pour faire plusieurs modifications et mise à niveau, j’ai rapatrié le site en local.

    Je travaille avec wampserver64 3.3.2.

    La base de donnée est rapatriée et installée.

    Je n’arrive pas à créer un virtualhost, cela pointe toujours sur le site en ligne à la seconde connexion. La première ne contient que des erreurs.

    Si je rend les liens du www cliquables, j’arrive bien sur localhost/monsite mais le css n’est pas chargé, et tous les liens pointent vers le site en ligne, normal car j’ai pas modifié en admin…. sauf que je n’arrive pas à me connecter à l’admin. j’ai changé le nom du répertoire de hide login, mais…rien, j’ai toujours un 404. J’ai modifié l’entrée de la bdd « option-siteurl » avec localhost. Si je laisse vide j’ai un joli message d’erreur de connexion à la bdd.

    Bref je tourne en rond.

    Si quelqu’un pouvait me lancer une piste SVP

    • Ce sujet a été modifié le il y a 1 mois et 3 semaines par Flobogo.
    • Ce sujet a été modifié il y a 1 mois et 3 semaines par Flobogo. Raison : modif du titre
    • Ce sujet a été modifié le il y a 1 mois et 3 semaines par cacalsof.
    #2470729
    Flobogo
    Modérateur
    Maître WordPress
    20124 contributions

    Bonjour,

    Avez-vous testé l’installation et le fonctionnement de base d’un WP vierge sur Wamp ? Le problème vient peut-être de là.

    Et avez-vous activé le rewrite_mode dans Wamp ? Je ne sais pas si c’est activé automatiquement dans la dernière version, mais à l’époque où j’avais installé Wamp, ce n’était pas activé, ce qui déclenchait des erreurs 404 partout sauf sur l’accueil.

    #2470802
    cacalsof
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Non je n’ai pas installé de WP vierge dessus, d’ailleurs je n’ai rien fait car c’est un nouveau PC, nouveau DD, et je viens de refaire l’installation de tous les éléments.

    Pour le mode rewrite, oui il est actif de base sur wamp, j’ai quand meme vérifié.

    Si je tape localhost/monsite/wp-admin j’ai un 404 avec un url flingué :

    J’arrive sur localhost/monsite/wp-admin/localhost/wp-login.php?redirectblablabla

    et je continu… si je tape localhost/monsite/wp-login

    il ouvre bien la page localhost/monsite/wp-login.php?redirectblablabla mais sans css …. et si je rentre les données de connexion

    il arrive sur localhost/wp-login.php donc un gros NOT FOUND

    J’ai déjà galéré dans le temps à réactiver un site en local, mais ici ???? je sèche

     

     

     

    #2470821
    Flobogo
    Modérateur
    Maître WordPress
    20124 contributions

    C’est donc peut-être votre installation de WAMP qui bugue quelque part. C’est pourquoi je vous conseille d’installer un WP « de base » (nouvelle installation vierge) : une fois que celle-ci fonctionnera, vous pourrez y importer votre base de données et placer la copie du dossier wp-content du site précédent.

    #2470853
    cacalsof
    Participant
    Initié WordPress
    4 contributions

    ok je vais tester un wp vierge aujourd’hui… je vous tiens au courant des résultats…

    #2470855
    cacalsof
    Participant
    Initié WordPress
    4 contributions

    Re….. l’installation d’un WP vierge s’est passée correctement.

    J’ai comparé les 2 BDD et je me suis rendu compte que je n’avais plus la ligne « blogname » dans la table « options ».

    Je l’ai recréé et j’ai inséré une valeur à savoir http://locahost/monsite

    Du coup j’ai aussi modifié la valeur de siteurl par http://locahost/monsite

    Et j’ai accés maintenant à l’admin.

    Merci beaucoup pour votre coup de main, quelquefois les conseil les plus simple sont les meilleurs.

    Maintenant le vrai travail peut enfin commencer…

    #2470887
    Flobogo
    Modérateur
    Maître WordPress
    20124 contributions

    De rien. Je passe le sujet en « résolu »

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.