Impossible de me connecter en tant qu’admin

  • Statut : non résolu
7 sujets de 1 à 7 (sur un total de 7)
  • Auteur
    Messages
  • #450945
    koz
    Membre
    Chevalier WordPress
    305 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.1.2
    – Nom de l’hebergeur : OVH
    – Adresse du site : http://www.koztoujours.fr

    Problème(s) rencontré(s) :

    J’ai dû réinstaller wordpress, et la base de données, suite à un changement de solution d’hébergement. Pb : à chaque restauration de BDD réussi, lorsque je tente de me connecter, il refuse le mot de passe donné à l’install. J’utilise donc mon ancien mot de passe et là, voilà sur quoi je tombe :

    Warning: Invalid argument supplied for foreach() in /home.10.6/koztoujo/www/wp-includes/capabilities.php on line 31

    Warning: Cannot modify header information – headers already sent by (output started at /home.10.6/koztoujo/www/wp-includes/capabilities.php:31) in /home.10.6/koztoujo/www/wp-includes/pluggable.php on line 313

    Warning: Cannot modify header information – headers already sent by (output started at /home.10.6/koztoujo/www/wp-includes/capabilities.php:31) in /home.10.6/koztoujo/www/wp-includes/pluggable.php on line 314

    Warning: Cannot modify header information – headers already sent by (output started at /home.10.6/koztoujo/www/wp-includes/capabilities.php:31) in /home.10.6/koztoujo/www/wp-includes/pluggable.php on line 275

    Et lorsque je veux me faire renvoyer un mdp, j’ai un message me disant que “la combinaison identifiant / adresse e-mail n’est pas valide.”.

    Si vous avez une idée …😉

    #594684
    nomasis
    Membre
    Initié WordPress
    39 contributions

    Rhô ! mais c’est Khoz que je lis sur Agoravox
    c’est la classe ce forum.
    À part je peux pas t’aider : suis nioubie sur WP.
    Désolé.
    À te lire.

    #594685
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Il y’a un petit problème lors de la migration de la DB.

    Fais une petite recheche, j’ai deja filé la soluce.
    Au pire…. je la retaperai 😉

    #594686
    koz
    Membre
    Chevalier WordPress
    305 contributions

    Merci d’en avoir au moins eu l’intention nomasis 😉

    AmO, j’imagine que c’est la solution qui figure là : http://www.wordpress-fr.net/support/sujet-4043-resolu-erreur-php-login-apres-changement-hebergeur

    AmO wrote:
    Le problème vient de l’import de la base de données.

    Tu as de problème d’accents ?

    Si oui, retente l’import, en bidouillant l’encodage.

    Si non, modifie la table wp_options depuis pma
    avec le champ :

    (66, 0, ‘wp_user_roles’, ‘Y’, 1, ‘a:5:{s:13:”administrator”;a:2:{s:4:”name”;s:14:”Administrateur”;s:12:”capabilities”;a:47:{s:13:”switch_themes”;b:1;s:11:”edit_themes”;b:1;s:16:”activate_plugins”;b:1;s:12:”edit_plugins”;b:1;s:10:”edit_users”;b:1;s:10:”edit_files”;b:1;s:14:”manage_options”;b:1;s:17:”moderate_comments”;b:1;s:17:”manage_categories”;b:1;s:12:”manage_links”;b:1;s:12:”upload_files”;b:1;s:6:”import”;b:1;s:15:”unfiltered_html”;b:1;s:10:”edit_posts”;b:1;s:17:”edit_others_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:10:”edit_pages”;b:1;s:4:”read”;b:1;s:8:”level_10″;b:1;s:7:”level_9″;b:1;s:7:”level_8″;b:1;s:7:”level_7″;b:1;s:7:”level_6″;b:1;s:7:”level_5″;b:1;s:7:”level_4″;b:1;s:7:”level_3″;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:17:”edit_others_pages”;b:1;s:20:”edit_published_pages”;b:1;s:13:”publish_pages”;b:1;s:12:”delete_pages”;b:1;s:19:”delete_others_pages”;b:1;s:22:”delete_published_pages”;b:1;s:12:”delete_posts”;b:1;s:19:”delete_others_posts”;b:1;s:22:”delete_published_posts”;b:1;s:20:”delete_private_posts”;b:1;s:18:”edit_private_posts”;b:1;s:18:”read_private_posts”;b:1;s:20:”delete_private_pages”;b:1;s:18:”edit_private_pages”;b:1;s:18:”read_private_pages”;b:1;s:12:”delete_users”;b:1;s:12:”create_users”;b:1;}}s:6:”editor”;a:2:{s:4:”name”;s:7:”Editeur”;s:12:”capabilities”;a:34:{s:17:”moderate_comments”;b:1;s:17:”manage_categories”;b:1;s:12:”manage_links”;b:1;s:12:”upload_files”;b:1;s:15:”unfiltered_html”;b:1;s:10:”edit_posts”;b:1;s:17:”edit_others_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:10:”edit_pages”;b:1;s:4:”read”;b:1;s:7:”level_7″;b:1;s:7:”level_6″;b:1;s:7:”level_5″;b:1;s:7:”level_4″;b:1;s:7:”level_3″;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:17:”edit_others_pages”;b:1;s:20:”edit_published_pages”;b:1;s:13:”publish_pages”;b:1;s:12:”delete_pages”;b:1;s:19:”delete_others_pages”;b:1;s:22:”delete_published_pages”;b:1;s:12:”delete_posts”;b:1;s:19:”delete_others_posts”;b:1;s:22:”delete_published_posts”;b:1;s:20:”delete_private_posts”;b:1;s:18:”edit_private_posts”;b:1;s:18:”read_private_posts”;b:1;s:20:”delete_private_pages”;b:1;s:18:”edit_private_pages”;b:1;s:18:”read_private_pages”;b:1;}}s:6:”author”;a:2:{s:4:”name”;s:6:”Auteur”;s:12:”capabilities”;a:10:{s:12:”upload_files”;b:1;s:10:”edit_posts”;b:1;s:20:”edit_published_posts”;b:1;s:13:”publish_posts”;b:1;s:4:”read”;b:1;s:7:”level_2″;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:12:”delete_posts”;b:1;s:22:”delete_published_posts”;b:1;}}s:11:”contributor”;a:2:{s:4:”name”;s:12:”Contributeur”;s:12:”capabilities”;a:5:{s:10:”edit_posts”;b:1;s:4:”read”;b:1;s:7:”level_1″;b:1;s:7:”level_0″;b:1;s:12:”delete_posts”;b:1;}}s:10:”subscriber”;a:2:{s:4:”name”;s:13:”Abonné”;s:12:”capabilities”;a:2:{s:4:”read”;b:1;s:7:”level_0″;b:1;}}}’, 20, 8, ”, 1, ‘yes’),

    Désolé, effectivement, on se prend à croire que son petit pb est bien original, alors que non…

    Bon, pour le moment, je cherche la bonne table, et j’espère comprendre tout seul comment la modifier 😉

    Une question, tout de même : il ne faut toucher à wp-options que si l’on n’a pas de pbs d’accent ? Parce que j’en ai…

    #594687
    koz
    Membre
    Chevalier WordPress
    305 contributions

    J’ai trouvé aussi ce fil : http://www.wordpress-fr.net/support/sujet-4147-acces-administration-apres-upgrade-impossible

    Mais je ne sais pas comment modifier le champ, ni faire une install en local.

    Par ailleurs, pour les accents, je veux bien refaire l’import et “trifouiller l’encodage”, mais dans quel sens ? (en regardant dans la BDD, il semble que je sois en latin_swedish, eh oui…)

    #594688
    koz
    Membre
    Chevalier WordPress
    305 contributions

    Dominique Perretti m’a donné une solution :

    Une solution qui peut marcher est de forcer l’utf8 à la sortie de la base.
    Dans wordpress, normalement, il faut regarder le fichier wp-db.php qui
    se trouve dans wp-includes.
    Chez moi, il y a une fonction ligne 42 qui s’appelle :

    function wpdb($dbuser, $dbpassword, $dbname, $dbhost)

    Ligne suivante, tu as :

    $this->dbh = @mysql_connect($dbhost, $dbuser, $dbpassword);

    Eh bien tu peux ajouter, juste derrière cette ligne, les lignes suivantes :

    mysql_query(“set character_set_results = ‘utf8’;”, $this->dbh);
    mysql_query(“set character_set_connection = ‘utf8’;”, $this->dbh);
    mysql_query(“set character_set_client = ‘utf8’;”, $this->dbh);

    J’ai le sentiment que ça pourrait marcher !

    Et ça a marché. Je ne pensais pas que le pb d’encodage et le pb d’accès à l’admin était lié. Mais si.

    #594689
    mj23
    Membre
    Initié WordPress
    41 contributions

    slt j’ai eu ce pb il y a qqs jours en passant d’un compte free à un autre free
    meme en modifiant les 2 trucs dans la BDD ca marchait pas

    ma soluce marche seulement si tu as tjs ton ancien blog en ligne :

    tu vas dans “options”
    Adresse de WordPress (URL) : tu tapes l’adresse de ton futur hebergement
    Adresse du blog (URL) : idem

    là tu valides et tu vas réexporter ta nouvelle BDD. Il ne te reste plus qu’à importer cette BDD sur ton nouveau blog

    moi ca a marché 😉
    bon courage
    MJ

7 sujets de 1 à 7 (sur un total de 7)
  • Vous devez être connecté pour répondre à ce sujet.