[Résolu] Impossible de configurer le même header sur ma “page des articles”

  • WordPress :5.2
  • Statut : résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2292649
    Alexis Ducat
    Participant
    Initié WordPress
    3 contributions

    Bonjour à tous.

    Ma configuration WP actuelle :
    – Version de WordPress : 5.3.2
    – Version de PHP/MySQL : 7.2.22 / 5.6.43
    – Thème utilisé : Smart Theme v3
    – Thème URI : http://optimizetheme.com
    – Extensions en place : Ad Injection (1.2.0.19), ClickFunnels (3.1.1), Forum_wordpress_fr (4.2), Google Analytics for WordPress by MonsterInsights (7.10.3), iThemes Security (7.6.1), OptimizeBuilder (1.0.17), OptimizePress Dashboard (1.0.17), Really Simple SSL (3.2.7), SSL Insecure Content Fixer (2.7.2), WordPress Force HTTPS (0.1.4), WordPress HTTPS (3.4.0), WP Super Cache (1.7.0), Yet Another Related Posts Plugin (5.1.2), Yoast SEO (12.8)
    – Adresse du site : https://vouloirinvestir.fr
    – Nom de l’hébergeur : Apache

    Problème(s) rencontré(s) :

    En toute honnêteté, cela fait des jours que je cherche en vain une solution à mon problème, je me repose sur cette communauté dans l’espoir d’obtenir enfin une aide concluante !

    Je n’y connais rien en codage, je n’ai aucune connaissance de base. Ce site est en cours de création depuis peu mais voilà, depuis le début, quelque chose m’échappe.

    J’ai pu faire un joli header (à mon sens) sur ma page d’accueil, ma page programme et même mes mentions légales (le même partout), mais il m’est impossible de mettre le même header sur ma page blog destinée à recevoir les articles (ni même le footer).

    Certes, c’est personnalisable depuis “Apparence ->  Theme Options” mais le fait est que je n’arrive jamais à obtenir le même header sur toutes les pages donc ce n’est pas une solution, c’est plutôt du cache misère selon moi.

     

    Pour préciser la situation, j’ai créé toutes mes pages à partir de templates OptimizePress, or, dès que je mets la page blog en tant que “page des articles” toutes mes modifications préalables disparaissent et je me retrouve avec le header de base (+ footer) configuré dans Smart Theme qu’il m’est impossible de supprimer.

    C’est à la fois simple et compliqué à expliquer, je pense avoir été clair mais si ce n’est pas le cas dites le moi.

    En vous remerciant d’avance pour les réponses apportées !

    #2292674
    momofr@free.fr
    Modérateur
    Maître WordPress
    2873 contributions

    Salut, c’est tout à fait normal, les réglages de Lecture des préférences de WordPress pointent vers les fichiers modèle du thème.

    Si tu veux utiliser une mise en forme particulière tu ne dois pas pointer de page particulière dans ce réglages mais créer ta propre page de sommaire de blog. Il suffit ensuite de l’ajouter à ton menu comme Blog. Dans ce cas il te faut un module pour présenter les articles dans cette page.

    #2292687
    PhiLyon
    Modérateur
    Maître WordPress
    24381 contributions

    Bonjour.

    As-tu regardé cette doc, ils parlent de Blog Post Hero https://docs.optimizepress.com/category/2220-blog-setup

    🙂

    #2292701
    Alexis Ducat
    Participant
    Initié WordPress
    3 contributions

    Merci pour vos précieuses réponses, qu’entendez vous par “module pour présenter les articles dans cette page” ? Et avec cette option, est-ce que les articles peuvent s’intégrer sans souci directement à la page tout comme la “page des articles” ?

    Quand à la ressource OptimizePress, c’est bien pensé mais je n’ai pas trouvé de solution en regardant les vidéos.

    #2292723
    Alexis Ducat
    Participant
    Initié WordPress
    3 contributions

    J’ai trouvé la solution, pour celles ou ceux qui souhaitent l’obtenir il vous suffit de sélectionner “OP3 – Full Width Template” dans les paramètres toutes vos pages : cela aura pour effet d’apposer le même header et le même footer partout de façon automatique ! 🙂

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.