[Résolu] Impossible d’ajouter un article et télécharger des images (Créer un compte)

  • WordPress :6.0
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 44)
  • Auteur
    Messages
  • #2428254
    Remi Coachsenior
    Participant
    Initié WordPress
    27 contributions

    Bonjour,

    Ma configuration WP actuelle : 6.0.3

    • Version de PHP/MySQL : 7.4
    • Thème utilisé : MintWP
    • Extensions en place : WP Super Cache, Smush
    • Nom de l’hébergeur :  OVH
    • Adresse du site :  http://www.en-forme-apres-50ans.com

    Problème(s) rencontré(s) :  Depuis plusieurs jours je n’arrive pas à ajouter un article, j’ai affiché : Permalien : prewiew=true et « vous êtes en train de modifier la page d’accueil ». Je ne sais pas comment résoudre ce problème, je peux juste écrire en lieu et place d’articles anciens.

    D’autre part je ne peux pas non plus télécharger des photos depuis mes fichiers jusqu’à ma médiathèque, message d’erreur. La photo de mise en avant du nouvel article n’est pas affichée.

    Merci par avance de bien vouloir me conseiller.

    Rémi

    #2428267
    Hatake
    Participant
    Chevalier WordPress
    180 contributions

    Bonjour,
    Cela ressemble à ce message de discussion
    https://wpfr.net/support/sujet/permalien-previewtrue-la-ou-il-devrait-y-avoir-lurl-de-la-page/

    Vous avez quelle offre chez OVH ?
    La base de  mémoire peut être saturé.

    Sur OVH, vous pouvez faire une restauration de votre site avant ce problème.

    #2428338
    Remi Coachsenior
    Participant
    Initié WordPress
    27 contributions

    Bonsoir,

    Merci pour votre réponse. Effectivement j’avais déjà vu le lien du post en rapport, sans voir la solution.

    J’ai l’offre perso2014 chez OVH et une utilisation de 9.07 GO sur 100 Go possible.

    J’ai déjà fait une sauvegarde à – 1 mois, d’une je perds mon dernier article, 2 le problème revient.

    J’avoue être perdu.

    Rémi

    #2428344
    Hatake
    Participant
    Chevalier WordPress
    180 contributions

    Re,
    L’offre Perso2014, les 100 Go, c’est l’espace disque, mais la base de données MySQL ?
    L’offre Perso actuelle, a une base de données de « 1 base de 200 Mo ».

    Il faudrait essayer de mettre un autre thème, (en passant le thème MintWP dernière mise à jour : 27 juillet 2021), puis désactiver les plugins.
    Vous avez seulement 2 plugins ?
    Il est bien d’avoir un site à jour, pas seulement au niveau de WordPress, mais aussi du thème et des plugins, une mise à jour de l’année en cours, pour limiter les risques de conflits, d’erreur, de bug.

    #2428347
    ferman
    Participant
    Maître WordPress
    5584 contributions

    Il est facile de vérifier si c’est bien un problème de base de données depuis l’espace client OVH.

    #2428371
    Remi Coachsenior
    Participant
    Initié WordPress
    27 contributions

    Bonsoir,

    J’avais repris une base de données de 400 mo j’en suis à 174 mo.

    J’ai 36 extensions dont All in one security, Seo framework, Updraft, wp optimize, Medusa, Fast vélocity etc

    Je vais essayer avec un autre thème à jour, merci de m’avoir fait la remarque concernant Mintwp.

    #2428373
    Flobogo
    Modérateur
    Maître WordPress
    18887 contributions

    Bonjour,

    J’avais repris une base de données de 400 mo j’en suis à 174 mo

    Cela fait quand même lourd ! Ça peut expliquer que ça mouline. Puisque vous avez WP Optimize, regardez ce que vous pouvez optimiser. Et si ça ne fonctionne pas à partir de l’admin’, passez directement par PhpMyAdmin (tuto).

    Autre piste : désactivez toutes vos extensions, et voyez si vous pouvez télécharger une image. Si oui, c’est qu’une de vos extensions alourdit ou bloque tout le système !

    #2428388
    Remi Coachsenior
    Participant
    Initié WordPress
    27 contributions

    Mais est-ce qu’une extension pourrait entrainer l’impossibilité de rajouter un article ? Et de ne pas me retrouver avec un « prewiew=true ?

    #2428409
    Flobogo
    Modérateur
    Maître WordPress
    18887 contributions

    Je vous ai suggéré 2 pistes. Ce sont des pistes, pas des solutions garanties à 100%. Commencez par suivre le 1er conseil si vous voulez.

    #2428486
    Remi Coachsenior
    Participant
    Initié WordPress
    27 contributions

    Bonjour à tous,

    Après désactivation de toutes les extensions, toujours les mêmes messages d’erreur et impossibilité de télécharger des images.

    Optimisation faite. Je vais restaurer encore une fois à – 1 mois et voir à nouveau. Sinon je tenterai en changeant le thème.

    Enfin je ne sais pas trop quoi faire de plus…

    #2428505
    Hatake
    Participant
    Chevalier WordPress
    180 contributions

    Bonjour,
    36 plugins, cela augmente les risques de soucis.
    Je vous conseillerai de vérifier si leurs mises à jour sont de l’année en cours https://wordpress.org/plugins/

    Par exemple, il y a des plugins sans mises à jour depuis 4 ans.
    https://fr.wordpress.org/plugins/wp-speed-grades-pro/

    Celui là, sans mise à jour depuis 2 ans.
    https://fr.wordpress.org/plugins/wp-advanced-search/

    Celui 3 ans sans mise à jour.
    https://fr.wordpress.org/plugins/sola-testimonials/

    #2428539
    Remi Coachsenior
    Participant
    Initié WordPress
    27 contributions

    Re,

    Oui j’ai retiré ces plugins obsolètes, maintenant même en changeant et activant un nouveau thème (Human), toujours impossible de télécharger des images (notamment pour l’en-tête) et de pouvoir écrire un nouvel article. Je retrouve même pas la date des différents médias déposés des années avant. Et toujours ce pénible « prewiew=true’…

    #2428679
    Flobogo
    Modérateur
    Maître WordPress
    18887 contributions

    Après optimisation, vous avez quel poids de BDD ? Vous avez réussi à installer un nouveau thème, mais vous n’arrivez pas à télécharger une image ?? C’est bizarre …

    Vous avez vidé le cache de WP-Super-Cache ? C’est une extension un peu complexe à configurer, et parfois, une erreur peut persister, si l’extension est mal désactivée. (voir son support)

    Au pire, il va falloir activer le mode « debug » pour afficher les erreurs → suivez ces consignes , en résumé :

    • Par FTP, affichez votre fichier wp-config.php. Faites une sauvegarde sur votre ordinateur.
    • Ensuite, recherchez la ligne suivante, et modifier false par true :
    define( 'WP_DEBUG', false );
    • Puis, ajoutez ces lignes :
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', true );

     

    • Envoyez cette nouvelle version du fichier wp-config.php par FTP du côté hébergement ; puis rendez-vous sur votre site. Les erreurs devraient être listées.
    • Copiez les erreurs, pour revenir les coller ici.
    • Puis repassez « true » à « false » dans la 1ère ligne de débug du fichier wp-config.php si vous ne voulez pas que les erreurs restent affichées sur votre site.

     

    #2428788
    Hatake
    Participant
    Chevalier WordPress
    180 contributions

    Bonjour,
    Ce n’était que des exemples de plugins obsolètes, vous avez vérifié le reste de vos plugins ?
    A tester, supprimer WP Super Cache
    https://tipsnfreeware.com/how-to-uninstall-wp-super-cache-wordpress-plugin/

    Mettre à la place le plugin WP Fastest Cache.

    Hâte de voir les messages d’erreur par le mode Debug.

    #2428793
    Remi Coachsenior
    Participant
    Initié WordPress
    27 contributions

    Bonjour,

    Où se trouve le mode débug ? J’ai installé Fatest cache

15 sujets de 1 à 15 (sur un total de 44)
  • Vous devez être connecté pour répondre à ce sujet.