[Résolu] Impossible d’ajouter de nouvelles pages – Mise à jour échouée

  • WordPress :5.2
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 29)
  • Auteur
    Messages
  • #2277391
    BenPix
    Participant
    Initié WordPress
    15 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.0/5.6
    • Thème utilisé : Divi
    • Extensions en place : Comarquage service-public.fr(0.5.5) / Divi Booster (2.9.9) / Divi Builder (2.20.2) / Divi Contact Form DB (1.7) / Divi Switch (3.0.1) / Google Map Embed (1.4.7)
    • Nom de l’hébergeur : OVH
    • Adresse du site :

    Problème(s) rencontré(s) : Bonjour, depuis hier soir, je ne peux plus ajouter de nouvelles pages. La page de création de page semble fonctionner, mais lorsque je clique sur le bouton User Divi Builder, un message en encadré rouge apparaît indiquant Mise à jour échouée.

    J’ai pu avoir une info sur l’erreur, la voici :

    TypeError: Cannot read property ‘name’ of undefined
    at ye (https://mon_site/wp-includes/js/dist/blocks.min.js?ver=6.2.5:2:84764)
    at je (https://mon_site/wp-includes/js/dist/blocks.min.js?ver=6.2.5:2:85060)
    at t.value (https://mon_site/wp-includes/js/dist/block-editor.min.js?ver=2.0.3:55:185734)
    at ce (https://mon_site/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:98:136)
    at qg (https://mon_site/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:97:440)
    at hi (https://mon_site/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:104:285)
    at Qg (https://mon_site/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:144:217)
    at Rg (https://mon_site/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:145:76)
    at Sc (https://mon_site/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:158:109)
    at Z (https://mon_site/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.8.4:156:492)

    D’autre part, je peux voir dans la base de données qu’il essaye de me créer ma page, car il y a un insert, avec la valeur Brouillon auto dans la colonne post_title.

    J’ai tenté de désactiver tous les plugins, ce qui n’a rien changé au problème.

    Est-ce dû au fait que je n’ai pas encore acheté la licence de Divi ? Si oui, pourquoi cela ne provoquait pas d’erreur auparavant ?

    J’ai tenté ce qui est proposé dans ce post, mais sans succès, l’erreur reste la même (bien que je n’aie pas trop compris la solution…changer le nom du dossier me fait perdre toutes mes extensions, donc je ne peux plus créer de pages, et quand je le remet comme avant, aucun changement sur l’erreur).

    Merci de votre aide

    • Ce sujet a été modifié le il y a 1 mois par  BenPix.
    #2277804
    BenPix
    Participant
    Initié WordPress
    15 contributions

    Il n’y a personne pour m’aider ?

    #2277819
    PhiLyon
    Modérateur
    Maître WordPress
    23781 contributions

    Bonjour.

    Est-ce dû au fait que je n’ai pas encore acheté la licence de Divi ?

    Le plus simple est de leur demander.

    🙂

    #2277910
    Flobogo
    Modérateur
    Maître WordPress
    15850 contributions

    Bonjour,

    Et par ailleurs, vérifiez que vous n’avez pas atteint la capacité maximale de votre offre chez votre hébergeur. (la base de données ou l’ensemble des fichiers sont peut-être trop volumineux)

    #2278027
    BenPix
    Participant
    Initié WordPress
    15 contributions

    J’attend la réponse de l’équipe Divi.

    Pour ce qui est de la capacité maximale, j’avais déjà vérifié et je suis très loin des maxima. Donc c’est autre chose.

    #2278336
    BenPix
    Participant
    Initié WordPress
    15 contributions

    L’équipe Divi m’invite à acheter la licence pour qu’ensuite leur Support Technique réponde à ma question (vu qu’il faut être licencié pour pouvoir contacter le support). Et si le support me dit que cette erreur n’a rien à voir avec eux, j’en serai toujours au même point.

    #2278340
    ferman
    Participant
    Maître WordPress
    1189 contributions

    Bonjour,

    Regardez ici pour des problèmes semblables et une solution (revenir à l’éditeur classique) qui n’en est pas vraiment une. Ou peut-être pour une solution réelle si vous avez  la chance que le problème soit le même.

     

    #2278406
    Flobogo
    Modérateur
    Maître WordPress
    15850 contributions

    Si vous pensez que le problème vient de DIVI, il y a un moyen simple de vérifier : en passant par FTP, accédez au dossier wp-content/themes, et là, renommez le dossier de divi en ajoutant un -x à la fin, par ex. Cela activera un des thèmes par défaut de WordPress (Nineteen ou un thème de la série Twenty-XX)

    Si le problème est résolu, c’est que ça vient de DIVI. Dans le cas contraire, il faudra faire d’autres tests.

    #2278442
    BenPix
    Participant
    Initié WordPress
    15 contributions

    J’ai tenté la solution de ferman avec le nettoyage du cache du navigateur, mais sans succès.

    J’ai également tenté de renommer le dossier theme, puis le dossier plugins, puis les 2 en même temps, toujours le même message d’erreur à la création de page. Le problème ne provient donc pas de Divi ni des autres thèmes ou plugins.

    On avance, merci pour votre aide, même si le soucis n’est toujours pas résolu.

    #2278502
    BenPix
    Participant
    Initié WordPress
    15 contributions

    J’ai remarqué que le bug nous affecte depuis que WP s’est mis à jour, en passant de la version 5.2.2 à la 5.2.3. Je pensais donc avoir trouvé la solution, en revenant à la version précédente de WP, mais étrangement il n’y a aucune amélioration…

    Pourtant, ça ne peut pas être une coïncidence. Y aurait-il quelques chose que j’aurais omis de faire ?

    Pour info, j’ai téléchargé la version 5.2.2, puis via FTP j’ai remplacé tous les dossiers et fichiers dans le dossier de WP sauf le wp-content, et enfin j’ai lancé la page mon_site/wp-admin/update-core.php.

    #2278594
    Flobogo
    Modérateur
    Maître WordPress
    15850 contributions

    J’ai également tenté de renommer le dossier theme

    Impossible, car WordPress a besoin d’un thème. Je vous ai dit de renommer le dossier du thème Divi donc par exemple wp-content/themes/divi-X

    via FTP j’ai remplacé tous les dossiers et fichiers dans le dossier de WP sauf le wp-content

    C’est exactement ce qu’il faut faire, mais avec la version 5.2.3. Il y a peut-être un fichier manquant, et en remettant la 5.2.2, le fichier nécessaire n’est toujours pas là. Il est d’ailleurs conseillé de supprimer wp-admin et wp-includes, et la quinzaine de fichiers à la racine (sauf wp-content, donc, et sauf wp-config.php) avant d’uploader les nouveaux dossiers et fichiers en remplacement.

    #2278645
    BenPix
    Participant
    Initié WordPress
    15 contributions

    Pardon, c’est ce que je voulais dire, j’ai changé le dossier divi et non pas le dossier theme… Excusez-moi pour mon manque de précision dans ma réponse.

    Ce qui m’a paru étrange c’est qu’après ça, il me proposait toujours de créer la page avec le divi builder ! C’est pourquoi j’ai ensuite désactivé tous les plugins ET le theme divi, pour créer une page de façon basique. Mais toujours le même message d’erreur.

     

    Vous me conseillez donc de mettre la version 5.2.3 via FTP, en veillant à bien supprimer puis uploader les fichiers, et non les remplacer, plutôt que de faire la mise à jour depuis le tableau de bord ?

    Si effectivement un fichier manque,et qu’en remettant 5.2.2 il ne soit toujours pas là, pourquoi la 5.2.3 contiendrait-elle ce fichier ?

    Faut-il également supprimer le htaccess lors de cette procédure, étant donné qu’il ne sera pas recréé ?

     

    Je vais tenter la mise à jour en 5.2.3 via FTP comme vous me le proposez et j’éditerai mon post pour donner le résultat.

     

    • Cette réponse a été modifiée le il y a 3 weeks et 1 jour par  BenPix.
    • Cette réponse a été modifiée le il y a 3 weeks et 1 jour par  BenPix.
    #2278671
    BenPix
    Participant
    Initié WordPress
    15 contributions

    Aucun changement…

    #2278810
    Flobogo
    Modérateur
    Maître WordPress
    15850 contributions

    Si effectivement un fichier manque,et qu’en remettant 5.2.2 il ne soit toujours pas là, pourquoi la 5.2.3 contiendrait-elle ce fichier ?

    Ben, la 5.2.3 est différente de la 5.2.2. Donc, il peut y avoir un fichier nécessaire à la 5.2.3 (qui serait mal passé la 1ère fois) mais qui ne serait pas dans la 5.2.2.

    Essayez de passer en PHP 7.1 ou même 7.2 chez OVH. Si ça ne donne rien non plus, contactez-les pour voir si il n’y a pas un problème de leur côté.

    Et merci de mettre l’adresse de votre site, si besoin en message privé. (seuls les admins du forum la verront)

    #2278872
    BenPix
    Participant
    Initié WordPress
    15 contributions

    Merci pour les explications.

    J’ai mis la version 5.2.3 plusieurs fois, et ça n’a jamais résolu le problème, donc ça doit pas être ça.

    Je vais changer de version PHP on verra bien. Entre temps j’ai sollicité le support de Divi, s’ils apportent une réponse, je le partagerai. Pareil pour OVH.

    Je vous partage le lien du site en MP.

15 sujets de 1 à 15 (sur un total de 29)
  • Vous devez être connecté pour répondre à ce sujet.