Impossible d’afficher un album avec wppa (Créer un compte)

  • Statut : non résolu
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #517399
    Albumenfolie
    Participant
    Initié WordPress
    10 contributions

    Bonsoir,

    Je viens vers vous car je suis désespérée !
    j’ai installée l’extension wppa sur mon site http://www.albumenfolie.com.
    J’ai même mis en place la « photo du jour » avec le widget, nickel…
    et là ça se corse car je n’arrive pas à afficher un album photo dans une page.
    Je n’écrit que des pages et aucun article car s’est un site professionnel de photographe, d’où l’importance d’arriver à mettre en place le wppa.

    Lorsque je met le %%wppa%%
    il se passe ceci :
    http://www.albumenfolie.com/naissance-2/

    j’ai tout essayé mais sans aucun résultat, vous êtes ma dernière chance, après ça je jette l’éponge !

    Merci mille fois d’avance pour l’aide que vous pourrez m’apporter.

    Cathy

    #866641
    Flobogo
    Modérateur
    Maître WordPress
    20088 contributions

    Salut,

    J’ai mis en place ce plugin depuis 1 semaine, alors, je vais essayer de t’aider, car j’ai réussi à afficher des albums photos.

    Pour t’aider, as-tu consulté la rubrique « aide et info » du plugin ? Elle est à moitié en français et moitié en anglais, mais ça aide quand même 😉

    Je te copie-colle ci-dessous une partie de cette aide (en italique), et je mets l’essentiel en gras :


    – Installer WP Photo ALbum Plus comme décrit au dessous de « Installation ».
    – Créer au moins deux albums dans l’onglet « Albums photos ». Il suffit d’entrer le nom et une brève description puis d’appuyez sur « Créer Album ». Laissez  » Parent » à  » — aucun —« .
    – Dans l’onglet d’upload, vous pouvez maintenant uploader vous photos. Uploadez au moins 2 photos à chaque album. Assurez-vous que les photos que vous uploadez sont de taille raisonnable (disons jusqu’à 1024×768 pixels). Ne pas uploader des images 7 MPixels !
    – Créer une nouvelle page WP, nommez-la avec quelque chose comme « Gallerie Photo » and placez ceci dans le contenu: %%wppa%%
    – Publiez la page, et visualisez la page depuis votre site WP.
    – Maintenant, allez jouer avec les options du menu « Options », découvrez toutes les options configurables et regarder ce qui se passe lorsque vous ré-ouvrez la page « Gallerie Photo ».

    En résumé : il faut d’abord créer 2 albums, et pour chacun d’eux, mettre « aucun » parent.
    Ce n’est que comme ça que le code %% wppa %% fonctionnera ! C’est le principe de « galerie » qui contient plusieurs albums photos … donc 2 au minimum !!

    Mon résultat est là : http://www.mon-coin-de-bourgogne.fr/galeries-de-photos/

    Sinon, pour 1 seul album, il faut spécifier son n° ID
    Je copie-colle l’aide (dont la dernière ligne est en anglais 😕 )

    Si vous souhaitez afficher un seul album – par exemple l’album n° 19 – dans une page WP ou dans un article WP (ils agissent exactement de la même manière), ajouter une deuxième ligne comme ceci:
    %%album=19%%
    This will result in the display of the contents of album nr 19.

    Pour ma part, c’est un peu là que je coince : je voudrais pouvoir afficher un album dans une page, qui ne serait pas dans ma liste d’albums par défaut (la galerie). Mais impossible de créer une album x sans le rattacher à un parent … qui lui sera affiché dans la page d’albums par défaut :(

    Dis-moi si tu y arrives pour une galerie d’abord … et pour un album seul dans une page, qui ne serait pas repris dans la galerie générale.

    #866642
    Albumenfolie
    Participant
    Initié WordPress
    10 contributions

    bonsoir,

    C’est exactement ce que j’ai fait : 2 albums , avec -aucun- parents.
    je suis allez voir le guide info , même mon mari (plus calé que moi en anglais) et informaticien n’y est pas arrivé !

    On ne voit pas où sa bloque !
    On a essayé le code %%wppa%% et celui d’un seul album mais que dalle.
    on dirait que le code trouve pas le chemin.

    Tu as vu ce qui apparait en bleu sur la page ?

    en tout cas Merci pour ta réponse.

    #866643
    Flobogo
    Modérateur
    Maître WordPress
    20088 contributions

    Salut,

    Oui, j’avais vu ta page. J’ai pensé que tu n’avais pas créé 2 albums, ou pas mis « aucun » pour l’album-parent.

    Ce qui est bizarre, c’est que j’avais d’abord essayé le plugin Next Gen Gallery (ça fait 1 mois et 1/2 que j’ai mis en route la création de mon site), et j’ai eu un problème similaire : le code s’affichait, au lieu de l’album … :(
    Puis j’avais réussi à obtenir au moins les vignettes … (mais je ne sais plus en faisant quoi)
    Par contre, WPPA a fonctionné tout de suite chez moi.

    Est-ce que tu as bien suivi les étapes dans l’ordre ?
    –> d’abord créer deux albums vides, sans parent ; puis mettre des photos dedans ; puis créer la page « galerie » et enfin y mettre le code.

    Peut-être que si tu désactives et supprimes le plugin, puis tu le réinstalles et tu ré-essayes, ça marchera ? 😕

    #866644
    Albumenfolie
    Participant
    Initié WordPress
    10 contributions

    Re !

    ALors moi la seule différence ( mais on a essayer aussi de modifier) est que ma page s’appelle « naissance  » ou « grossesse » comme les albums d’ailleurs …

    sinon on a fait exactement ça.

    Mais désinstaller et ré-installer j’y ai pensé. Je vais essayer et je vous dirais.

    Merci

    #866645
    Flobogo
    Modérateur
    Maître WordPress
    20088 contributions

    En fait, j’ai jeté un oeil à ton code-source. Pour l’insertion de l’album, je vois ça :

    <p><strong></p><span style="color:blue;font-weight:bold">[WPPA+ Photo display]</span><p><br />

    Je ne suis pas une grande spécialiste, mais je crois que tu devrais virer le HTML qui entoure l’insertion du code.
    Mets-toi sur l’onglet HTML de l’édition de page, et enlève les balises

    , etc … qui suivent la fin de ton texte « normal » de présentation

    En espérant que tu n’aies pas déjà tout désinstallé 😕

    #866646
    Albumenfolie
    Participant
    Initié WordPress
    10 contributions

    Salut,

    Alors justement j’allais m’y mettre….comme j’ai pas tout compris ce que tu m’as expliqué, je vais attendre que mon mari rentre et il pourra peut-être m’aider avec tes explications.

    Merci,

    Je te tiens au courant 🙂

    #866647
    Albumenfolie
    Participant
    Initié WordPress
    10 contributions

    en attendant j’ai mis une galerie mais ce n’est pas ce que je veux !

    #866648
    Flobogo
    Modérateur
    Maître WordPress
    20088 contributions

    Ce que je te conseillais, c’était en quelque sorte de « nettoyer » ton code HTML avant et après l’insertion du code %%wppa%%
    Comme tu as mis d’autres photos (au passage : elles sont adorables, ces photos de bébés !), ce que je t’indiquais n’apparaît plus dans ton code-source (= le HTML de la page)

    – Sois tu remodifies ta page pour essayer d’insérer tes albums WPPA après avoir supprimé ceux de la galerie WordPress.
    – Ou alors, tu recrées une nouvelle page (en donnant un titre provisoire que tu modifieras ensuite pour remettre l’ancien) et tu ré-essayes l’insertion directe des albums WPPA.

    En cas de souci, il va falloir que je discute avec ton mari à propos du HTML si pour toi c’est … du chinois !
    Pourtant, je trouve ton site très joli et il semble bien construit, c’est déjà un beau résultat !
    Si besoin, n’hésites pas à m’envoyer un MP, je te donnerai mon adresse mail perso, ce sera peut-être plus facile pour échanger.

9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.