[Résolu] Impossible d’accéder à WP-admin (Créer un compte)

  • WordPress :4.9.4
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 18)
  • Auteur
    Messages
  • #2393675
    shihoo
    Participant
    Chevalier WordPress
    173 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 8.1/5.7
    • Thème utilisé : Stroevilla
    • Extensions en place : Advanced WP Columns, Business Hours Indicator, Contact Form 7, Jackmail Newsletters, Jetpack par WordPress.com, Pricing Table by Supsystic, Shortcodes Ultimate, TinyMCE Advanced, Ultimate Social Media PLUS, WooCommerce, WP Google Maps, E-transactions, W3 total cache
    • Nom de l’hébergeur : 1and1
    • Adresse du site : boutique.dautek.fr

    Problème(s) rencontré(s) :  Je ne plus accéder à wp-admin. C’est un site que je vais fermé mais je voudrais y accéder pour récupérer certaines données. Voir la capture pour le message d’erreur. Merci pour votre aide.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2393680
    Li-An
    Modérateur
    Maître WordPress
    26212 contributions

    Bonjour, vos données sont dans la base de données. Vous pouvez y accéder via le phpmyadmin de votre hébergeur.

    Sinon, allez par FTP au niveau du répertoire wp-content/plugins et changez son nom en pluginsxxx pour désactiver toutes les extensions. Même chose pour le thème dans wp-content/themes/nom-du-theme. Et réessayez.
    Pour retrouver les extensions et le thème, il suffira de remettre les noms par défaut des répertoires.

    #2393682
    shihoo
    Participant
    Chevalier WordPress
    173 contributions

    Tout d’abord merci de m’avoir répondu. J’ai fait ce que vous m’avais dit et voici ce que cela donne, regardez la capture.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2393687
    pasglop
    Participant
    Chevalier WordPress
    436 contributions

    Est-ce depuis que le site tourne avec un PHP 8.1 ?

    #2393689
    shihoo
    Participant
    Chevalier WordPress
    173 contributions

    Non j’étais en PHP 7.3 mais il n’était plus valide alors je suis passé en 8.1. J’ai fait pareil avec un autre site et cela a fonctionné.

    J’ai essayé de repasser en 7.4 car 7.3 n’existe plus mais cela ne fonctionne pas.

    #2393691
    Li-An
    Modérateur
    Maître WordPress
    26212 contributions

    C’est visiblement lié à votre extension de cache W3 Total Cache. C’est une vrai plaie ce plugin, je vous mets les manips à faire manuellement https://www.thewebmaster.com/wordpress-articles/how-to-uninstall-w3-total-cache-manually/

    #2393707
    shihoo
    Participant
    Chevalier WordPress
    173 contributions

    Ok merci je vais essayer et du coup par quel plugin de cache je pourrai le remplacer?

    • Cette réponse a été modifiée le il y a 3 mois et 3 semaines par shihoo.
    #2393711
    shihoo
    Participant
    Chevalier WordPress
    173 contributions

    J’ai fais ce que le tuto disais, j’ai supprimé tout les fichiers à part wp-cache-config.php car je ne l’avais pas dans mon dossier. J’ai ensuite enlever tout ce qui resté dans mon fichier .htaccess pour laisser que ce qu’il dit mais cela ne change rien je peux toujours pas y accéder.

    #2393724
    Li-An
    Modérateur
    Maître WordPress
    26212 contributions

    Vous avez toujours le même message ? Parce que le précédent était lié au cache. Baissez le php à 7.4+

    #2393726
    shihoo
    Participant
    Chevalier WordPress
    173 contributions

    Oui j’ai toujours le même message et si je met le PHP a 7.4 je n’ai même plus accès au site, j’ai un même d’erreur alors que en 8.0 ou 8.1 je peux accéder au site mais pas eu backoffice.

    #2393733
    Li-An
    Modérateur
    Maître WordPress
    26212 contributions

    Vous avez bien désactivé thème et extensions par FTP comme je vous l’ai proposé ? Si c’est le cas, il n’y a pas de raison que ça fonctionne en php 8.1 et pas 7.4+

    Remettez éventuellement php 8 que je vois le site – et pour être sûr que vous avez bien tout désactivé.

    #2393734
    shihoo
    Participant
    Chevalier WordPress
    173 contributions

    Je suis en PHP 8.1 mais après les manipulations sur w3 total cache je n’avais pas remis la désactivation du thème et des plugins, chose que je viens de faire et en effet j’ai pu me connecter merci. Du coup si je désactive w3 total cache pourrais je accéder à nouveau à mon site sans désactiver le thème et les plugins?

    Et quel plugin de cache dois-je prendre? Merci

    #2393735
    Li-An
    Modérateur
    Maître WordPress
    26212 contributions

    Il n’y a pas de raison que ça ne marche pas. Dans les extensions de cache, je privilégie https://fr.wordpress.org/plugins/wp-fastest-cache/ qui est assez simple à utiliser.

    #2393736
    shihoo
    Participant
    Chevalier WordPress
    173 contributions

    Du coup je peux pas désactiver w3 total cache puis supprimer le dossier directement dans wp-content/plugins?

    Je vais installer fatest cache alors.

    #2393737
    shihoo
    Participant
    Chevalier WordPress
    173 contributions

    Par contre le site ne fonctionne plus en ayant tout remis sauf w3 total cache, mais j’ai accès au back office.

15 sujets de 1 à 15 (sur un total de 18)
  • Vous devez être connecté pour répondre à ce sujet.