[Résolu] Impossible d’accéder à mon site en local (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
2 sujets de 16 à 17 (sur un total de 17)
  • Auteur
    Messages
  • #2420129
    ferman
    Participant
    Maître WordPress
    5358 contributions

    Bonjour,

    Le site n’est qu’en local actuellement.

    Et donc vous n’avez pas fait de sauvegarde? J’en fais régulièrement; ça permet de tester sans avoir à repartir du site distant en cas de problème sérieux.

    Donc sans avoir de sauvegarde ni de site en ligne, voilà ce que je ferais (et que je n’ai jamais eu à faire):

    1.  On peut espérer que votre base de données est sur votre serveur mais vous ne la voyez pas à cause du changement de port. Regardez  ce que le dossier XAMPP/mysql/data contient. S’il contient votre base de données (ce dont je doute) sauvegardez-le (tout le dossier « data »).
    2. D’autre part, voyez-vous le dossier contenant votre site (wp-admin, include, content .etc)? Si oui faites en une copie.
    3. Regardez ce qui occupe le port 80 (peut -être Skype) et voyez s’il est possible de déloger cet occupant pour le mettre ailleurs. (Voir ICI pour ça et plus largement pour des détails sur les changements de port dans XAMPP). Si vous pouvez libérer le port 80, revenez à la situation de départ en remettant les ports par défaut. Le problème devrait être réglé.
    4. Si vous ne pouvez-pas libérer le port 80, et si le dossier XAMPP/mysql/data dans votre XAMPP « ports modifiés » ne contenait pas votre base de données, sauvegardez le (il devrait contenir votre base de données; à vérifier)*.  Refaites le changement de ports et remplacez le dossier data .Voir ici comment  récupérer les données de la BDD dans les dossiers MYSQL/data.

    *Si le dossier « data » à ce niveau ne contient pas non plus votre base de données, je pense que ce sera très mal parti.

     

     

    #2420172
    batcha
    Participant
    Initié WordPress
    9 contributions

    Ferman, UN GRAND MERCI !! Vous venez de me sauver, j’ai enfin réussi à résoudre le problème grâce à vous !

     

    Lors du changement de port, le tuto me demandais de renommer mon dossier XAMPP/mysql/data en >> XAMPP/mysql/data-old

    Et de renommer en parallèle le dossier XAMPP/mysql/backup en >> XAMPP/mysql/data

    Les BDD n’étaient pas dans le backup d’origine mais étaient toujours dans le « data-old ».

    J’ai donc tout transféré et tout est revenu en ordre.µ

    Encore un grand merci à vous pour  le temps accordé, j’apprécie vraiment.

    Merci également aux autres contributeurs qui m’ont aidé à faire avancer le problème !

2 sujets de 16 à 17 (sur un total de 17)
  • Vous devez être connecté pour répondre à ce sujet.