Impossible d’accéder à l’admin depuis la MAJ 5.0

  • WordPress :5.0
  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2231728
    Arcantide
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé :
    • Extensions en place :
    • Nom de l’hébergeur :
    • Adresse du site :

    Problème(s) rencontré(s) :

     

    Bonjour,

    Après avoir installé la MAJ 5.0 de WP, impossible d’accéder à l’administration du site.

    Quoique je fasse, je retombe sur la même page (voir PJ)

    Que dois-je faire?!

    Merci

    • Ce sujet a été modifié le il y a 1 week et 5 days par  Arcantide.
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2231735
    Arcantide
    Participant
    Initié WordPress
    4 contributions

    Je m’en suis sorti en renommant le répertoire /plugins en /pluginsOLD.
    De là, j’ai pu accéder à l’admin de WP.
    Et j’ai enfin renommé le répertoire des plugins avec son nom original.
    Ça marche mais je ne comprends pas ce qui s’est passé!
    Une url mise en cache?
    Merci quand même 😉

    #2231794
    C_Lucien
    Modérateur
    Maître WordPress
    3373 contributions

    Bonjour,

    la compatibilité du thème et des extensions avec la version 5.0 avait-elle été vérifiée avant mise à jour ?

    #2231876
    Arcantide
    Participant
    Initié WordPress
    4 contributions

    Bonjour Lucien,

    Merci de votre retour.

    Comment vérifier la compatibilité d’un thème ou d’un plugin?

    #2231970
    Flobogo
    Modérateur
    Maître WordPress
    15055 contributions

    Bonjour,

    Comment vérifier la compatibilité d’un thème ou d’un plugin?

    En consultant son descriptif (sur wp.org pour les extensions et thèmes gratuits)

    Pour info, avant toute mise à jour (surtout aussi importante que la passage v 4.x à v 5.0), il est fortement conseillé de désactiver toutes ses extensions.

    #2233265
    yourtes chapuze
    Participant
    Initié WordPress
    5 contributions

    Bonjour, j’ai le même problème qu’Arcantide.

    Je ne réussissais plus à me connecter sur l’admin. J’ai donc modifié wp-contents/plugins   en wp-contents/pluginsOLD.

    Cela m’a permis de rouvrir l’admin de mon site (ouf!). Par contre que faire ensuite, tout est désactivé, aucune axtension n’est plus installé. Je dois toutes les réinstaller ?

    Et que faire avec la modification wp-contents/pluginsOLD, il faut le laisser ?

    Mon thème est Vantage (j’ai un vantage-child), extensions : gutemberg,   contact-form-7,  métaslider,   really simple SSL, wordpress SEO et un peu d’autres.

    Merci d’avance et merci pour les réponses précédentes car je me sens vraiment seule face à ce problème. Cela a même fait planter mon ordi lors de l’installation.

     

     

    #2233356
    Arcantide
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    il suffit de renommer à nouveau le répertoire avec son nom d’origine et tout rentre dans l’ordre.

    Une url mise en cache sans doute. Je ne sais pas trop…

    #2233519
    Flobogo
    Modérateur
    Maître WordPress
    15055 contributions

    Bonjour @yourtes-chapuze,

    Après avoir récupéré l’accès admin’, vos extensions sont désactivées, mais toujours présentes. Vous pouvez donc renommer normalement le dossier wp-content/plugins, puis vous retournez dans l’admin’ du site, vous allez sur la liste des extensions, et vous les réactivez l’une après l’autre. Si aucune ne provoque le bug, tout va bien.

    Comme je le disais :

    avant toute mise à jour (…), il est fortement conseillé de désactiver toutes ses extensions.

    #2234025
    yourtes chapuze
    Participant
    Initié WordPress
    5 contributions

    Merci pour les infos. Cela fonctionne. Désormais, je ferai attention à la compatibilité des extensions …

    Pour ma part, ce problème est résolu, et par la même occasion un autre problème de téléchargement d’image qui fonctionne à nouveau depuis cette mise à jour.

     

    #2234122
    FloA
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Même difficulté, aucun accès depuis 9h ce matin avec ce message d’erreur : « Error establishing a database connection ».

    A quel moment aurais-je pu être prévenue du passage à une nouvelle version? Tout allait bien en éteignant hier soir et plus d’accès ce matin avec un mail à 11h28 signifiant que mon site a été mis à jour.

    Que faire? Merci par avance de tout élément de réponse.

    #2234127
    C_Lucien
    Modérateur
    Maître WordPress
    3373 contributions

    Bonjour,

    @FloA

    Votre problème est différent, ce n’est pas forcément la même configuration. Merci d’ouvrir une nouvelle discussion et de compléter le questionnaire.

    #2234466
    FloA
    Participant
    Initié WordPress
    2 contributions

    Dans les 2 minutes qui ont suivi ce post, mon accès s’est miraculeusement rétabli…Merci beaucoup C_Lucien de votre réactivité.

    #2234484
    Flobogo
    Modérateur
    Maître WordPress
    15055 contributions

    Bonjour @floa

    Votre problème était totalement différent, puisqu’il concerne la mise à jour automatique en version 4.9.9 pour ceux qui étaient encore en 4.9.8. Alors que la mise à jour évoquée dans cette discussion (et dans cette rubrique du forum), c’est celle du passage en 5.0 qui ne se fait pas automatiquement justement parce que comme c’est une MAJ importante.

    Pour info, chaque mise à jour (automatique ou non) peut entraîner un bug si un fichier passe mal. Mais la plupart des MAJ automatiques se passent sans souci, car ce sont des mises à jour mineures, avec parfois juste quelques fichiers modifiés. Elles sont tout de même très importantes, car elles concernent souvent la sécurité, c’est pour ça qu’elles sont faites automatiquement.

    Ici, il est question du passage en WP 5.0, qui est une version « majeure » avec de gros changements, notamment celui du passage de l’éditeur visuel au système par « blocs » appelé Gutenberg.
    C’est pourquoi chaque utilisateur devra faire manuellement cette mise à jour, quand il/elle sera prêt(e). En particulier, il est conseillé de la tester localement ou sur site en sous-domaine.

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.