Impossible d’accèder à la base de données

  • WordPress :4.9.4
  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #2124494
    hatfab
    Participant
    Initié WordPress
    26 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 5.4
    • Thème utilisé : Lovecraft
    • Extensions en place :
    • Nom de l’hébergeur : free-h.org
    • Adresse du site :

    Problème(s) rencontré(s) :

    Bonjour,

    Je cherche à mettre en place un réseau multisite WP. Je suis la procédure normale mais après avoir collé ces lignes dans mon fichier wp-config.php :

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', 'wp.primavera-esi.org');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    j’obtiens ce message : Une ou plusieurs tables de votre base de données sont indisponibles. La base de données a peut-être besoin d’être réparée.

    Puis, après réparation ceci :

    wpfc_1_posts: Table ‘wordpress2016.wpfc_1_posts’ doesn’t exist
    wpfc_1_comments: Table ‘wordpress2016.wpfc_1_comments’ doesn’t exist
    wpfc_1_links: Table ‘wordpress2016.wpfc_1_links’ doesn’t exist
    wpfc_1_options: Table ‘wordpress2016.wpfc_1_options’ doesn’t exist
    wpfc_1_postmeta: Table ‘wordpress2016.wpfc_1_postmeta’ doesn’t exist
    wpfc_1_terms: Table ‘wordpress2016.wpfc_1_terms’ doesn’t exist
    wpfc_1_term_taxonomy: Table ‘wordpress2016.wpfc_1_term_taxonomy’ doesn’t exist
    wpfc_1_term_relationships: Table ‘wordpress2016.wpfc_1_term_relationships’ doesn’t existwpfc_1_termmeta: Table ‘wordpress2016.wpfc_1_termmeta’ doesn’t exist
    wpfc_1_commentmeta: Table ‘wordpress2016.wpfc_1_commentmeta’ doesn’t exist

    Quelqu’un peut-il m’aider à résoudre ce problème ?

    Merci

     

     

    #2125676
    momofr@free.fr
    Modérateur
    Maître WordPress
    1561 contributions

    Salut, je pense que tu n’as pas suivi la bonne procédure, on ne place qu’une ligne dans wp-config.php :

    define(‘WP_ALLOW_MULTISITE’, true);

    Une fois fait tu lances la procédure d’installation et tu fais tout le reste depuis l’administration WP (installation thèmes, extensions, sites et domaine, etc.

    #2125700
    hatfab
    Participant
    Initié WordPress
    26 contributions

    Salut, merci de ta réponse. Après avoir activé le réseau avec WP, il te demande bien de copier ces lignes dans ton fichier wp-config.php. C’est à partir de là que ça bug.

    Une idée ?

    Merci

    #2125703
    hatfab
    Participant
    Initié WordPress
    26 contributions

    Voici la capture d’écran:

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2125713
    momofr@free.fr
    Modérateur
    Maître WordPress
    1561 contributions

    Tu fais bien les changements dans le fichier htaccess ?

    #2125715
    hatfab
    Participant
    Initié WordPress
    26 contributions

    Oui, et d’ailleurs on dirait que c’est lui qui pose problème. Si je remets le fichiers .htaccess comme d’origine, je n’ai plus l’erreur. Mais je n’ai pas encore installé le 2e site.

     

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.