impossibilité d’activé plugin yoast

  • WordPress :4.9.4
  • Statut : non résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #2160502
    casper
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    Ma configuration WP actuelle WordPress 4.9.6

    • Version de PHP/MySQL : 5.4.16 / 5.5.56-MariaDB
    • Thème utilisé :  responsive (mais earth est prévu prochainement)
    • Extensions en place :  – active : All-in-One Event Calendar by Time.ly et BackWPup; inactive : Akismet Anti-Spam, Google Maps CP, Hello Dolly, Hueman Addons
    • Nom de l’hébergeur : haisoft.net (Linux)
    • Adresse du site : (serveur distant)

    Problème(s) rencontré(s) :

    Bonjour à tous, Débutant en wordpress, je reprends un site basique que je dois modifier. J’éprouve des difficultés lors de l’activation du module SEO Yoast.  Après plusieurs tentatives infructueuses, je réessaie de façon différente en indiquant define(‘WP_DEBUG’, true); dans le wp-config.php.

    J’installe le plugin SEO Yoast (après avoir télécharger le .zip en local) tout ce passe bien. Mais quand je clique sur le bouton pour l’activé j’ai une erreur qui apparaît:

    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 49152 bytes) in /var/www/vhosts/site.com/httpdocs/wp-admin/includes/media.php on line 371

    L’interface d’administration n’est plus accessible. Je dois supprimer le répertoire du plugin via FTP pour récupérer l’interface d’admin.

    J’ imagine que c’est un paramètre du serveur à modifier, mais lequel ?  Est il possible d’effectuer la modification via ini_set() ? Si oui comment et ou ?

    Comment me sortir de ce mauvais pas ?  Y a t-il des informations du phpinfo() qui vous serraient nécessaire pour me répondre?

    Ci-après, en fichier joint, un extrais des logs du serveur (error_log). [J’ai modifier uniquement l’URL du site.]

    Je remercie par avance celui ou celle qui pourra m’aider.

    Jean-Pierre

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2160576
    Li-An
    Modérateur
    Maître WordPress
    20005 contributions

    Bonjour, il me semble que Yoast nécessite au moins php 5.6 sachant que php 7.0+ voire 7.1+ est recommandé pour WP.

    #2161761
    casper
    Participant
    Initié WordPress
    2 contributions

    Bonjour, LI-An merci pour votre réponse. Sur cette page, il est indiqué que la version minimum de php demandée est 5.2.4. D’où mon incompréhension.

    J’éprouve également des difficultés pour l’ installation du thème earth que nous avons acheté. Ce qui n’est pas normal puisque j’ai réussi en local.

    Je n’ai pas la main sur le serveur, je vais contacté la personne qui le gère et lui demandé de passer à PHP 7+ pour voir.    Et je reviens vers vous.

    Merci

    Jean-Pierre

     

    #2161775
    Li-An
    Modérateur
    Maître WordPress
    20005 contributions

    Ah vous avez raison, Yoast SEO ne demande « que » php 5.2.4. Mais cette version de php n’est plus maintenue depuis des années et WP recommande php 7+ rien que pour des raisons de rapidité d’exécution.

    Pour ce qui est de votre message premier, il indique un problème de mémoire à l’installation de l’extension, c’est à dire que le serveur n’est pas assez costaud pour gérer cette installation. Comme ce n’est pas du mutualisé, c’est assez compliqué (voire impossible pour moi) de vous aider plus). C’est la personne qui gère le serveur qui peut corriger les problèmes à ce niveau.

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.