Images : galère ! (Créer un compte)

  • Statut : non résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #462195
    codfingers
    Participant
    Maître WordPress
    541 contributions

    Bonjour,

    depuis la version 2.6 je n’ai que des problèmes question images. Je suis passé en version 2.6.1 et c’est pareil

    Tout a commencé lorsque par mégarde ( grrrrrr!) j’ai supprimé en ftp dans mon dossier “mes images ” et “2008” le dossier créé par wordpress : 08

    Dans divers mes réglages sont corrects / mes images et l’url complet.

    Mais lorsque je veux importer une image maintenant voilà le résultat :
    Warning: file_exists() [function.file-exists]: Unable to access /mes images in /mnt/124/free.fr/e/8/catastrophy.b/wordpress/wp-includes/functions.php on line 1435

    Warning: is_dir() [function.is-dir]: Unable to access / in /mnt/124/free.fr/e/8/catastrophy.b/wordpress/wp-includes/functions.php on line 1444

    Warning: file_exists() [function.file-exists]: Unable to access / in /mnt/124/free.fr/e/8/catastrophy.b/wordpress/wp-includes/functions.php on line 1435

    Warning: is_dir() [function.is-dir]: Unable to access / in /mnt/124/free.fr/e/8/catastrophy.b/wordpress/wp-includes/functions.php on line 1444

    Warning: file_exists() [function.file-exists]: Unable to access / in /mnt/124/free.fr/e/8/catastrophy.b/wordpress/wp-includes/functions.php on line 1435

    Warning: is_dir() [function.is-dir]: Unable to access / in /mnt/124/free.fr/e/8/catastrophy.b/wordpress/wp-includes/functions.php on line 1444

    Warning: file_exists() [function.file-exists]: Unable to access / in /mnt/124/free.fr/e/8/catastrophy.b/wordpress/wp-includes/functions.php on line 1435

    Warning: is_dir() [function.is-dir]: Unable to access / in /mnt/124/free.fr/e/8/catastrophy.b/wordpress/wp-includes/functions.php on line 1444

    Warning: file_exists() [function.file-exists]: Unable to access / in /mnt/124/free.fr/e/8/catastrophy.b/wordpress/wp-includes/functions.php on line 1435

    Warning: is_dir() [function.is-dir]: Unable to access / in /mnt/124/free.fr/e/8/catastrophy.b/wordpress/wp-includes/functions.php on line 1444

    Warning: file_exists() [function.file-exists]: Unable to access / in /mnt/124/free.fr/e/8/catastrophy.b/wordpress/wp-includes/functions.php on line 1435

    Warning: is_dir() [function.is-dir]: Unable to access / in /mnt/124/free.fr/e/8/catastrophy.b/wordpress/wp-includes/functions.php on

    J’ai tout essayé creer un dossier 08 ( ce doit sûrement être un dossier spécial) , enlever la fonction “Organiser mes fichiers envoyés dans des dossiers mensuels et annuels! des heures passées ! Mais je n’arrive pas à résoudre ce problème !!

    Qui a une solution ?

    Cordialement,

    #642303
    Aurélien Denis
    Gestionnaire du forum
    Chevalier WordPress
    205 contributions

    Salut,

    je pense qu’il s’agit des autorisations d’accès aux fichiers (CHMOD) qui doit être mal paramétré.

    Utilise ton client FTP pour les modifier et si tu ne sais pas trop quoi mettre, lis ceci : WordPress Permissions

    #642304
    codfingers
    Participant
    Maître WordPress
    541 contributions

    je suis sur Mac et je ne sais pas comment faire pour cette autorisation dont tu parles.

    En ftp j’ai un dossier “mes images” et dedans le dossier 2008, il manque le dossier 08 que j’ai viré.

    là je suis complètement bloqué.

    #642305
    JayLBR
    Participant
    Maître WordPress
    1067 contributions

    hello,

    Le droit dont parle Maigret est un droit CHMOD.

    Dans ton FTP, fait un clic droit sur ton dossier et regarde les droits CHMOD. Coche tout ou taper directement 777.

    Par contre ton message est peut etre du à autre chose. Je m’explique, quand tu as mis tes photos la première fois, elle se sont inscrite dans ta base de donnée. Si tu veux les uploader une nouvelle fois, elles seront peut etre considérées comme déjà existantes.

    Si tu as supprimé ton répertoire images sur ton FTP, le mieux est peut être de le recréer dans ton FT et d’y glisser tes images et miniatures concervant les nom des images et la l’architecture du répertoire comme il l’était avant.

    Maintenant si le problème se pose également sur une nouvelle image (inexistante avant), alors y a des chance que ça soit un problème de droit d’écriture sur ton FTP.

    #642306
    applimed
    Participant
    Chevalier WordPress
    183 contributions

    Dans WordPress 2.6 et 2.6.1 (contrairement aux versions antérieures) le répertoire de stockage des images doit être spécifié explicitement dans Réglages > Divers > Chemin d’URL complet pour les fichiers, s’il est différent de celui par défaut (wp-content/upload), ce qui semble être votre cas, même si cette option est affichée comme “facultative”.

    Voir http://www.wordpress-fr.net/support/viewtopic.php?pid=85864#p85864

    #642307
    codfingers
    Participant
    Maître WordPress
    541 contributions

    En effet le dossier 07 (juillet) les infos sont rwxr-xr-x (755)

    Si pour le dossier que j’ai créé 08 (puisque je l’avais viré en faisant une fausse manip)

    Ce dossier nouveau 08 est seulement rwx


    (700)

    Si je veux le transformer en 7555 ou 777( rwxrwxrwx) j’obtiens du serveur (free)
    Erreur ftp impossible de changer les permissions
    Command unrecognized

    230 User catastrophy logged in.
    CWD /wordpress/mes images/2008
    250 CWD command successful.
    SITE CHMOD 777 08
    500 ‘SITE’: command unrecognized.

    j’espère pouvoir être aider car je craque un peu sur ce 100000m, sans doute un manque de préparation sportive

    cordialement,

    #642308
    Aurélien Denis
    Gestionnaire du forum
    Chevalier WordPress
    205 contributions

    Je viens d’apprendre qu’il était impossible de modifier les permissions chez Free…

    #642309
    codfingers
    Participant
    Maître WordPress
    541 contributions

    que faire alors ? parce que je ne peux plus importer d’images !!!

    #642310
    applimed
    Participant
    Chevalier WordPress
    183 contributions

    Effectivement, on ne peut pas modifier les permissions des dossiers chez Free, mais chez moi, ça ne pose pas de problème pour l’importation des images, moyennant la précaution indiquée dans mon précédent message.

    #642311
    codfingers
    Participant
    Maître WordPress
    541 contributions

    Bon j’ai résolu ce problème d’une manière barbare :

    Adios le dossier “mes images” ( j’imagine qu’en septembre cela créera un dossier 09… donc je reviendrais dans ce dossier)
    Dans “divers” j’ai mis le chemin wp-content/uploads
    et l’adresse complète.

    WordPress a créé un dossier 2008 , 08 avec les autorisations 755 !!!

    et cela marche !

    Question au calés du code qui peut résoudre le problème que rencontrent les abonnés à free avec le fameux chmod :
    Pourquoi WordPress arrive à créer un dossier Chmod 755 !, et pourquoi, nous, par ftp on ne peut pas !!!

    zarbi non ?

    Je remercie ceux qui m’ont aidé ! Vive WordPress France, ici, les médailles sont en or !

    Cordialement,

    #642312
    codfingers
    Participant
    Maître WordPress
    541 contributions

    Applimed,
    j’ai utilisé votre solution en dernier recours…
    Merçi pour votre aide.
    cordialement,

    #642313
    applimed
    Participant
    Chevalier WordPress
    183 contributions

    Autre conseil : chez Free éviter les noms de dossiers ou de fichiers comportant des espaces (exemple “mes images”) qui posent des problèmes. Votre souci venait peut-être en partie de là.

    Attention aussi aux majuscules / minuscules qui sont prises en compte dans les adresses.

    Donc, choisir des noms tout en minuscules et remplacer les espaces par des traits de soulignement, par exemple : mes_images

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.