Images chez Free (Créer un compte)

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #455425
    Onyx91
    Membre
    Padawan WordPress
    70 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : Version 2.3.1
    – Thème utilisé : Trevilian Way – fr 0.40
    – Plugins en place : Akismet, All in One SEO
    – Nom de l’hebergeur : free.fr

    Problème(s) rencontré(s) :

    Bonjour,

    je mets en place un blog qui sera utilisé sous forme de “magazine”, avec plusieurs contributeurs. Ceux ci, ne sont pas familiers à l’univers des blogs, j’aimerai mettre en place un système de gestion des images plutôt simple.
    En gros, que les contributeurs puissent uploader, depuis l’écriture du billet, leurs images, les affichers dans le billet, pouvoir les redimensionner …

    J’ai essayé NextGen qui m’avait l’air prometteur, seul problème : Free ne laisse pas appliquer un CMOD 777 sur le dossier gallery.

    Quel plugin me conseillez-vous pour gérer les images, sous free ?

    Par avance, merci !

    #614885
    atch
    Participant
    Chevalier WordPress
    127 contributions
    Onyx91 wrote:
    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : Version 2.3.1
    – Thème utilisé : Trevilian Way – fr 0.40
    – Plugins en place : Akismet, All in One SEO
    – Nom de l’hebergeur : free.fr

    Problème(s) rencontré(s) :

    J’ai essayé NextGen qui m’avait l’air prometteur, seul problème : Free ne laisse pas appliquer un CMOD 777 sur le dossier gallery.

    Quel plugin me conseillez-vous pour gérer les images, sous free ?

    Par avance, merci !

    Si ça marche sous free 😉

    Il faut modifier le fichier principal : nggallery.php

    Dans les premières ligne du code il faut modifier :

    // Permission settings ############################################
    define(’NGGFOLDER_PERMISSION’, 0777);
    define(’NGGFILE_PERMISSION’, 0666);
    // ################################################################
    par

    // Permission settings ############################################
    define(’NGGFOLDER_PERMISSION’, 0700);
    define(’NGGFILE_PERMISSION’, 0600);
    // ################################################################
    Cela permettra au moment de vérifier les droits de ne pas avoir de problemes pour écrire dans les répertoires.

    (j’en touche deux mots sur mon blog : http://atchworks.free.fr/?p=18)

    Par contre il faut créer les répertoires à la main via FTP :( à part ça aucun problèmes….)
    L’avantage avec Nextgen, tu peux jouter des droits selon le niveau des rédacteurs.

    Sinon via imagemanager c’est pas mal aussi 😉 pour ajouter des photos mais multi utilisateurs je ne sais pas si c’est sure au niveau des droits (effacer les images d’un tiers!!!)

    V++

    Atch

    #614886
    Onyx91
    Membre
    Padawan WordPress
    70 contributions

    Merci de l’astuce Atch !
    Par contre … je créé mon repertoire gallery dans /wp-content … et des sous dossiers dedans. Mais ca ne me reconnait pas de galleries dans l’interface admin … j’arrive a créer des albums, mais pas de galleries, du coup, pas d’upload possible … que faire ?

    Merci par avance 😉

    #614887
    atch
    Participant
    Chevalier WordPress
    127 contributions
    Onyx91 wrote:
    Merci de l’astuce Atch !
    Par contre … je créé mon repertoire gallery dans /wp-content … et des sous dossiers dedans. Mais ca ne me reconnait pas de galleries dans l’interface admin … j’arrive a créer des albums, mais pas de galleries, du coup, pas d’upload possible … que faire ?

    Merci par avance 😉

    Dans tes sous répertoires, as tu ajouté à l’intérieur de chaque un répertoire “thumbs”?
    c’est nécéssaire pour créer les galeries.

    Ensuite, dans l’admin du plugin, tu vas dans/ ajouter une galerie/ importer via un dossier d’image, et tu mets le nom de ton répertoire.
    Ensuite, meme s’il te dit 0 photo ajoutée, va dans gérer une galerie, sélectionne la galerie et clique sur scanner le répertoire.

    Normalement ça devrait t’afficher les images 😉

    V++

    Atch

    #614888
    Onyx91
    Membre
    Padawan WordPress
    70 contributions

    Je ne comprends pas trop, le problème subsiste.

    J’ai bien créé les dossiers “thumbs” dans chaque dossier de ma gallerie.

    En fait, j’ai un dossier “gallery” dans /wp-content/ et dans /wp-content/gallery, là, j’ai créé mes dossiers correspondant à d’éventuels albums (avec a l’intérieur, /thumbs/), j’ai bon ?

    Et quand je veux faire “upload image” … j’ai “choose gallery”, mais il m’en propose aucune, alors que mes repertoires sont créés.
    De même que quand je vais dans “Manage gallery”, c’est vide.

    Si vous avez une idée … merci 🙂

    #614889
    atch
    Participant
    Chevalier WordPress
    127 contributions
    Onyx91 wrote:
    Je ne comprends pas trop, le problème subsiste.

    J’ai bien créé les dossiers “thumbs” dans chaque dossier de ma gallerie.

    En fait, j’ai un dossier “gallery” dans /wp-content/ et dans /wp-content/gallery, là, j’ai créé mes dossiers correspondant à d’éventuels albums (avec a l’intérieur, /thumbs/), j’ai bon ?

    Et quand je veux faire “upload image” … j’ai “choose gallery”, mais il m’en propose aucune, alors que mes repertoires sont créés.
    De même que quand je vais dans “Manage gallery”, c’est vide.

    Si vous avez une idée … merci 🙂

    Maintenant que ta galerie est créée physiquement il te faut la créer sur la base de donnée.

    Tu vas dans ajouter galerie et tu nommes la galerie avec le meme nom que ton répertoire 😉

    Normalement ça devrait le faire.

    v++

    Atch

    #614890
    Onyx91
    Membre
    Padawan WordPress
    70 contributions

    Merci Atch.

    En fait quand je fais ça, ça me dit :

    Directory wp-content/gallery/ didn’t have the permissions 0!
    Check this link, if you didn’t know how to set the permission : http://codex.wordpress.org/Changing_File_Permissions

    Malgré les changements que j’ai fait dans le fichier comme tu m’as dit au début …. :s

    #614891
    atch
    Participant
    Chevalier WordPress
    127 contributions
    Onyx91 wrote:
    Merci Atch.

    En fait quand je fais ça, ça me dit :

    Directory wp-content/gallery/ didn’t have the permissions 0!
    Check this link, if you didn’t know how to set the permission : http://codex.wordpress.org/Changing_File_Permissions

    Malgré les changements que j’ai fait dans le fichier comme tu m’as dit au début …. :s

    Normallement ça marche comme meme.

    Il continue à me mettre ce message mais, quand tu fais ” scanner le repertoire” dans la galerie; il te trouve les images.

    V++

    Atch

    #614892
    marjomax
    Membre
    Padawan WordPress
    54 contributions
    atch wrote:
    Onyx91 wrote:
    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : Version 2.3.1
    – Thème utilisé : Trevilian Way – fr 0.40
    – Plugins en place : Akismet, All in One SEO
    – Nom de l’hebergeur : free.fr

    Problème(s) rencontré(s) :

    J’ai essayé NextGen qui m’avait l’air prometteur, seul problème : Free ne laisse pas appliquer un CMOD 777 sur le dossier gallery.

    Quel plugin me conseillez-vous pour gérer les images, sous free ?

    Par avance, merci !

    Si ça marche sous free 😉

    Il faut modifier le fichier principal : nggallery.php

    Dans les premières ligne du code il faut modifier :

    // Permission settings ############################################
    define(’NGGFOLDER_PERMISSION’, 0777);
    define(’NGGFILE_PERMISSION’, 0666);
    // ################################################################
    par

    // Permission settings ############################################
    define(’NGGFOLDER_PERMISSION’, 0700);
    define(’NGGFILE_PERMISSION’, 0600);
    // ################################################################
    Cela permettra au moment de vérifier les droits de ne pas avoir de problemes pour écrire dans les répertoires.

    (j’en touche deux mots sur mon blog : http://atchworks.free.fr/?p=18)

    Par contre il faut créer les répertoires à la main via FTP :( à part ça aucun problèmes….)
    L’avantage avec Nextgen, tu peux jouter des droits selon le niveau des rédacteurs.

    Sinon via imagemanager c’est pas mal aussi 😉 pour ajouter des photos mais multi utilisateurs je ne sais pas si c’est sure au niveau des droits (effacer les images d’un tiers!!!)

    V++

    Atch

    Bonjour,
    Je voulais faire cette méthode pour pouvoir utiliser cette extension, mais je n’ai pas ce code dans le nggallery.php, y-a-t-il un autre moyen ?

    Merci
    Eric

    #614893
    marjomax
    Membre
    Padawan WordPress
    54 contributions

    Re-moi,

    Je crois avoir trouvé ma réponse ici :
    http://www.wordpress-fr.net/support/sujet-11090-impossible-utiliser-nextgen-gallery

    Je vais essayer.
    Eric

    #614894
    marjomax
    Membre
    Padawan WordPress
    54 contributions

    Super cette m”thode fonctionne apparemment ✅ pour moi……:wp:
    Merci.

    FInalement, je me parle tout seul 😉:hs:

    #614895
    IPreferNcy
    Membre
    Chevalier WordPress
    176 contributions

    Ok mais niveau sécurité, ce n’ est pas un peu risqué ???

    #614896
    marjomax
    Membre
    Padawan WordPress
    54 contributions

    Bonjour,

    Ben peut-être, mais est-ce qu’il y a une autre solution ?? 😉

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.