Il y a eu une erreur critique sur ce site. (Créer un compte)

  • WordPress :6.1
  • Statut : non résolu
  • Ce sujet contient 22 réponses, 3 participants et a été mis à jour pour la dernière fois par Li-An, le il y a 1 année.
15 sujets de 1 à 15 (sur un total de 23)
  • Auteur
    Messages
  • #2449404
    streghe
    Participant
    Padawan WordPress
    51 contributions

    Bonjour,

    Ma configuration WP actuelle 6.1.1

    • Version de PHP/MySQL : PHP 8.1.2 /MySQL 8.0.32
    • Thème utilisé :
    • Extensions en place :
    • Nom de l’hébergeur : localhost
    • Adresse du site : localhost

    Problème(s) rencontré(s) :

    Bonjour à tous, Bonjour à toutes

    D’abord un très grand merci à Madame Valérie Galassi d’avoir réglé le problème de mot de passe car je n’arrivais pas à me connecter

    Je suis en ce moment sous Xubuntu 22.04.2 et je travaille sur mon site blog en ligne en localhost

    Je ne suis plus mit depuis plussieurs années et donc je crains que ni mon blog, ni ma base de données ne sont à jours

    J’ai téléchargé et mit à jour la partie script du site, et je tombe sur l’erreur

    Il y a eu une erreur critique sur ce site

    En manipulant le fichier « wp-config.php » en fonction de « wp-config-dample.php », j’ai ajouté les lignes

    // Définition de l'adresse Parent (évite les redirections intempestives)
    define('WP_HOME', 'http://localhost/quelqueslignes');
    define('WP_SITEURL', 'http://localhost/quelqueslignes');

    // Installations des thèmes et plugins en localhost
    define('FS_METHOD', 'direct');

    // Active l’enregistrement dans le fichier /wp-content/debug.log
    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );

    // Désactive l’affichage des erreurs et des avertissements
    define( 'WP_DEBUG_DISPLAY', true );
    @ini_set( 'display_errors', 0 );
    define ('WP_ALLOW_REPAIR', true);

    // Utiliser les versions en développement des fichiers JS et CSS de base (seulement nécessaire si vous modifiez ces fichiers de base)
    define( 'SCRIPT_DEBUG', true );

    /* C'est tout, ne touchez pas au reste ! Bloguez bien ! */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    require_once(ABSPATH . 'wp-settings.php');

    J’ai donc les erreurs suivantes

    Deprecated: Optional parameter $file declared before required parameter $force is implicitly treated as a required parameter in /srv/quelqueslignes/wp-content/plugins/google-document-embedder/functions.php on line 100

    Deprecated: Function load_plugin_textdomain was called with an argument that is deprecated since version 2.7.0 with no alternative available. in /srv/quelqueslignes/wp-includes/functions.php on line 5677

    Deprecated: Function add_option was called with an argument that is deprecated since version 2.3.0 with no alternative available. in /srv/quelqueslignes/wp-includes/functions.php on line 5677

    Deprecated: Optional parameter $formdata declared before required parameter $nonce is implicitly treated as a required parameter in /srv/quelqueslignes/wp-content/plugins/wp-pagenavi/scb/Forms.php on line 65

    Deprecated: Optional parameter $file declared before required parameter $args is implicitly treated as a required parameter in /srv/quelqueslignes/wp-content/plugins/wp-pagenavi/scb/Cron.php on line 24

    Fatal error: Uncaught Error: Call to undefined function create_function() in /srv/quelqueslignes/wp-content/plugins/simple-tags/simple-tags.php:85 Stack trace: #0 /srv/quelqueslignes/wp-includes/class-wp-hook.php(308): init_simple_tags() #1 /srv/quelqueslignes/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters() #2 /srv/quelqueslignes/wp-includes/plugin.php(517): WP_Hook->do_action() #3 /srv/quelqueslignes/wp-settings.php(480): do_action() #4 /srv/quelqueslignes/wp-config.php(54): require_once('...') #5 /srv/quelqueslignes/wp-load.php(50): require_once('...') #6 /srv/quelqueslignes/wp-blog-header.php(13): require_once('...') #7 /srv/quelqueslignes/index.php(17): require('...') #8 {main} thrown in /srv/quelqueslignes/wp-content/plugins/simple-tags/simple-tags.php on line 85

    Notice: La fonction is_embed a été appelée de façon incorrecte. Les balises de requête conditionnelle ne fonctionnent pas avant le lancement de la requête. Avant cela, elles renvoient toujours le booléen false. Veuillez lire Débogage dans WordPress (en) pour plus d’informations. (Ce message a été ajouté à la version 3.1.0.) in /srv/quelqueslignes/wp-includes/functions.php on line 5835

    Notice: La fonction is_search a été appelée de façon incorrecte. Les balises de requête conditionnelle ne fonctionnent pas avant le lancement de la requête. Avant cela, elles renvoient toujours le booléen false. Veuillez lire Débogage dans WordPress (en) pour plus d’informations. (Ce message a été ajouté à la version 3.1.0.) in /srv/quelqueslignes/wp-includes/functions.php on line 5835

    Il y a eu une erreur critique sur ce site.

    En apprendre plus sur le débogage de WordPress.

    Certains fichiers de dossiers qui n’ont pas été mit à jour sont devenus obsolètes

    wp-content/plugins/google-document-embedder/functions.php on line 100
    wp-includes/functions.php on line 5677
    wp-content/plugins/wp-pagenavi/scb/Forms.php on line 65
    wp-content/plugins/wp-pagenavi/scb/Cron.php on line 24
    wp-content/plugins/simple-tags/simple-tags.php on line 85
    wp-includes/functions.php on line 5835

    Je ne sais pas quoi faire

    Pourriez-vous m’apporter une aide

    Cordialement,

    Streghe

    #2449417
    C_Lucien
    Modérateur
    Maître WordPress
    5116 contributions

    Bonjour,

    les messages d’erreur suggèrent que plusieurs extensions ne fonctionnent pas correctement.

    Dans un premier temps, désactivez les extensions en renommant le dossier plugins.

    Si ça rentre dans l’ordre, vous pourrez remettre le nom d’origine. Ensuite, renommer chaque dossier d’extension pour la rendre inactive.

    Les installer depuis le dépôt officiel et les activer. Vous aurez ainsi des versions à jour.

    Si ça ne fonctionne pas avec cette méthode, faudra creuser et comme je ne suis pas seul ici, d’autres idées seront les bienvenues…

    #2449434
    streghe
    Participant
    Padawan WordPress
    51 contributions

    Bonjour,

    Merci pour votre réponse

    Le problème étant que je n’ai pas accès à ce blog pour le moment, donc il m’est impossible de désactiver quoi que ce soit

    #2449565
    Li-An
    Participant
    Maître WordPress
    28351 contributions

    Bonjour, pour désactiver les extensions, il suffit de modifier de nom du répertoire plugins dans wp-content – par exemple en le renommant pluginsXXX

    #2449589
    streghe
    Participant
    Padawan WordPress
    51 contributions

    En modifiant le dossier « plugin » en « plugin### »

    j’ai l’erreur suivante

    <b>Deprecated</b>: La fonction register_sidebar_widget est obsolète depuis la version 2.8.0 ! Utilisez wp_register_sidebar_widget() à la place. in <b>/srv/quelqueslignes/wp-includes/functions.php</b> on line <b>5383</b>

    <b>Deprecated</b>: La fonction register_widget_control est obsolète depuis la version 2.8.0 ! Utilisez wp_register_widget_control() à la place. in <b>/srv/quelqueslignes/wp-includes/functions.php</b> on line <b>5383</b>

    <b>Deprecated</b>: La fonction register_sidebar_widget est obsolète depuis la version 2.8.0 ! Utilisez wp_register_sidebar_widget() à la place. in <b>/srv/quelqueslignes/wp-includes/functions.php</b> on line <b>5383</b>

    <b>Deprecated</b>: La fonction register_widget_control est obsolète depuis la version 2.8.0 ! Utilisez wp_register_widget_control() à la place. in <b>/srv/quelqueslignes/wp-includes/functions.php</b> on line <b>5383</b>

    <b>Deprecated</b>: La fonction register_sidebar_widget est obsolète depuis la version 2.8.0 ! Utilisez wp_register_sidebar_widget() à la place. in <b>/srv/quelqueslignes/wp-includes/functions.php</b> on line <b>5383</b>

    <b>Deprecated</b>: La fonction register_widget_control est obsolète depuis la version 2.8.0 ! Utilisez wp_register_widget_control() à la place. in <b>/srv/quelqueslignes/wp-includes/functions.php</b> on line <b>5383</b>

    <b>Deprecated</b>: La fonction register_sidebar_widget est obsolète depuis la version 2.8.0 ! Utilisez wp_register_sidebar_widget() à la place. in <b>/srv/quelqueslignes/wp-includes/functions.php</b> on line <b>5383</b>

    <b>Deprecated</b>: La fonction register_widget_control est obsolète depuis la version 2.8.0 ! Utilisez wp_register_widget_control() à la place. in <b>/srv/quelqueslignes/wp-includes/functions.php</b> on line <b>5383</b>

    <b>Deprecated</b>: Return type of Requests_Cookie_Jar::offsetExists($key) should either be compatible with ArrayAccess::offsetExists(mixed $offset): bool, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in <b>/srv/quelqueslignes/wp-includes/Requests/Cookie/Jar.php</b> on line <b>63</b>

    <b>Deprecated</b>: Return type of Requests_Cookie_Jar::offsetGet($key) should either be compatible with ArrayAccess::offsetGet(mixed $offset): mixed, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in <b>/srv/quelqueslignes/wp-includes/Requests/Cookie/Jar.php</b> on line <b>73</b>

    <b>Deprecated</b>: Return type of Requests_Cookie_Jar::offsetSet($key, $value) should either be compatible with ArrayAccess::offsetSet(mixed $offset, mixed $value): void, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in <b>/srv/quelqueslignes/wp-includes/Requests/Cookie/Jar.php</b> on line <b>89</b>

    <b>Deprecated</b>: Return type of Requests_Cookie_Jar::offsetUnset($key) should either be compatible with ArrayAccess::offsetUnset(mixed $offset): void, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in <b>/srv/quelqueslignes/wp-includes/Requests/Cookie/Jar.php</b> on line <b>102</b>

    <b>Deprecated</b>: Return type of Requests_Cookie_Jar::getIterator() should either be compatible with IteratorAggregate::getIterator(): Traversable, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in <b>/srv/quelqueslignes/wp-includes/Requests/Cookie/Jar.php</b> on line <b>111</b>

    <b>Deprecated</b>: Return type of Requests_Utility_CaseInsensitiveDictionary::offsetExists($key) should either be compatible with ArrayAccess::offsetExists(mixed $offset): bool, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in <b>/srv/quelqueslignes/wp-includes/Requests/Utility/CaseInsensitiveDictionary.php</b> on line <b>40</b>

    <b>Deprecated</b>: Return type of Requests_Utility_CaseInsensitiveDictionary::offsetGet($key) should either be compatible with ArrayAccess::offsetGet(mixed $offset): mixed, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in <b>/srv/quelqueslignes/wp-includes/Requests/Utility/CaseInsensitiveDictionary.php</b> on line <b>51</b>

    <b>Deprecated</b>: Return type of Requests_Utility_CaseInsensitiveDictionary::offsetSet($key, $value) should either be compatible with ArrayAccess::offsetSet(mixed $offset, mixed $value): void, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in <b>/srv/quelqueslignes/wp-includes/Requests/Utility/CaseInsensitiveDictionary.php</b> on line <b>68</b>

    <b>Deprecated</b>: Return type of Requests_Utility_CaseInsensitiveDictionary::offsetUnset($key) should either be compatible with ArrayAccess::offsetUnset(mixed $offset): void, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in <b>/srv/quelqueslignes/wp-includes/Requests/Utility/CaseInsensitiveDictionary.php</b> on line <b>82</b>

    <b>Deprecated</b>: Return type of Requests_Utility_CaseInsensitiveDictionary::getIterator() should either be compatible with IteratorAggregate::getIterator(): Traversable, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in <b>/srv/quelqueslignes/wp-includes/Requests/Utility/CaseInsensitiveDictionary.php</b> on line <b>91</b>

    <b>Warning</b>: Undefined variable $metakeywords in <b>/srv/quelqueslignes/wp-content/themes/fusion/header.php</b> on line <b>19</b>

     

    Je crois qu’il y a des mise à jour à faire, mais je ne sais pas quoi faire

    #2449610
    streghe
    Participant
    Padawan WordPress
    51 contributions

    J’ai pensé créer un nouveau site afin de faire un copier-coller des fichiers qui posent problèmes

    Qu’en pensez-vous ?

     

    #2449611
    Li-An
    Participant
    Maître WordPress
    28351 contributions

    Est-ce que votre thème est à jour ?

    #2449618
    streghe
    Participant
    Padawan WordPress
    51 contributions

    non, ça fait longtemps que je ne m’en occupais plus, ce n’est qu’actuellenent j’ai décidé de m’en occuper

    la version en ligne, fonctionne à merveille mais elles n’est pas à jour

    http://www.quelqueslignes.fr.nf

     

    #2449702
    streghe
    Participant
    Padawan WordPress
    51 contributions

    J’ai créer un autre blog afin d’avoir le fichier « functions.php » contenu dans « wp-includes » afin de l’insérer dans le script de mon site en local quelqueslignes

    le petit soucis étant que les adresses sont tous en « http://localhost/quelqueslignes » alors que mon serveur LAMP de xubuntu 22-04 n’accepte plus  ce genre d’adresse, j’ai dût faire apparaitre mon site à l’adresse « http://quelqueslignes »

    En claire, mon site LAMP est visible uniquement pour moi en « http://quelqueslignes » et j’ai du mal à atteindre la fonction administrateur

    Mon soucis étant, comment dans la base de donnée, modifier toutes les adresses « http://localhost/quelqueslignes » en « http://quelqueslignes » afin que je puisse entrer dans l’administration de mon site ?

    Cordialement

    Streghe

    • Cette réponse a été modifiée le il y a 1 année par streghe.
    #2449725
    streghe
    Participant
    Padawan WordPress
    51 contributions

    J’ai réussis à faire l’opération grâce à ce site

    Comment modifier les URLs WordPress dans la base de données MySQL à l’aide de phpMyAdmin ?

    UPDATE wp_options SET option_value = replace(option_value, 'oldurl.com', 'newurl.com') WHERE option_name = 'home' OR option_name = 'siteurl';UPDATE wp_posts SET guid = replace(guid, 'oldurl.com','newurl.com');UPDATE wp_posts SET post_content = replace(post_content, 'oldurl.com', 'newurl.com'); UPDATE wp_postmeta SET meta_value = replace(meta_value,'oldurl.com','newurl.com');
    Modification URL

    en modifiant ‘oldurl.com » par ‘http://localhost/quelqueslignes&rsquo; et ‘newurl.com’ par ‘http://quelqueslignes&rsquo;

    Dans le fichier config j’ai remplacé

    define(‘WP_HOME’, ‘http://localhost/quelqueslignes&rsquo;);
    define(‘WP_SITEURL’, ‘http://localhost/quelqueslignes&rsquo;);

    par

    define(‘WP_HOME’, ‘http://quelqueslignes&rsquo;);
    define(‘WP_SITEURL’, ‘http://quelqueslignes&rsquo;);

    Le site à fonctionné à nouveau normalement,

    Il m’a été demandé la mise à jour de ma base de donnée

    J’ai put accéder à la partie du back-office et faire les mise à jour des Thème

    Reste les plugins, il m’est signalé une erreur lorsque je réactive les plugins

    akismet
    captcha
    contact-form-7
    easy-post-types
    google-document-embedder
    hello.php
    image-zoomer-fx
    index.php
    menubar
    menubar0
    permalinks-migration-plugin-for-wordpress
    post-tags-and-categories-for-pages
    really-simple-captcha
    revision-control
    revision-diet
    simple-tags
    temp-write-test-1411052893
    tinymce-advanced
    twentyfifteen
    wp-maintenance
    wp-pagenavi
    wp-recaptcha
    wp-user-avatar

     

     

     

     

     

    #2449726
    Li-An
    Participant
    Maître WordPress
    28351 contributions

    Oui mais quelle erreur ? Vous réactivez les extensions une à une ?

    #2449741
    streghe
    Participant
    Padawan WordPress
    51 contributions

    au début j’ai tout réactivé d’un coup,  je n’avais plus mon blog mais une ligne simple

    J’ai désactivé le dossier, créer un autre dossier et insérer un plugin à la fois en faisant à chaque fois une mise à jour du plugin

    aux derniers, j’ai eut un petit soucis, une partie de la bande latéral droit à été supprimé et des messages d’erreurs se sont affichés dans le back-office dans la partie Winget

    Je donnerai les éléments demain

     

    • Cette réponse a été modifiée le il y a 1 année par streghe.
    #2449817
    streghe
    Participant
    Padawan WordPress
    51 contributions

    Voici les erreurs j’ai réactivé la détection des erreurs


    Deprecated: La fonction register_sidebar_widget est obsolète depuis la version 2.8.0 ! Utilisez wp_register_sidebar_widget() à la place. in /srv/quelqueslignes/wp-includes/functions.php on line 5383

    Deprecated: La fonction register_widget_control est obsolète depuis la version 2.8.0 ! Utilisez wp_register_widget_control() à la place. in /srv/quelqueslignes/wp-includes/functions.php on line 5383

    Deprecated: La fonction register_sidebar_widget est obsolète depuis la version 2.8.0 ! Utilisez wp_register_sidebar_widget() à la place. in /srv/quelqueslignes/wp-includes/functions.php on line 5383

    Deprecated: La fonction register_widget_control est obsolète depuis la version 2.8.0 ! Utilisez wp_register_widget_control() à la place. in /srv/quelqueslignes/wp-includes/functions.php on line 5383

    Deprecated: La fonction register_sidebar_widget est obsolète depuis la version 2.8.0 ! Utilisez wp_register_sidebar_widget() à la place. in /srv/quelqueslignes/wp-includes/functions.php on line 5383

    Deprecated: La fonction register_widget_control est obsolète depuis la version 2.8.0 ! Utilisez wp_register_widget_control() à la place. in /srv/quelqueslignes/wp-includes/functions.php on line 5383

    Deprecated: La fonction register_sidebar_widget est obsolète depuis la version 2.8.0 ! Utilisez wp_register_sidebar_widget() à la place. in /srv/quelqueslignes/wp-includes/functions.php on line 5383

    Deprecated: La fonction register_widget_control est obsolète depuis la version 2.8.0 ! Utilisez wp_register_widget_control() à la place. in /srv/quelqueslignes/wp-includes/functions.php on line 5383

    Deprecated: Return type of Requests_Cookie_Jar::offsetExists($key) should either be compatible with ArrayAccess::offsetExists(mixed $offset): bool, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /srv/quelqueslignes/wp-includes/Requests/Cookie/Jar.php on line 63

    Deprecated: Return type of Requests_Cookie_Jar::offsetGet($key) should either be compatible with ArrayAccess::offsetGet(mixed $offset): mixed, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /srv/quelqueslignes/wp-includes/Requests/Cookie/Jar.php on line 73

    Deprecated: Return type of Requests_Cookie_Jar::offsetSet($key, $value) should either be compatible with ArrayAccess::offsetSet(mixed $offset, mixed $value): void, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /srv/quelqueslignes/wp-includes/Requests/Cookie/Jar.php on line 89

    Deprecated: Return type of Requests_Cookie_Jar::offsetUnset($key) should either be compatible with ArrayAccess::offsetUnset(mixed $offset): void, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /srv/quelqueslignes/wp-includes/Requests/Cookie/Jar.php on line 102

    Deprecated: Return type of Requests_Cookie_Jar::getIterator() should either be compatible with IteratorAggregate::getIterator(): Traversable, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /srv/quelqueslignes/wp-includes/Requests/Cookie/Jar.php on line 111

    Deprecated: Return type of Requests_Utility_CaseInsensitiveDictionary::offsetExists($key) should either be compatible with ArrayAccess::offsetExists(mixed $offset): bool, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /srv/quelqueslignes/wp-includes/Requests/Utility/CaseInsensitiveDictionary.php on line 40

    Deprecated: Return type of Requests_Utility_CaseInsensitiveDictionary::offsetGet($key) should either be compatible with ArrayAccess::offsetGet(mixed $offset): mixed, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /srv/quelqueslignes/wp-includes/Requests/Utility/CaseInsensitiveDictionary.php on line 51

    Deprecated: Return type of Requests_Utility_CaseInsensitiveDictionary::offsetSet($key, $value) should either be compatible with ArrayAccess::offsetSet(mixed $offset, mixed $value): void, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /srv/quelqueslignes/wp-includes/Requests/Utility/CaseInsensitiveDictionary.php on line 68

    Deprecated: Return type of Requests_Utility_CaseInsensitiveDictionary::offsetUnset($key) should either be compatible with ArrayAccess::offsetUnset(mixed $offset): void, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /srv/quelqueslignes/wp-includes/Requests/Utility/CaseInsensitiveDictionary.php on line 82

    Deprecated: Return type of Requests_Utility_CaseInsensitiveDictionary::getIterator() should either be compatible with IteratorAggregate::getIterator(): Traversable, or the #[\ReturnTypeWillChange] attribute should be used to temporarily suppress the notice in /srv/quelqueslignes/wp-includes/Requests/Utility/CaseInsensitiveDictionary.php on line 91

    Warning: Undefined variable $metakeywords in /srv/quelqueslignes/wp-content/themes/fusion/header.php on line 19

    pourtant j’ai fait la mise à jour de chaqu’un des plugins  que j’ai réinstallé

    Je réactivais un plugin, il le détectait, je faisais la mise à jour

    dans le back-office section winget

    Le bloc « calendar » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « recent-posts » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « calendar » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « search » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « links » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « tag_cloud » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « fusion-flickr-gallery » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « fusion-twitter-posts » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « fusion-search » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « fusion-categories » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « meta » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « recent-comments » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « recent-posts » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « links » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « links » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « links » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « search » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « calendar » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « meta » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « recent-comments » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « recent-posts » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « links » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « links » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « links » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « search » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « calendar » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « calendar » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « fusion-search » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « recent-posts » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « calendar » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « search » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « links » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « tag_cloud » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « fusion-flickr-gallery » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « fusion-twitter-posts » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.
    Le bloc « fusion-categories » a été affecté par des erreurs et peut ne pas fonctionner correctement. Vérifiez les outils de développement pour obtenir plus de détails.

    Merci de votre aide

    Streghe

    #2449821
    streghe
    Participant
    Padawan WordPress
    51 contributions

    Ce qui est fastidieux et pénible sur ce forum, c’est qu’il est impossible de faire une modification à partir d’un certain temps, sur d’autre site, les modifications sont possibles à tous moments (ubuntu-fr.org, debian-facile.org…)

    Je vous voulais ajouter que en cas de nécessité, je me suis créer un nouveau site entièrement fait avec la dernière version de wordpress afin de récupérer les dossiers « wp-content » et « wp-includes » et leur fichier sans les plugins au cas où un échange de fichier serait nécessaire

    supprimer l’ancien fichier pour le remplacer par le nouveau émanant de deux version de wordpress différentes

    #2449822
    C_Lucien
    Modérateur
    Maître WordPress
    5116 contributions

    Bonjour,

    d’après les messages d’erreur, vous avez des éléments d’une ancienne installation de WordPress encore présents. Si les mises à jour ont été faites régulièrement, c’est anormal.

    Mon fichier /wp-include/functions.php se termine par ces lignes

    * @since 6.0.0
    *
    * @param array $array The array to sort, passed by reference.
    */
    function wp_recursive_ksort( &$array ) {
    foreach ( $array as &$value ) {
    if ( is_array( $value ) ) {
    wp_recursive_ksort( $value );
    }
    }
    ksort( $array );
    }

    Vous pouvez, à partir d’une archive fraîche de WordPress, écraser les deux dossiers wp-includes et wp-admin, ainsi que les fichiers *.php à la racine sauf wp-config.php. Le dossier wp-content et le fichier wp-config.php sont à conserver absolument.

    il est impossible de faire une modification à partir d’un certain temps

    De mémoire, c’est une mesure destinée à protéger le contenu des discussions contre les effacements à postériori que certains pratiquent après avoir obtenu leur réponse. Pratique qui aurait pour conséquence de vider le forum de ce qui constitue une base de connaissance.

    Par contre, j’ai oublié le délai accordé pour les modifications –ou je ne l’ai jamais su…

15 sujets de 1 à 15 (sur un total de 23)
  • Vous devez être connecté pour répondre à ce sujet.