[Résolu] Icone « loupe » devenu « fl »

  • WordPress :4.9.4
  • Statut : résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #2157477
    Salomé
    Participant
    Initié WordPress
    29 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : Avada
    • Extensions en place : BackUpWordPress, Contact Form 7, Custom Hooks, FacetWP, Fusion Builder, Fusion Core, Images de catégories, Loco Translate, Show Current Template, WP CSV, WP-Optimize, WPML Multilingual CMS
    • Nom de l’hébergeur : OVH
    • Adresse du site : http://www.lciballast.com/

    Problème(s) rencontré(s) :

    Bonjour,

    Depuis quelques jours, l’icone « loupe » de la barre de recherche (en haut à droite du site) a sauté pour laisser place aux lettres « fl »

    Avez-vous déjà rencontré ce problème et sauriez vous me dire commet y remédier svp ?

    D’avance merci

    Salomé

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2158061
    momofr@free.fr
    Modérateur
    Maître WordPress
    1712 contributions

    Salut, tu utilises le thème Premium Avada, je t’invite à contacter le support de ce thème qui répondra à ta question.

    #2171652
    Salomé
    Participant
    Initié WordPress
    29 contributions

    Bonjour,

    Je suis toujours bloqué avec ce problème, car le support de mon thème a expiré.

    J’ai contacté le développeur que j’avais engagé l’année dernière pour m’aider à modifier le site, et il s’avère qu’il avait lui-même importer un autre icône pour la barre de recherche. C’est pour ça que l’icône « saute » lorsque je mets à jour mon thème. À savoir que j’avais déjà installé un thème enfant/parent.

    Ce problème d’icône était déjà survenu l’année dernière d’ailleurs, mais malheureusement à ce jour la garantie de 3 mois du développeur en question est expirée, je dois repayer une heure de travail pour qu’il me remette mon icône. Autant le dire clairement, je n’ai pas envie de payer cette somme tous les 4 mois, ça ne résout pas le problème sur le long terme. :/

    Si vous avez une solution, une idée, une piste, je vous en serais reconnaissante 🙂

    Belle journée à tous

    • Cette réponse a été modifiée le il y a 2 weeks et 1 day par  Salomé.
    • Cette réponse a été modifiée le il y a 2 weeks et 1 day par  Salomé.
    #2171720
    momofr@free.fr
    Modérateur
    Maître WordPress
    1712 contributions

    Salut, si le thème est personnalisé ce n’est évident de t’aider, déjà je note que c’est un symbole FontAwesome (police de symboles embarquée dans le thème Avada).

    Si l’on regarde comment sont chargées les icônes FA dans Avada ce n’est pas comme le code ton bouton donc ça ressemble en effet à du « bricolage » et là sans avoir accès au code pas facile de savoir comment c’est réalisé.

    Si tu as une thème enfant il faut essayer d’ajouter dans une copie du fichier header.php l’appel au CDN FA avec ce lien :

    <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.0.4/css/all.css" integrity="sha384-DmABxgPhJN5jlTwituIyzIUk6oqyzf3+XuP7q3VfcWA2unxgim7OSSZKKf0KSsnh" crossorigin="anonymous">

    Pas sûr que ça marche.

    #2172083
    Salomé
    Participant
    Initié WordPress
    29 contributions

    Salut Momo, merci pour ton aide. Oui j’ai un thème enfant mais malheureusement, pas de changement en rajoutant ça dans le fichier header.php

    Effectivement il s’agit d’un symbole  FontAwesome, et justement il semblerait que le problème soit survenu après la mise a jour de FA V4 à la V5.

    Je pensais à quelque chose comme réimporter les bibliothèques ?
    Notre développeur nous a dit qu’il faut changer la syntaxe utilisée dans les parties qu’il avait ajouté.

    J’attends ton retour, si effectivement ça paraît compliqué à gérer, je lui demanderais de s’en charger.

    #2172084
    momofr@free.fr
    Modérateur
    Maître WordPress
    1712 contributions

    Salut, Avada gère les FA avec des classes CSS :

    <i class="fas fa-search"></i>

    Il faudrait déjà que le bouton soit sur cette classe fa-search mais je pense que ça fonctionnera très bien avec un lien « a« .

    #2172093
    PhiLyon
    Modérateur
    Maître WordPress
    19647 contributions

    Bonjour.

    Les bibliothèques sont bien importées, plus bas dans ta page tu en as 3, dont la loupe.

    🙂

    #2172094
    Salomé
    Participant
    Initié WordPress
    29 contributions

    J’ai essayé de mettre ça en CSS mais ça ne change rien :/

    #2172120
    momofr@free.fr
    Modérateur
    Maître WordPress
    1712 contributions

    Salut, vu que tout cela est déjà du bricolage tu peux outrepasser l’icône FA avec une simple image en arrière-plan par exemple avec ceci :

    #menu-menu-principal .searchform .search-table .search-button input[type="submit"] {
    	text-indent: -5000px;
    	background: url(https://danishmodernla.com/assets/images/magnifying_glass.png) no-repeat center center / 50% white !important;
    }

    L’URL de l’icône est en dur, il te faudrait une icône placée dans ton thème enfant plutôt (url relative alors).

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2172130
    Salomé
    Participant
    Initié WordPress
    29 contributions

    Malheureusement ce n’est pas vraiment une solution car l’icône est aussi décalé, quand l’icône à sauté l’apparence de la barre de recherche à également changé. J’ai réussi à trouver une ancienne capture d’écran afin que vous puissiez voir la différence.

    Merci beaucoup pour votre aide, je vais demander à notre developer de s’en occuper, c’est trop compliqué de savoir ce qu’il a bricolé et comment le reproduire.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2172214
    momofr@free.fr
    Modérateur
    Maître WordPress
    1712 contributions

    Entièrement d’accord et vu ce que je vois en code ce n’est pas fait au plus simple.

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.