HTTP Error 500 (Créer un compte)

  • WordPress :6.1
  • Statut : non résolu
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #2431672
    cyberkate
    Participant
    Initié WordPress
    19 contributions

    Bonjour,

    Je fais appel à vous car, du jour au lendemain, l’un de mes sites affiche une erreur HTTP 500. J’ai eu beau modifier le fichier .htaccess ainsi que faire évoluer la configuration PHP, rien n’y fait.

    Ma configuration WP actuelle :

    Problème(s) rencontré(s) :
    <h1>Cette page ne fonctionne pas</h1>
    Impossible de traiter cette demande via http://www.telechargement-donnees-chronotachygraphe.fr à l’heure actuelle.
    <div id= »error-information-popup-container »>
    <div id= »error-information-popup »>
    <div id= »error-information-popup-box »>
    <div id= »error-information-popup-content »>
    <div class= »error-code »>HTTP ERROR 500</div>
    </div>
    <div>Merci d’avance pour votre aide. :)</div>
    </div>
    </div>
    </div>

    #2431690
    Flobogo
    Modérateur
    Maître WordPress
    18887 contributions

    Bonjour,

    Pour commencer à vous dépanner, passez par FTP (Filezilla ou équivalent) ou par le gestionnaire de fichiers de votre hébergeur, et désactivez toutes les extensions en renommant le sous-dossier wp-content/plugins (avec -X à la fin, par ex.). Si cela vous redonne accès  au tableau de bord, renommez ensuite le dossier plugins normalement, cela vous permettra de réactiver les extensions.

    Si ça ne vous redonne pas accès, faites la même chose pour le thème en renommant le sous-dossier wp-content/themes/divi. Et réessayez.

    Si vous n’avez toujours pas accès, contactez votre hébergeur, car les erreurs 500 viennent assez souvent d’un problème serveur.

    Au fait, dites-nous ce que vous avez fait comme modif’ sur le fichier .htaccess.

    #2432067
    cyberkate
    Participant
    Initié WordPress
    19 contributions

    Bonsoir,

    Merci pour votre aide.

    J’ai renommé le sous dossier « plugin » ainsi que le thème « divi » mais j’ai toujours le même souci. Et l’hébergeur me dit que le problème n’est pas de son ressort en me donnant des liens vers des documentations qui ne résolvent pas le problème… 🙁

    Concernant le fichier .htaccess initial, le voici :

     

    
    # BEGIN WordPress
    # Les directives (lignes) entre « BEGIN WordPress » et « END WordPress » sont générées
    # dynamiquement, et doivent être modifiées uniquement via les filtres WordPress.
    # Toute modification des directives situées entre ces marqueurs sera surchargée.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    #Bloquer l'indexation des fichiers Word et PDF
    <files ~ "\.(doc|docx|pdf)$">
    Header set X-Robots-Tag "noindex, nofollow"
    </Files>

     

    Je l’ai renommé pour le désactiver mais cela ne change rien.

    J’ai ensuite récupéré le fichier .htaccess mentionné dans ce tutoriel, mais cela ne change rien : https://www.hostinger.fr/tutoriels/htaccess-wordpress

    Merci beaucoup pour toute l’aide que vous pourrez m’apporter. 🙂

    Bonne soirée à vous

     

    #2432077
    Flobogo
    Modérateur
    Maître WordPress
    18887 contributions

    Bon, on va essayer autre chose : c’est peut-être une mise à jour de WordPress qui s’est mal passée, cela arrive parfois avec OVH.

    Donc, il faut faire une mise à jour manuelle, en suivant ces instructions détaillées. Téléchargez la dernière version de WordPress ici : en principe, pour vous, c’est la 6.1.1, mais si vous pensez que vous aviez une version inférieure, essayez avec la dernière proposée selon la décimale (exemple : prenez 6.0.3 si vous étiez en 6.0.x.)

    Et surtout, n’oubliez pas de faire avant les sauvegardes suivantes :

    • par FTP ou par le gestionnaire de fichiers → le dossier wp-content complet + le fichier wp-config.php + le fichier .htaccess
    • par PhpMyAdmin → sauvegarde de la base de données, selon ce tuto
    #2432429
    cyberkate
    Participant
    Initié WordPress
    19 contributions

    Bonjour,

    J’ai suivi tous vos conseils, et il y a du mieux. 🙂

    Le site est désormais visible, j’ai mis à jour les fichiers sur le FTP ainsi que la base de données.

    Toutefois, j’ai des bugs d’affichage lors de ma connexion au back office. Certains textes ne s’affichent pas (cf. captures d’écran). Auriez-vous une idée svp ?

    Merci à vous

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2432447
    Flobogo
    Modérateur
    Maître WordPress
    18887 contributions

    Effectivement, c’est déjà mieux 😉

    Essayez avec un thème par défaut (thème Twenty-quelque-chose), et désactivez aussi toutes les extensions (sauf Akismet ou autre extension anti-spam). Est-ce que ça change quelque chose ?

    Au fait, avez-vous bien la dernière version de Divi ? Et vos extensions sont-elles à jour ?

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.