HELP !! bug ou vrai problème de sécurité? (Créer un compte)

  • WordPress :5.8
  • Statut : non résolu
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #2393843
    Jerome218
    Participant
    Initié WordPress
    30 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4.25 / 5.6.50-log
    • Version WP ! 5.8.2
    • Thème utilisé : maison sur une base
    • Extensions en place : entre autre all in one security and firewall, CPT UI, ACF Pro…
    • Nom de l’hébergeur : OVH
    • Adresse du site :

    Problème(s) rencontré(s) :

    Depuis la dernière mise à jour  (-> 5.8.2) je ne dispose plus de certains droits… bien qu’étant le seul compte et administrateur (j’ai vérifié mon wp_users)  je ne peux plus ajouter de plugin ni de thème (pas de menu ou de bouton ajouter) mais je peux ajouter des comptes et des contenus…

    Je en peux pas faire la mise à jour vers 5.8.3, le système me demande même d’informer l’administrateur du site…

    Avez-vous une idée ou un conseil  pur que je récupère les droits?

    Merci !!

     

    #2393858
    Flobogo
    Modérateur
    Maître WordPress
    18338 contributions

    Bonjour,

    Si vous savez accéder à votre installation par FTP (Filezilla), vous allez dans wp-content > plugins, et vous renommez le dossier en plugins-X. Cela les désactivera tous d’un seul coup. Si ça vous redonne un accès normal à l’admin’, il suffira de renommer le dossier correctement, pour ensuite, allez dans votre admin et réactiver les extensions une par une.

    Si cette 1ère manipulation ne donne rien, faites de même pour votre thème, en renommant son dossier : wp-content > themes > nom-du-theme-X. Là encore, si ça vous redonne accès à l’admin, il faudra ensuite renommer le dossier du thème normalement.

    Ensuite, essayez une mise à jour manuelle en WP 5.8.3, toujours par FTP, après avoir sauvegardé votre base de données.

    Vous pouvez aussi vérifier dans votre base de données si vous êtes toujours administrateur, en suivant ces conseils donnés ailleurs par @ferman :

    il faut aller dans phpmyadmin, table wp_options et chercher la ligne wp_user_roles (la 3e ou 4e page). Double cliquez sur la case option_value (cliquez droit dans cette case, sélectionnez tout, puis copiez) ressortez et collez le texte dans bloc notes. Comparez-le à  ce que vous voyez ici . Si vous n’avez aucun plugin qui écrit dans la base de données, (si ça commence par a:5:) les deux textes doivent être identiques . Vous pourriez déjà vérifier ça (si c’est ça la solution est simple).

2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.