[Résolu] Gros soucis – activer plugin… (Créer un compte)

  • WordPress :5.5
  • Statut : résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #2357292
    jujutou
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.3 – MySQL Community Server (GPL)
    • Thème utilisé : Academica Pro 3.0
    • Extensions en place : ACF Pro/qTransltate/widgets, caldera forms, classic editor, form manager, SEO, Mailpoet 3, Popup Maker, Q-translateX, WPZoom, the evetn calendar (+pro), tinyMCE advanced, Updraftplus, Use Role editor, WP MCM, WP page navi, zotpress, WP Fast, updraftplus
    • Nom de l’hébergeur : CNRS – renater?
    • Adresse du site : http://cri1149.fr/

    Problème(s) rencontré(s) :

    Bonjour,

    J’ai un gros soucis avec le site web, je commence par le début

    1. Notre site était très lent et la page des extensions installés beugais car m’affichait
      “Service Unavailable”
      The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.””
      Alors que tout le reste fonctionne !
    2. Donc je me suis dis qu’il y avait une extension qui fait planter tout ça.
    3. J’en désactive, 2 -3 (dont ceux qui avait des log d’erreur) mais aucune amélioration.
    4. Je décide de désactiver toutes les extensions … et la le site inaccessible et l’interface admin wordpress inaccessible non plus.
    5. Donc je vais sur le FTP pour renommer et réactiver le dossier plugin. Il ne se passe rien …
    6. J’active le mode “recovery” de wordpress, et là j’accède à l’interface admin wordpress, mais le même beug recommence et donc je ne peux pas utiliser cette interface pour réactiver mes extensions. (le site est inaccessible sans les extensions).
    7. J’ai essayé de les réactiver via FTP, via PHPmyadmin et via function.php mais il ne se passe rien … (je ne suis pas sûr d’avoir fait les bonnes commandes car je m’y connais pas trop trop …)

    Du coup je suis avec un site dont l’écran est blanc et je n’ai plus de solution pour activer mes extensions…

    Pouvez vous m’aider, svp ? Je suis un peu perdu …

    Merci !

    #2357320
    jujutou
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    maintenant le site m’envoie l’erreur :
    <h1>Forbidden</h1>
    You don’t have permission to access / on this server.

     

    Comment réactiver les plugins quand on a pas accès a l’interface wordpress des extensions ??

    J’ai essayé par FTP mais pas de succès.

    Via PHPmyadmin, mon fichier “active_plugin” est complètement différent de ce que l’on trouve sur internet … donc je n’ose pas y touche sans faire de bêtise …

    Merci de votre aide …

    #2357323
    Li-An
    Modérateur
    Maître WordPress
    24425 contributions

    Bonjour, ce que vous nous racontez ressemble plus à un problème serveur qu’un problème WP. Il faut voir avec l’hébergeur.

    #2357326
    jujutou
    Participant
    Initié WordPress
    14 contributions

    Bonjour,
    Merci pour votre réponse.

    Le soucis est que le problème a commencé par mon intervention, en voulant désactiver les plugins, je me suis retrouvé dans l’incapacité de les réactiver.

    Puis le thème c’est mis a ce désactiver également (je ne sais pas pourquoi).

    Et seulement ce matin (sans rien faire), cet erreur 403…

    Je vais les contacter, mais j’ai la sensation qu’ils ne vont pas pouvoir agir …

    #2357327
    Li-An
    Modérateur
    Maître WordPress
    24425 contributions

    Est-ce que vous avez des sauvegardes de la base de données ? Vous ou l’hébergeur ? Il faudrait pouvoir réimporter le contenu de la base d’avant le problème.

    Vous pouvez essayer de faire une réparation/optimisation de la base de données via phpMyadmin et allez par FTP au niveau du répertoire wp-content/plugins et changez son nom en pluginsxxx pour désactiver toutes les extensions. Même chose pour le thème dans wp-content/themes/nom-du-theme – comme ça on sera sûr que tout est désactivé. Et réessayez.
    Pour retrouver les extensions et le thème, il suffira de remettre les noms par défaut des répertoires.

    Ça donne l’impression que votre base de données a eu un coup de chaud. Vérifiez aussi que vous n’avez pas atteint votre quota de volume base de donnée et/ou fichiers.

    • Cette réponse a été modifiée le il y a 3 semaines et 3 jours par Li-An.
    #2357397
    jujutou
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    J’ai des sauvegarde FTP mais pas de PHPmyadmin … J’ai contacté l’hébergeur afin de savoir s’ils ont une sauvegarde. voir s’il peuvent faire une restauration.

    J’ai effectué vos démarches,  mais pas de retour à la normal …

    Néanmoins l’interface recovery revient avec le mail de WordPress disant que l’extension qtranslate-x pose soucis.

    Sur cette interface, les extensions et thème n’arrive pas à s’activer, j’obtiens les messages suivants :

    Le chargement d’une ou plusieurs extensions a échoué.
    Vous pouvez trouver davantage de détails et faire des modifications sur l’écran des extensions.”

    Un ou plusieurs thèmes ont échoués à se charger correctement.
    Vous trouverez plus de détails et pouvez apporter des modifications sur l’écran des thèmes.”

    J’ai beau relancer le thème, il continue a planter.

    Et impossible d’accéder à la page des extensions, elles plante, j’obtiens le message “erreur 503 : service indisponible”

    Je ne sais plus quoi faire a part attendre la réponse de l’hébergeur …

     

    Pour le quota de donnée, il faut aussi que je vois avec l’hébergeur j’imagine !?

    #2357414
    Li-An
    Modérateur
    Maître WordPress
    24425 contributions

    Normalement oui si vous n’avez pas une page dédiée pour vérifier ce genre de choses.

    #2357782
    jujutou
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    Pour vous tenir au courant :

    Nous avons récupéré notre thème, qui a réussi à s’activer. Nous avons donc récupéré une partie de notre site.

    En revanche, les extensions sont toujours désactivé, et la page “extensions installés” renvoie toujours vers le message

    ““Service Unavailable”
    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.”

    Sans ces plugins, la moitié de notre site web n’est pas utilisable … J’ai relancé l’hébergeur afin qu’il voit de son côté s’il n’y a pas quelque chose qui coince.

    Notre hébergement a reçu des attaques en rapport a l’actualité, ce qui en est peut être la cause (mais le problème existait avant ces attaques donc bon …)

    Je vous tiendrais au courant de la suite.

    #2360257
    jujutou
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    Pour mettre à jour mon problème !

    Notre hébergeur a enfin pris le temps de voir ce qui n’allait pas … Il s’agit en faite d’un problème du plugin Qtranslate (obsolète depuis 4 ans) avec surement une mise à jour WordPress. De même le plugin “the events calendar” semblait poser des problèmes.

    Ils ont donc remplacé le plugin Qtranslate par le Qtranslate-XT, et les problèmes ce sont résolu ! Site web plus rapide et page d’extensions de nouveau accessible.

    Donc problème résolu !

    Néanmoins, je trouve l’administration du site vraiment “bordélique” et pas optimal …
    Pour les langues Français/anglais, il y a deux onglets page wordpress, et dans les cadre de zone de texte, il y a également 2 onglets Fr/En.
    Ainsi, si on sélectionne la langue principale FR mais que dans les cadres ont met EN, aucun texte n’apparait… De même parfois, certains texte disparaissent sans raison … Enfin bon c’est galère.

    Le problème est que j’ai l’impression que le plugin Qtranslate est hyper imprégné dans le code de notre thème. Car dès qu’on désactive le plugin, c’est l’écran blanc, tout le site entier plante …

    Donc ça m’a l’air compliqué a améliorer tout ça sans tout cassé …

    Vous connaissez des plugins “simple” qui permettent d’avoir deux langues sur notre site web ?

     

    Autrement mon autre question :

    Est-ce qu’il est possible de créer un 2ème thème (le même que l’actuelle par exemple) sans le rendre actif/public afin de réaliser toutes les modifications que l’ont souhaite sans cassé le site et une fois que tout est en place, de switch vers cette nouvelle configuration du thème ?

    En faite, j’aimerais reprendre le thème à zéro pour repartir sur des bases saines, faire toutes les modifications tranquillement (ça risque de prendre du temps) pendant que l’ancien thème reste actif, et quand je serais satisfait de ma configuration, de le remplacer par mon nouveau thème ?

    Merci !

     

    #2360259
    C_Lucien
    Modérateur
    Maître WordPress
    4420 contributions

    Bonjour,

    vous pourriez installer une configuration parallèle de WordPress, dans un sous-domaine, pointant vers un dossier dédié.

    Ou l’installer sur un environnement local avec les “piles” les plus populaires pour votre système LAMP, MAMP, XAMPP,… voire Local by FlyWheel.

    Pour le problème de langue, c’est un autre sujet, mieux vaut ouvrir une nouvelle discussion avec un titre significatif.

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.