Google, sitemaps et indexation ? (Créer un compte)

  • Statut : non résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #477327
    Ryuuketsu
    Participant
    Initié WordPress
    39 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.9
    – Thème utilisé : Mystique
    – Extensions en place : quelques unes dont “Google XML Sitemaps”
    – Nom de l’hebergeur : Free.fr
    – Adresse du site : http://ryuuk3tsu.free.fr

    Problème(s) rencontré(s) :

    Bonjour à tous, je rencontre depuis peu un petit souci avec mes sitemaps
    Lorsque je vais dans les outils webmaster google, je vois le message d’erreur suivant concernant mon sitemap

    Nous avons rencontré une erreur en essayant d’accéder à votre sitemap. Assurez-vous que votre sitemap est conforme aux consignes et qu’il est accessible à l’emplacement que vous avez spécifié. Ensuite, essayez de nouveau.

    Avant je n’avais pas de soucis, mais depuis peu ça ne fonctionne plus, idem sur mon autre blog qui fonctionnait nickel jusque là. J’avais pensé que ça pourrait être du à mon fichier robots.txt qui refuse l’indexation de sitemap.xml, mais la ligne est commentée ?

    #Disallow: /sitemap.xml

    Ce qui m’a mis la puce à l’oreille c’est que malgré quelques articles, quelques visites par jour, le blog n’est pas du tout référencé

    Vous auriez une idée de comment m’y prendre ?

    #706807
    Li-An
    Modérateur
    Maître WordPress
    24378 contributions

    Je suppose que le sitemap est créé par un plugin ? Si c’est le cas, cf. les nombreux sujets à propos de WP2.9 et du plugin en question. Si c’est autre chose, préciser comment est créé le sitemap.

    #706808
    Ryuuketsu
    Participant
    Initié WordPress
    39 contributions

    Merci Li-An

    J’ai tenté d’effectuer une recherche, mais il m’est impossible d’aller a la deuxième page des résultats. Le problème n’est pas au niveau de la création du sitemaps, mais plutôt je pense de son acceptation par goole. Le sitemaps présent sur mon site est bon et à jour, mais google me dit qu’il a un problème pour y accèder

    #706809
    Li-An
    Modérateur
    Maître WordPress
    24378 contributions

    Peut-être un problème avec Free…

    #706810
    Ryuuketsu
    Participant
    Initié WordPress
    39 contributions

    C’est apparu il y a environ 3semaines, pas exclusivement sous la 2.9 . Je ne sais pas trop d’où ça pourrait venir, le message d’erreur n’est pas très explicite :s

    #706811
    Lumiere de Lune
    Participant
    Maître WordPress
    19367 contributions

    Tu as dans GWT une page qui te permet de tester si ton robots.txt permet d’accéder ou pas à un fichier donné.

    #706812
    Ryuuketsu
    Participant
    Initié WordPress
    39 contributions

    Merci Lumiere de Lune
    J’avais déjà utilisé cette page pour tester mon robots.txt avant de le mettre en place. Mais j’ai des doutes concernant son efficacité, étant donné que j’avais interdit l’accès à la page “a propos’ de mon blog, et que c’est la seule page qui s’est trouvée indexée, d’autant plus que j’avais interdit toute indexation à cette époque là

    En tout cas, le lien vers mon sitemap est bien autorisé pour googlebot et valide

    #706813
    Lumiere de Lune
    Participant
    Maître WordPress
    19367 contributions

    L’indexation et le robots c’est deux choses différentes.
    Le robot interdit le crawl. En revanche, si google trouve une page par un lien il va éventuellement l’indexer (mais pas en crawler le contenu)
    Le seul moyen pour éviter d’être indexé, c’est le no-index

    Cela dit, il est possible qu’il y ait eu des problèmes de disponibilité 🙂

    #706814
    Ryuuketsu
    Participant
    Initié WordPress
    39 contributions

    Merci pour les explications lumiere de lune
    En fait la page indexée n’était présente sur aucun lien sur internet, c’est bien ce qui me parait bizarre. En ce qui concerne le souci, vraiment je ne vois pas d’où ça pourrait venir. Je réessaie d’envoyer le fichier manuellement sur les outils webmaster google, ça fonctionne, mais après lors de la “reconnaissance” automatique, ça coince à nouveau :(

    #706815
    Ryuuketsu
    Participant
    Initié WordPress
    39 contributions

    Bonjour, excusez moi je remonte le sujet, j’ai eu beau chercher je n’ai pas trouvé de solution
    Aujourd’hui l’erreur est bien sur revenue

    #706816
    marie_mada
    Membre
    Maître WordPress
    531 contributions

    et si dans ton robots.txt tu mets :

    User-agent: *
    Disallow: /cgi-bin
    Disallow: /wp-admin
    Disallow: /wp-includes
    Disallow: /wp-content
    
    
    User-agent: Mediapartners-Google
    Allow: /
    
    User-agent: Adsbot-Google
    Allow: /
    
    User-agent: Googlebot-Image
    Allow: /
    
    User-agent: Googlebot-Mobile
    Allow: /
    
    #User-agent: ia_archiver-web.archive.org
    #Disallow: /
    
    Sitemap: http://www.tonsite.com/sitemap.xml

    en plus ?
    moi je fais cela et du coup dans google
    il marque :

    Ligne 23 : Sitemap: http://www.monsite.com/sitemap.xml Référence à un plan Sitemap valide détectée

    ciao

    #706817
    Ryuuketsu
    Participant
    Initié WordPress
    39 contributions

    Merci Marie_Mada
    En fait j’ai déjà référence à un fichier sitemap valide qui est affiché… Le problème ne vient malheureusement pas du robots.txt…

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.