Garder lecture musique quad je navigue (Créer un compte)

  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #526165
    Telerias
    Membre
    Initié WordPress
    49 contributions

    Bonjour,

    J’ai récemment installé un lecteur musical sur mon WP => http://wordpress.org/plugins/stratus/
    J’aimerais que lorsque la page se recharge ou si je navigue sur le site la lecture reste, sauf que ce n’est pas le cas. Pourtant, même si la FAQ du plug-in indique que ce n’est pas possible, sur ce site ils ont exactement le même lecteur sans les problèmes énoncés ! http://turborecordings.com/

    Avez-vous une idée de la manière de procéder ? Merci d’avance !

    Ma configuration WP actuelle
    – Version de WordPress : 3.5.2
    – Version de PHP/MySQL :
    – Thème utilisé : Backstreet
    – Extensions en place :
    – Nom de l’hebergeur : TMDHosting
    – Adresse du site :

    Problème(s) rencontré(s) : http://www.boxonrecords.com/ (maintenance)

    #902180
    Li-An
    Participant
    Maître WordPress
    28431 contributions

    Vous devriez essayer avec l’original: http://stratus.sc/

    #902181
    Telerias
    Membre
    Initié WordPress
    49 contributions

    J’avais pensé à ça en effet, sauf que je n’arrive pas à l’installer : comme indiqué sur ce lien j’ai ajouté dans header.php entre les :

    $(document).ready(function(){
    $.stratus({
    links: ‘http://soundcloud.com/foofighters/sets/wasting-light’
    });
    });

    Et aucun lecteur n’apparaît. Même quand je clique sur mes lien comportant la class= »stratus » …?

    #902182
    Li-An
    Participant
    Maître WordPress
    28431 contributions

    J’y connais queue de chie en javascript. Y’a quelqu’un qui avait le mm problème que vous qui l’a résolu ici: http://stackoverflow.com/questions/14448837/stratus-player-soundcloud-api-non-stop-play

    #902183
    Telerias
    Membre
    Initié WordPress
    49 contributions

    Ah nickel merci ça a l’air d’être la bonne solution ! Ca a même l’air simple sur le papier, donc du coup mon soucis est différent : comment recharger juste la div de contenu quand on clique sur un lien. J’ai donc activé le plug-in et indiqué la div qui englobe tout le contenu (la mienne c’est : class= »container_12 wrapper », j’ai donc juste mis wrapper c’est eut être ça le soucis)…et ça ne marche pas, quand je clique sur un lien aucune page ne se charge (normal) mais aucun contenu non plus…

    Peut être est-ce parce que j’ai zappé la 5ème étape que je n’ai pas compris

    Merci de votre aide, je sens qu’il ne reste plus grand chose !

    #902184
    Telerias
    Membre
    Initié WordPress
    49 contributions

    Alors, je rectifie : j’ai tout englobé sauf le header et le footer de dans div id= »content » dans le fichier index.php. Et ça marche, des fois : sur certaines pages ça fonctionne (et du coup le problème du lecteur résolu), mais souvent le chargement des pages est très long, et parfois certaines ne s’affichent pas

    #902185
    Li-An
    Participant
    Maître WordPress
    28431 contributions

    Il faudrait éventuellement vérifier qu’il n’y ait pas d’interférence avec d’autres plugins et le thème.

    #902186
    Telerias
    Membre
    Initié WordPress
    49 contributions

    Comment je peux repérer de telles interférences ?

    Parmi les pages qui ne marchent pas certaines que j’ai créé sur wordpress et que j’ai codé entièrement dans la zone texte. Mais pourtant ma div content devrait tout englober puisque je l’ai précisé dans index.php, peut être dois-je mettre manuellement cette div ailleurs ?

    #902187
    Li-An
    Participant
    Maître WordPress
    28431 contributions

    Ben en désactivant les plugins et en mettant un thème par défaut, vous pourrez vous faire une idée. Sinon, je n’ai pas d’idée particulière pour vous aider plus.

    #902188
    Telerias
    Membre
    Initié WordPress
    49 contributions

    Bien vu, quand je mets un thème de base ça marche nickel ! Du coup c’est mon thème Backstreet qui marche moyen avec. Du coup c’est peut être ma div qui est mal mise, ou je ne sais quoi d’autre ?

    #902189
    Li-An
    Participant
    Maître WordPress
    28431 contributions

    Peut être le javascript utilisé par le thème… Il faudrait voir avec le concepteur. Et en effet, y’a peut-être aussi des balises div qui se referment dans d’autres fichiers mais bon…

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.